aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2001-08-23 07:47:23 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2001-08-23 07:47:23 +0000
commit7265c072b36b2ef90ec375271a38578178b2f4f2 (patch)
tree5d9a20284752553e818736cb3568ee863e7d1b6d /ports-mgmt
parentd6cae5eecf103a528514027a68424d176d1831ce (diff)
downloadports-7265c072b36b2ef90ec375271a38578178b2f4f2.tar.gz
ports-7265c072b36b2ef90ec375271a38578178b2f4f2.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portupgrade-devel/Makefile6
-rw-r--r--ports-mgmt/portupgrade/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/ports-mgmt/portupgrade-devel/Makefile b/ports-mgmt/portupgrade-devel/Makefile
index 8fb3e616228b..11e74a58ba61 100644
--- a/ports-mgmt/portupgrade-devel/Makefile
+++ b/ports-mgmt/portupgrade-devel/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20010823
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
@@ -49,7 +50,10 @@ DOCS= ChangeLog README
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
post-patch:
- ${RUBY} -i -pe 'sub %r:/usr/local:, "${LOCALBASE}"' ${WRKSRC}/pkgdb.rb
+.for f in pkgdb.rb pkgtools.rb
+ ${RUBY} -i~ -pe 'sub %r:/usr/local:, "${LOCALBASE}"' ${WRKSRC}/${f}
+.endfor
+ ${RUBY} -i~ -pe 'sub %r:(PORTS_DBDIR = .* )PORTSDIR$$:, "\\1PORTS_DIR"' ${WRKSRC}/portsdb.rb
do-install:
cd ${WRKSRC} && ${RUBY} install.rb
diff --git a/ports-mgmt/portupgrade/Makefile b/ports-mgmt/portupgrade/Makefile
index 8fb3e616228b..11e74a58ba61 100644
--- a/ports-mgmt/portupgrade/Makefile
+++ b/ports-mgmt/portupgrade/Makefile
@@ -7,6 +7,7 @@
PORTNAME= portupgrade
PORTVERSION= 20010823
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.iDaemons.org/distfiles/
@@ -49,7 +50,10 @@ DOCS= ChangeLog README
EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
post-patch:
- ${RUBY} -i -pe 'sub %r:/usr/local:, "${LOCALBASE}"' ${WRKSRC}/pkgdb.rb
+.for f in pkgdb.rb pkgtools.rb
+ ${RUBY} -i~ -pe 'sub %r:/usr/local:, "${LOCALBASE}"' ${WRKSRC}/${f}
+.endfor
+ ${RUBY} -i~ -pe 'sub %r:(PORTS_DBDIR = .* )PORTSDIR$$:, "\\1PORTS_DIR"' ${WRKSRC}/portsdb.rb
do-install:
cd ${WRKSRC} && ${RUBY} install.rb