aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-11-05 13:49:10 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-11-05 13:49:10 +0000
commit27dd4c4aefaf5190de16cd2e5d7577cd2e2d584f (patch)
treee5f096e7d8e7ee796cfceff01b510575a581b378 /ports-mgmt
parentd9411bb1cbe484818176c0921e700c24f5461e12 (diff)
downloadports-27dd4c4aefaf5190de16cd2e5d7577cd2e2d584f.tar.gz
ports-27dd4c4aefaf5190de16cd2e5d7577cd2e2d584f.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmanager/Makefile49
-rw-r--r--ports-mgmt/portmanager/distinfo4
-rw-r--r--ports-mgmt/portmanager/pkg-descr12
-rw-r--r--ports-mgmt/portmanager/pkg-message8
-rw-r--r--ports-mgmt/portmanager/pkg-plist10
5 files changed, 39 insertions, 44 deletions
diff --git a/ports-mgmt/portmanager/Makefile b/ports-mgmt/portmanager/Makefile
index 71471a5ea257..b7d531edbde0 100644
--- a/ports-mgmt/portmanager/Makefile
+++ b/ports-mgmt/portmanager/Makefile
@@ -6,30 +6,24 @@
#
PORTNAME= portmanager
-PORTVERSION= 0.3.0
-PORTREVISION= 1
-#-----------------------------------------
-#for local use, remove before submitting PR
-CATEGORIES= sysutils
-#CATEGORIES= local/sysutils
-#VALID_CATEGORIES+= ${CATEGORIES} # for FreeBSD to accept our local category
-#-----------------------------------------
-MASTER_SITES= http://portmanager.sunsite.dk/distfiles/ \
- ${MASTER_SITE_SOURCEFORGE}
+PORTVERSION= 0.3.2
+CATEGORIES= sysutils
+MASTER_SITES= http://portmanager.sunsite.dk/distfiles/ \
+ ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= portmanager
-MAINTAINER= ports@FreeBSD.org
-COMMENT= FreeBSD installed ports status and safe update utility
+MAINTAINER= ports@FreeBSD.org
+COMMENT= FreeBSD installed ports status and safe update utility
-MAN1= portmanager.1
-MAN3= libMG.3 MGdbAdd.3 MGdbCreate.3 MGdbDelete.3 \
- MGdbGetRecordQty.3 MGdbGoTop.3 MGdbSeek.3
+MAN1= portmanager.1
+MAN3= libMG.3 MGdbAdd.3 MGdbCreate.3 MGdbDelete.3 \
+ MGdbGetRecordQty.3 MGdbGoTop.3 MGdbSeek.3
GNU_CONFIGURE= yes
-USE_REINPLACE= yes
INSTALLS_SHLIB= yes
-INSTALL_TARGET= install info
+USE_REINPLACE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+INSTALL_TARGET= install info
#
# if --with-bin=something then withvar=${PREFIX} + something
@@ -38,31 +32,24 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
# so --with-bindir=/bin will become ${PREFIX}/bin at configure
# time.
#
-CONFIGURE_ARGS= --with-prefix=${PREFIX} --with-bindir=/bin --with-tempdir=/tmp \
+CONFIGURE_ARGS= --with-prefix=${PREFIX} --with-bindir=/bin \
--with-etcdir=/etc/portmanager --with-pkgdbdir=/var/db/pkg \
- --with-portsdir=${PORTSDIR} --with-sharedir=/share/portmanager
+ --with-portsdir=${PORTSDIR} --with-sharedir=/share/portmanager \
+ --with-tempdir=/tmp
-OPTIONS= DEBUG "Enables debug support and all compile warning" off
+OPTIONS= DEBUG "Enables debug support and all compile warning" off
.include <bsd.port.pre.mk>
-#
-# In FreeBSD 6.0 dumps core when compiled WITHOUT debug symbols
-# so for a temp fix just making the WITH_DEBUG non optional.
-#
-.if ${OSVERSION} >= 600000
-WITH_DEBUG= YES
-.endif
-
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --with-debug=yes
.endif
post-patch:
.if ${PORTREVISION} != 0
- @${REINPLACE_CMD} -e \
- 's|VERSION "${PORTVERSION}"|VERSION "${PORTVERSION}_${PORTREVISION}"|g' \
- ${WRKSRC}/externVars.h.in
+ @${REINPLACE_CMD} -e \
+ 's|PACKAGE_VERSION "${PORTVERSION}"|PACKAGE_VERSION "${PORTVERSION}_${PORTREVISION}"|g' \
+ ${WRKSRC}/externVars.h.in
.endif
post-install:
diff --git a/ports-mgmt/portmanager/distinfo b/ports-mgmt/portmanager/distinfo
index 4db554640e0a..c44432ec91d2 100644
--- a/ports-mgmt/portmanager/distinfo
+++ b/ports-mgmt/portmanager/distinfo
@@ -1,2 +1,2 @@
-MD5 (portmanager-0.3.0.tar.gz) = 160a49044ea2e91e943a92bd1ade3346
-SIZE (portmanager-0.3.0.tar.gz) = 421183
+MD5 (portmanager-0.3.2.tar.gz) = b268e3c2d9ee5d8d82306a2fd8b121bd
+SIZE (portmanager-0.3.2.tar.gz) = 429615
diff --git a/ports-mgmt/portmanager/pkg-descr b/ports-mgmt/portmanager/pkg-descr
index e87a5c79dba8..446eed4cf413 100644
--- a/ports-mgmt/portmanager/pkg-descr
+++ b/ports-mgmt/portmanager/pkg-descr
@@ -4,10 +4,12 @@ dependency ports are built.
**New options**
-1) Leaf port report: Shows ports with no other ports depending on
-them, these are ports that may be safely de-installed.
+1) Single port update/add/rebuild examples:
-2) Remove leaf ports safely: Interactively delete leaf ports.
+portmanager x11/gnome2 updates/adds gnome2 and dependencies
+portmanager x11/gnome2 -f rebuilds gnome2 and dependencies
+
+2) portmanager -u -f forces rebuild of everything
portmanager-questions archive may be found at:
http://www.mail-archive.com/portmanager-questions%40sunsite.dk/
@@ -16,6 +18,4 @@ to subscribe just send an empty message to:
portmanager-questions-subscribe@sunsite.dk
WWW: http://portmanager.sunsite.dk/
-
-Michael C. Shultz
-ringworm01@gmail.com
+Author: Michael C. Shultz <ringworm01@gmail.com>
diff --git a/ports-mgmt/portmanager/pkg-message b/ports-mgmt/portmanager/pkg-message
index 8399ace9351c..22bf923cefcf 100644
--- a/ports-mgmt/portmanager/pkg-message
+++ b/ports-mgmt/portmanager/pkg-message
@@ -7,7 +7,13 @@
*
* upgrades everything except nedit,open office and their dependencies
*
-* portmanager -sl will show you leaf ports, these are safe to remove
+* portmanager x11/gnome2 -l
+*
+* upgrade gnome2 and its dependencies with logging enabled
+*
+* portmanager x11/gnome2 -l -f
+*
+* rebuild gnome2 and its dependencies
*
* portmanager -slid will let you safely remove leaf ports
*
diff --git a/ports-mgmt/portmanager/pkg-plist b/ports-mgmt/portmanager/pkg-plist
index 0413ed4c98a6..0d9c2533d4d6 100644
--- a/ports-mgmt/portmanager/pkg-plist
+++ b/ports-mgmt/portmanager/pkg-plist
@@ -4,8 +4,10 @@
@unexec rm -f %D/share/portmanager/configure.db.temp 2>/dev/null || true
@unexec rm -f %D/share/portmanager/ignore.db 2>/dev/null || true
@unexec rm -f %D/share/portmanager/portCache.tmp 2>/dev/null || true
-@unexec rm -f %D/share/portmanager/port_dependencies.db 2>/dev/null || true
+@unexec rm -f %D/share/portmanager/ports_available.db 2>/dev/null || true
+@unexec rm -f %D/share/portmanager/ports_available_dependencies.db 2>/dev/null || true
@unexec rm -f %D/share/portmanager/ports_cache.db 2>/dev/null || true
+@unexec rm -f %D/share/portmanager/ports_dependencies.db 2>/dev/null || true
@unexec rm -f %D/share/portmanager/ports_installed.db 2>/dev/null || true
@unexec rm -f %D/share/portmanager/ports_old.db 2>/dev/null || true
%%DATADIR%%/help.txt
@@ -13,8 +15,8 @@ bin/portmanager
etc/portmanager/pm-020.conf.SAMPLE
include/libMG.h
lib/libMG.so
-lib/libMG.so.1
-lib/libPMGR.so
-lib/libPMGR.so.1
+lib/libMG.so.2
+lib/libMGPM.so
+lib/libMGPM.so.1
@unexec rmdir %D/etc/portmanager 2>/dev/null || true
@unexec rmdir %D/share/portmanager 2>/dev/null || true