aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorDag-Erling Smørgrav <des@FreeBSD.org>2011-09-01 13:38:33 +0000
committerDag-Erling Smørgrav <des@FreeBSD.org>2011-09-01 13:38:33 +0000
commita5279a0fa4bcac7e60a0cc0128ee5c56dd014621 (patch)
tree1c6fc9d1650852393c08c72a5a684f0ed99962ba /ports-mgmt
parent82d85232474a3cdaf8c6ae547f12c5315dd51c38 (diff)
downloadports-a5279a0fa4bcac7e60a0cc0128ee5c56dd014621.tar.gz
ports-a5279a0fa4bcac7e60a0cc0128ee5c56dd014621.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/porteasy/Makefile2
-rw-r--r--ports-mgmt/porteasy/src/porteasy.pl11
2 files changed, 9 insertions, 4 deletions
diff --git a/ports-mgmt/porteasy/Makefile b/ports-mgmt/porteasy/Makefile
index e47e264a32ad..f4c89716aee1 100644
--- a/ports-mgmt/porteasy/Makefile
+++ b/ports-mgmt/porteasy/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= porteasy
-PORTVERSION= 2.8.4
+PORTVERSION= 2.8.5
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/porteasy/src/porteasy.pl b/ports-mgmt/porteasy/src/porteasy.pl
index a1c4da3e39c7..adc2a86acd54 100644
--- a/ports-mgmt/porteasy/src/porteasy.pl
+++ b/ports-mgmt/porteasy/src/porteasy.pl
@@ -1,6 +1,6 @@
#!/usr/bin/perl -w
#-
-# Copyright (c) 2000-2005 Dag-Erling Coïdan Smørgrav
+# Copyright (c) 2000-2011 Dag-Erling Coïdan Smørgrav
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -32,8 +32,8 @@ use strict;
use Fcntl;
use Getopt::Long;
-my $VERSION = "2.8.4";
-my $COPYRIGHT = "Copyright (c) 2000-2005 Dag-Erling Smørgrav. " .
+my $VERSION = "2.8.5";
+my $COPYRIGHT = "Copyright (c) 2000-2011 Dag-Erling Smørgrav. " .
"All rights reserved.";
# Constants
@@ -1169,6 +1169,11 @@ MAIN:{
}
}
+ # Environment overrides default
+ if ($ENV{'PORTSDIR'}) {
+ $portsdir = $ENV{'PORTSDIR'};
+ }
+
# Scan command line options
Getopt::Long::Configure("auto_abbrev", "bundling");
GetOptions(