aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-06-30 14:43:56 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-06-30 14:43:56 +0000
commitc606c07468a896af6477b3afc184168a2ca07940 (patch)
tree0c264226531ba6a44ec8b41694ec7105cc7d03d4 /ports-mgmt
parent9892b377f84dc3c1786e7f9555cfa9dc3c4fee15 (diff)
downloadports-c606c07468a896af6477b3afc184168a2ca07940.tar.gz
ports-c606c07468a896af6477b3afc184168a2ca07940.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/pkg-devel/Makefile1
-rw-r--r--ports-mgmt/pkg-devel/files/patch-libpkg__utils.c19
-rw-r--r--ports-mgmt/pkg/Makefile1
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__utils.c19
4 files changed, 40 insertions, 0 deletions
diff --git a/ports-mgmt/pkg-devel/Makefile b/ports-mgmt/pkg-devel/Makefile
index a5e87b2844d2..b220f944863c 100644
--- a/ports-mgmt/pkg-devel/Makefile
+++ b/ports-mgmt/pkg-devel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.1.3
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://files.etoilebsd.net/pkg/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/ports-mgmt/pkg-devel/files/patch-libpkg__utils.c b/ports-mgmt/pkg-devel/files/patch-libpkg__utils.c
new file mode 100644
index 000000000000..bce55b43cf37
--- /dev/null
+++ b/ports-mgmt/pkg-devel/files/patch-libpkg__utils.c
@@ -0,0 +1,19 @@
+commit dbb08c0d2a5da374ddc128f93eb0d57efa08ccf8
+Author: Bryan Drewery <bryan@shatow.net>
+Date: Sun Jun 30 09:37:15 2013 -0500
+
+ Return proper value in sha256_fd()
+
+diff --git libpkg/utils.c libpkg/utils.c
+index 45a220a..50dcdd1 100644
+--- libpkg/utils.c
++++ libpkg/utils.c
+@@ -396,7 +396,7 @@ cleanup:
+ close(my_fd);
+ (void)lseek(fd, 0, SEEK_SET);
+
+- return (EPKG_OK);
++ return (ret);
+ }
+
+ int
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 0d431dd15f85..175584169712 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -2,6 +2,7 @@
PORTNAME= pkg
DISTVERSION= 1.1.3
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://files.etoilebsd.net/pkg/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/ \
diff --git a/ports-mgmt/pkg/files/patch-libpkg__utils.c b/ports-mgmt/pkg/files/patch-libpkg__utils.c
new file mode 100644
index 000000000000..bce55b43cf37
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__utils.c
@@ -0,0 +1,19 @@
+commit dbb08c0d2a5da374ddc128f93eb0d57efa08ccf8
+Author: Bryan Drewery <bryan@shatow.net>
+Date: Sun Jun 30 09:37:15 2013 -0500
+
+ Return proper value in sha256_fd()
+
+diff --git libpkg/utils.c libpkg/utils.c
+index 45a220a..50dcdd1 100644
+--- libpkg/utils.c
++++ libpkg/utils.c
+@@ -396,7 +396,7 @@ cleanup:
+ close(my_fd);
+ (void)lseek(fd, 0, SEEK_SET);
+
+- return (EPKG_OK);
++ return (ret);
+ }
+
+ int