aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-10-16 09:56:45 +0000
committerClement Laforet <clement@FreeBSD.org>2005-10-16 09:56:45 +0000
commit0cfb7f53f21f6c82187a16cf1fb3685d887f8a21 (patch)
treeb2b1821270e9772120d615f0392a5ac11f7bda33 /ports-mgmt
parent7d35098aec4454eb19f5da4b1519b08a3e0b451b (diff)
- Add a workaround to new checksum target to keep backward compatibility.
If checksum should be equal to IGNORE and it doesn't have an entry in distinfo check if it has already been "registered". In other words, if they're no SHA256 checksum (which is the case IRL), fallback to MD5 checksum results.
Notes
Notes: svn path=/head/; revision=145541
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index 961cf08fb027..d02068ae5374 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -4188,6 +4188,7 @@ checksum: fetch check-checksum-algorithms
pattern="`${ECHO_CMD} $$file | ${SED} -e 's/\./\\\\./g'`"; \
\
ignored="true"; \
+ alreadymatched="false"; \
for alg in ${CHECKSUM_ALGORITHMS:U}; do \
ignore="false"; \
eval alg_executable=\$$$$alg; \
@@ -4201,13 +4202,14 @@ checksum: fetch check-checksum-algorithms
if [ $$ignore = "false" ]; then \
if [ -z "$$CKSUM" ]; then \
${ECHO_MSG} "=> No $$alg checksum for $$file recorded (expected IGNORE)"; \
- OK="false"; \
+ OK="$$alreadymatched"; \
elif [ $$CKSUM != "IGNORE" ]; then \
${ECHO_MSG} "=> $$alg Checksum for $$file is not set to IGNORE in distinfo file even though"; \
${ECHO_MSG} " the file is in the "'$$'"{IGNOREFILES} list."; \
OK="false"; \
else \
ignored="false"; \
+ alreadymatched="true"; \
fi; \
fi; \
done; \