aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorAlfonso S. Siciliano <alfix86@gmail.com>2022-01-17 15:55:24 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2022-01-17 15:55:24 +0000
commit651c7482a33043fe691f82bfe30195be27da649d (patch)
tree0bb563a64c582e337b51905f708c9b1b1949dc3e /ports-mgmt
parent9c94338d4816ffa74707a722d8f6a50176934388 (diff)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portconfig/Makefile4
-rw-r--r--ports-mgmt/portconfig/distinfo6
-rw-r--r--ports-mgmt/portconfig/files/patch-portconfig.c25
3 files changed, 5 insertions, 30 deletions
diff --git a/ports-mgmt/portconfig/Makefile b/ports-mgmt/portconfig/Makefile
index 68cacd6c0a66..fff16832e520 100644
--- a/ports-mgmt/portconfig/Makefile
+++ b/ports-mgmt/portconfig/Makefile
@@ -1,5 +1,5 @@
PORTNAME= portconfig
-PORTVERSION= 0.1.1
+PORTVERSION= 0.2
CATEGORIES= ports-mgmt
MAINTAINER= bapt@FreeBSD.org
@@ -9,7 +9,7 @@ LICENSE= BSD2CLAUSE
USE_GITLAB= yes
GL_ACCOUNT= alfix
-GL_COMMIT= 222ee8a8f6a790fe6a9c72f7b615e47ecdb56399
+GL_COMMIT= 9103a17b253ead68937bfffdf9135cd6ada8a538
USES= localbase:ldflags
BUILD_DEPENDS= ${LOCALBASE}/lib/libbsddialog.a:devel/bsddialog
diff --git a/ports-mgmt/portconfig/distinfo b/ports-mgmt/portconfig/distinfo
index 0b524941e5d6..d8f2245468a6 100644
--- a/ports-mgmt/portconfig/distinfo
+++ b/ports-mgmt/portconfig/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1638783870
-SHA256 (alfix-portconfig-222ee8a8f6a790fe6a9c72f7b615e47ecdb56399_GL0.tar.gz) = 20e0ccbe417607502a37c0cd86e04a5cf5c5d54577549f0448cf585e2458bff0
-SIZE (alfix-portconfig-222ee8a8f6a790fe6a9c72f7b615e47ecdb56399_GL0.tar.gz) = 202181
+TIMESTAMP = 1642434908
+SHA256 (alfix-portconfig-9103a17b253ead68937bfffdf9135cd6ada8a538_GL0.tar.gz) = 5908d23ad0680e2ae38aa3e1f21af265b2b981989333c205c86badb53a27896f
+SIZE (alfix-portconfig-9103a17b253ead68937bfffdf9135cd6ada8a538_GL0.tar.gz) = 202379
diff --git a/ports-mgmt/portconfig/files/patch-portconfig.c b/ports-mgmt/portconfig/files/patch-portconfig.c
deleted file mode 100644
index 0351f0638be1..000000000000
--- a/ports-mgmt/portconfig/files/patch-portconfig.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- portconfig.c.orig 2021-11-29 17:22:25 UTC
-+++ portconfig.c
-@@ -253,9 +253,6 @@ main(int argc, char *argv[])
- theme = BSDDIALOG_THEME_DIALOG;
- newstr = "+";
- }
-- else if (strcasecmp(env, "magenta") == 0) {
-- theme = BSDDIALOG_THEME_MAGENTA;
-- }
- else if (strcasecmp(env, "blackwhite") == 0) {
- theme = BSDDIALOG_THEME_BLACKWHITE;
- }
-@@ -290,10 +287,10 @@ main(int argc, char *argv[])
- confhelp.title = "HELP";
- confhelp.hfile = NULL;
- for (;;) {
-- output = bsddialog_mixedlist(conf, helpmsg, h, w, 0, ngroups,
-+ output = bsddialog_mixedlist(&conf, helpmsg, h, w, 0, ngroups,
- groups, NULL, NULL);
- if (output == BSDDIALOG_HELP) {
-- output = bsddialog_textbox(confhelp, conf.hfile, 0, 0);
-+ output = bsddialog_textbox(&confhelp, conf.hfile, 0, 0);
- if(output == BSDDIALOG_ERROR)
- break;
- }