aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2006-02-23 08:28:48 +0000
committerKris Kennaway <kris@FreeBSD.org>2006-02-23 08:28:48 +0000
commitbce8e54a02ce47d9e74acecc026a390dbc111b43 (patch)
tree03b0997664625e37524e8bb363c5391017a83c7f /ports-mgmt
parent9c33f48abd5d686aa9788085fb1a2965297258a1 (diff)
downloadports-bce8e54a02ce47d9e74acecc026a390dbc111b43.tar.gz
ports-bce8e54a02ce47d9e74acecc026a390dbc111b43.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/newportsversioncheck/Makefile7
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile10
-rw-r--r--ports-mgmt/tinderbox/Makefile10
3 files changed, 13 insertions, 14 deletions
diff --git a/ports-mgmt/newportsversioncheck/Makefile b/ports-mgmt/newportsversioncheck/Makefile
index 271e9bfeab2a..ee30daf4c613 100644
--- a/ports-mgmt/newportsversioncheck/Makefile
+++ b/ports-mgmt/newportsversioncheck/Makefile
@@ -14,10 +14,9 @@ MASTER_SITES= http://www.mavetju.org/download/
MAINTAINER= edwin@mavetju.org
COMMENT= Ports new version checker
-PERL_RUN_DEPENDS= \
- DBD-SQLite:${PORTSDIR}/databases/p5-DBD-SQLite \
- MIME-Lite:${PORTSDIR}/mail/p5-MIME-Lite \
- LWP:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ ${SITE_PERL}/MIME/Lite.pm:${PORTSDIR}/mail/p5-MIME-Lite \
+ ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww
USE_PERL_RUN= yes
USE_SQLITE= yes
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 8d2ab3aa7f15..615b8ae8b344 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= edwin@mavetju.org
COMMENT= Port build tinderbox system
-PERL_RUN_DEPENDS= Digest-MD5:${PORTSDIR}/security/p5-Digest-MD5 \
- Net-SMTP:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
+ ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
cvsup:${PORTSDIR}/net/cvsup-without-gui
OPTIONS= PGSQL "With pgsql" On \
@@ -37,13 +37,13 @@ USE_PHP= session
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
-PERL_RUN_DEPENDS+= DBD-Pg:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-PERL_RUN_DEPENDS+= DBD-mysql:${PORTSDIR}/databases/p5-DBD-mysql
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.include "${PORTSDIR}/Mk/bsd.php.mk"
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index 8d2ab3aa7f15..615b8ae8b344 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -13,9 +13,9 @@ MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= edwin@mavetju.org
COMMENT= Port build tinderbox system
-PERL_RUN_DEPENDS= Digest-MD5:${PORTSDIR}/security/p5-Digest-MD5 \
- Net-SMTP:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
+ ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
+ ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
cvsup:${PORTSDIR}/net/cvsup-without-gui
OPTIONS= PGSQL "With pgsql" On \
@@ -37,13 +37,13 @@ USE_PHP= session
.if defined(WITH_PGSQL)
USE_PGSQL= yes
USE_PHP+= pgsql
-PERL_RUN_DEPENDS+= DBD-Pg:${PORTSDIR}/databases/p5-DBD-Pg
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if defined(WITH_MYSQL)
USE_PHP+= mysql
USE_MYSQL= yes
-PERL_RUN_DEPENDS+= DBD-mysql:${PORTSDIR}/databases/p5-DBD-mysql
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
.endif
.include "${PORTSDIR}/Mk/bsd.php.mk"