aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2017-04-21 19:50:59 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2017-04-21 19:50:59 +0000
commit6bb9127bab848c98bc4d493adc75d5cdaf11ae56 (patch)
tree76d0efccb7b200b8203d799a80ac6112c6e346d4 /ports-mgmt
parent2aadf79bad96b51fe5bfb9a44295b74f2f428905 (diff)
downloadports-6bb9127bab848c98bc4d493adc75d5cdaf11ae56.tar.gz
ports-6bb9127bab848c98bc4d493adc75d5cdaf11ae56.zip
Update to 2.17.8.
* Check for use of OPT_XXX_OFF syntax to prevent false incorrect option usage assertions. [1] * Remove now-obsolete warning about using :LU operators with make(1). [2] * Fix the regex to prevent direct command use from hittin on lines like FOO_USES=... [3] PR: 218260 [1] 218325 [2] 218672 [3] Submitted by: jrm [2] Reported by: rezny [2]
Notes
Notes: svn path=/head/; revision=439128
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl18
2 files changed, 5 insertions, 15 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index fde76669458a..c2ea738313c6 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.17.7
+PORTVERSION= 2.17.8
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index ec90d67197ce..d1c02384c313 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.401 2017/03/29 15:26:37 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.405 2017/04/21 19:47:51 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 17;
-my $micro = 7;
+my $micro = 8;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1405,16 +1405,6 @@ sub checkmakefile {
}
#
- # whole file: use of :LU variable expansion modifiers
- #
- print "OK: checking for use of :LU variable expansion modifiers.\n" if ($verbose);
- if ($whole =~ /\$\{[^}]+:[LU]/m) {
- my $lineno = &linenumber($`);
- &perror("FATAL", $file, $lineno, ":U and :L syntax is not supported ".
- "anymore. Please use :tu and :tl instead.");
- }
-
- #
# whole file: use of IGNOREFILES
#
print "OK: checking for use of IGNOREFILES.\n" if ($verbose);
@@ -1635,7 +1625,7 @@ sub checkmakefile {
# skip global options
next if ($i eq 'DOCS' or $i eq 'NLS' or $i eq 'EXAMPLES' or $i eq 'IPV6' or $i eq 'X11' or $i eq 'DEBUG');
if (!grep(/^$i$/, (@mopt, @popt))) {
- if ($whole !~ /\n${i}_($m)(.)?=[^\n]+/) {
+ if ($whole !~ /\n${i}_($m)(_\w+)?(.)?=[^\n]+/) {
if (!$slaveport) {
&perror("WARN", $file, -1, "$i is listed in ".
"OPTIONS_DEFINE, but no PORT_OPTIONS:M$i appears.");
@@ -1979,7 +1969,7 @@ xargs xmkmf
&& $curline !~ /^NO_CDROM(.)?=[^\n]+$i/m
&& $curline !~ /^MAINTAINER(.)?=[^\n]+$i/m
&& $curline !~ /^CATEGORIES(.)?=[^\n]+$i/m
- && $curline !~ /^USES(.)?=[^\n]+$i/m
+ && $curline !~ /^(\w+)?USES(.)?=[^\n]+$i/m
&& $curline !~ /^WX_COMPS(.)?=[^\n]+$i/m
&& $curline !~ /^ONLY_FOR_ARCHS_REASON(.)?=[^\n]+$i/m
&& $curline !~ /^NOT_FOR_ARCHS_REASON(.)?=[^\n]+$i/m