aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2019-06-24 14:30:47 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2019-06-24 14:30:47 +0000
commit7039eb9b03b402b559fc76060f2f323cab1a5959 (patch)
treec9d87c6ca3fe2eefcb4fdf862a9c0dd5fe16cf9b /ports-mgmt
parent6a806270eda79369d4de2d0d9b516702efcf4d91 (diff)
downloadports-7039eb9b03b402b559fc76060f2f323cab1a5959.tar.gz
ports-7039eb9b03b402b559fc76060f2f323cab1a5959.zip
ports-mgmt/caronade:
- Update to 0.2.0 - Use go:modules instead of manual GOFLAGS=-mod=vendor Changes in 0.2.0: ================= Features: * New Web UI with Bulma * Implement EMail notifications * Allow Environment variables to be written in Go template syntax * Add PathMatch parameter to separate repository into different environments * Implement better overlay Portstree * Add SSH recipe for remote building * Support GNU make Bugs: * Use the correct poudriere portstree when building * Fix clean targets in portlint and poudriere recipe * Render Job Template as soon as the job starts * Fix issue when StatusAPI is not used/configured
Notes
Notes: svn path=/head/; revision=505029
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/caronade/Makefile6
-rw-r--r--ports-mgmt/caronade/distinfo6
-rw-r--r--ports-mgmt/caronade/pkg-plist3
3 files changed, 8 insertions, 7 deletions
diff --git a/ports-mgmt/caronade/Makefile b/ports-mgmt/caronade/Makefile
index 5a6ba96708bc..9c1fa682388a 100644
--- a/ports-mgmt/caronade/Makefile
+++ b/ports-mgmt/caronade/Makefile
@@ -2,8 +2,7 @@
PORTNAME= caronade
DISTVERSIONPREFIX=v
-DISTVERSION= 0.1.0
-PORTREVISION= 1
+DISTVERSION= 0.2.0
CATEGORIES= ports-mgmt
MASTER_SITES= https://code.bluelife.at/decke/caronade/archive/ \
LOCAL/decke/caronade/
@@ -16,7 +15,7 @@ COMMENT= Small and light tool to help with FreeBSD Ports CI
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go
+USES= go:modules
USE_RC_SUBR= caronade
USE_GITHUB= nodefault
@@ -24,7 +23,6 @@ GH_TUPLE= NYTimes:gziphandler:v1.1.1:gziphandler/vendor/github.com/NYTimes/gziph
go-yaml:yaml:v2.2.2:yaml/vendor/gopkg.in/yaml.v2
GO_PKGNAME= code.bluelife.at/decke/caronade
-MAKE_ENV+= GOFLAGS=-mod=vendor
post-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
diff --git a/ports-mgmt/caronade/distinfo b/ports-mgmt/caronade/distinfo
index 39c881a4b26d..9054a5859f03 100644
--- a/ports-mgmt/caronade/distinfo
+++ b/ports-mgmt/caronade/distinfo
@@ -1,6 +1,6 @@
-TIMESTAMP = 1552658543
-SHA256 (caronade/v0.1.0.tar.gz) = f38ef48bb783588610a3a65191cff9f230087a074668f1b7846ee089aab3335f
-SIZE (caronade/v0.1.0.tar.gz) = 59372
+TIMESTAMP = 1561385995
+SHA256 (caronade/v0.2.0.tar.gz) = f8dde847d7bcbf3ac755143e7404e567bed619d367f42629ae03b2e87c697758
+SIZE (caronade/v0.2.0.tar.gz) = 49438
SHA256 (caronade/NYTimes-gziphandler-v1.1.1_GH0.tar.gz) = c236c216a16e4286338e66e0947938944992f918fe827c31f8745c0be98818d2
SIZE (caronade/NYTimes-gziphandler-v1.1.1_GH0.tar.gz) = 52107
SHA256 (caronade/go-yaml-yaml-v2.2.2_GH0.tar.gz) = 42c3e4ef9eca2860d22b3c6c5582c6c13fb4b417e5ebc1acc56ee5e2c4ddcaff
diff --git a/ports-mgmt/caronade/pkg-plist b/ports-mgmt/caronade/pkg-plist
index 5d85958cf857..5f64472604cb 100644
--- a/ports-mgmt/caronade/pkg-plist
+++ b/ports-mgmt/caronade/pkg-plist
@@ -2,8 +2,11 @@ bin/caronade
caronade/static/caronade.min.css
caronade/static/favicon-32.png
caronade/static/favicon-96.png
+caronade/static/logo.png
+caronade/templates/email.txt
caronade/templates/index.html
caronade/work/portlint.mk
caronade/work/poudriere.mk
+caronade/work/ssh.mk
%%ETCDIR%%/caronade.yaml.sample
@dir caronade/builds