aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2011-01-10 04:43:58 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2011-01-10 04:43:58 +0000
commitd6cedf8b477417859c061f8813ee9d1bd1d7360a (patch)
treeee46f86c78e580896b4b88136e689b805a0f5c76 /ports-mgmt
parentd3572568e4c67c697c12e15190d68bf26fc27424 (diff)
downloadports-d6cedf8b477417859c061f8813ee9d1bd1d7360a.tar.gz
ports-d6cedf8b477417859c061f8813ee9d1bd1d7360a.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl15
2 files changed, 11 insertions, 6 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 520a43d284d4..9a7009c05faf 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -8,7 +8,7 @@
#
PORTNAME= portlint
-PORTVERSION= 2.13.2
+PORTVERSION= 2.13.3
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index db57916ab69c..6cc821277aa0 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.203 2010/11/07 22:10:25 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.207 2011/01/10 04:42:45 marcus Exp $
#
use strict;
@@ -52,7 +52,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 13;
-my $micro = 2;
+my $micro = 3;
sub l { '[{(]'; }
sub r { '[)}]'; }
@@ -464,7 +464,7 @@ if ($committer) {
if /^(?:\.\.?|CVS)$/;
my $filename = $dir eq '.' ? $_ : "$dir/$_";
if (-d $filename) {
- if (!$entries{$_} || $entries{$_} ne 'D') {
+ if ((!$entries{$_} || $entries{$_} ne 'D') && $filename ne 'work') {
&perror("FATAL", "", -1, "directory $filename not in CVS.");
}
else {
@@ -699,8 +699,13 @@ sub checkplist {
# E.g., %%PORTDOCS%%%%RUBY_MODDOCDIR%% will be OK because there is
# no %%PORTRUBY_MODDOC%% substitution.
my %check_xxxdir_ok = (
+ "DOCS" => "DOCS",
+ "EXAMPLES" => "EXPAMPLES",
+ "DATA" => "DATA",
+ "RUBY_DOC" => "DOCS",
+ "RUBY_EXAMPLES" => "EXAMPLES",
"RUBY_MODDOC" => "DOCS",
- "RUBY_MODEXAMPLES" => "DOCS",
+ "RUBY_MODEXAMPLES" => "EXAMPLES",
);
open(IN, "< $file") || return 0;
@@ -925,7 +930,7 @@ sub checkplist {
if ($_ =~ m{^%%PORT(\w+)%%(.*?)%%(\w+)DIR%%(.*)$} and $1 ne $3) {
&perror("WARN", $file, $., "Do not mix %%PORT$1%% with %%$3DIR%%. ".
- "Use '%%PORT$3%%$2%%$3DIR%%$4' instead and update Makefile ".
+ "Use '%%PORT$check_xxxdir_ok{$3}%%$2%%$3DIR%%$4' instead and update Makefile ".
"accordingly.") unless (defined($check_xxxdir_ok{$3}) and
$check_xxxdir_ok{$3} eq $1);
}