aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-03-25 15:24:52 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-03-25 15:24:52 +0000
commit09bc6e62037d0a457a54dee9279858846b4b2171 (patch)
tree791cefa5254ea5af660bded23f1b695e4061a438 /ports-mgmt
parent08b816c9f3792bb3f841fc462a9e995935671ed0 (diff)
downloadports-09bc6e62037d0a457a54dee9279858846b4b2171.tar.gz
ports-09bc6e62037d0a457a54dee9279858846b4b2171.zip
Notes
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile15
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-lib__tinderlib.sh27
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-webui__core__TinderboxDS.php20
3 files changed, 55 insertions, 7 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 64bc3e497232..8bc08428540f 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -6,6 +6,7 @@
PORTNAME= tinderbox
PORTVERSION= 3.2
+PORTREVISION= 1 # 2009-03-25
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
http://T32.TecNik93.com/FreeBSD/ports/${PORTNAME}/sources/
@@ -20,11 +21,11 @@ CONFLICTS= tinderbox-[0-9]*
OPTIONS= PGSQL "With pgsql" Off \
MYSQL "With mysql" On \
CSUP "Use csup for updates" On \
- CVSUP "Use cvsup for updates" Off \
WEBUI "Install web interface" On \
APACHE "Use Apache for web interface" On \
LIGHTTPD "Use LightHTTPD for web interface" Off \
- CHECK_FOR_ROOT "Check it ./tc is run by uid 0" On
+ CHECK_FOR_ROOT "Check it ./tc is run by uid 0" On \
+ LSOF "Use lsof not fstat for killMountProcesses()" On
NO_BUILD= yes
WANT_PERL= yes
@@ -73,16 +74,16 @@ RUN_DEPENDS+= csup:${PORTSDIR}/net/csup
.endif
.endif
-.if defined(WITH_CVSUP)
-RUN_DEPENDS+= cvsup:${PORTSDIR}/net/cvsup-without-gui
-.endif
-
.if !defined(WITHOUT_APACHE) && defined(WITH_WEBUI)
USE_APACHE= 1.3+
.elif defined(WITH_LIGHTTPD) && defined(WITH_WEBUI)
RUN_DEPENDS+= lighttpd:${PORTSDIR}/www/lighttpd
.endif
+.if defined(WITH_LSOF)
+RUN_DEPENDS+= lsof:${PORTSDIR}/sysutils/lsof
+.endif
+
pre-everything::
.if (!defined(WITHOUT_APACHE) || defined(WITH_LIGHTTPD)) && !defined(WITH_WEBUI)
@${ECHO_CMD} "It doesn't make sense to depend on Apache or LightHTTPD if not using either web interface."
@@ -98,8 +99,8 @@ post-patch:
.ifdef WITHOUT_CHECK_FOR_ROOT
${REINPLACE_CMD} -e 's/^if \[ `id -u` != 0 \]; then/if false; then/' \
${WRKSRC}/tc
- @cd ${WRKSRC} && ${FIND} . -name '*.orig' -exec ${RM} {} \;
.endif
+ @cd ${WRKSRC} && ${FIND} . -name '*.orig' -exec ${RM} {} \;
do-install:
@${MKDIR} ${PREFIX}/tinderbox/scripts
diff --git a/ports-mgmt/tinderbox-devel/files/patch-lib__tinderlib.sh b/ports-mgmt/tinderbox-devel/files/patch-lib__tinderlib.sh
new file mode 100644
index 000000000000..79fe31d8541a
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-lib__tinderlib.sh
@@ -0,0 +1,27 @@
+--- ./lib/tinderlib.sh.orig 2009-02-24 21:36:38.000000000 +0200
++++ ./lib/tinderlib.sh 2009-03-25 06:14:12.238205132 +0200
+@@ -23,7 +23,7 @@
+ # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ # SUCH DAMAGE.
+ #
+-# $MCom: portstools/tinderbox/lib/tinderlib.sh,v 1.55.2.4 2008/11/10 07:03:02 marcus Exp $
++# $MCom: portstools/tinderbox/lib/tinderlib.sh,v 1.55.2.5 2009/03/14 23:57:13 marcus Exp $
+ #
+
+ tinderLocJail () {
+@@ -131,7 +131,14 @@
+
+ pids="XXX"
+ while [ ! -z "${pids}" ]; do
+- pids=$(fstat -f "${dir}" | tail +2 | awk '{print $3}' | sort -u)
++ # Lsof is more reliable when it comes to nullfs, so prefer it if
++ # found.
++ lsof=$(which lsof 2>/dev/null)
++ if [ -n "${lsof}" ]; then
++ pids=$(${lsof} | fgrep "${dir}" | awk '{print $2}' | sort -u)
++ else
++ pids=$(fstat -f "${dir}" | tail +2 | awk '{print $3}' | sort -u)
++ fi
+
+ if [ ! -z "${pids}" ]; then
+ echo "Killing off pids in ${dir}"
diff --git a/ports-mgmt/tinderbox-devel/files/patch-webui__core__TinderboxDS.php b/ports-mgmt/tinderbox-devel/files/patch-webui__core__TinderboxDS.php
new file mode 100644
index 000000000000..5add81055d46
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-webui__core__TinderboxDS.php
@@ -0,0 +1,20 @@
+--- ./webui/core/TinderboxDS.php.orig 2009-02-24 21:36:38.000000000 +0200
++++ ./webui/core/TinderboxDS.php 2009-03-25 06:14:12.244205304 +0200
+@@ -24,7 +24,7 @@
+ # OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ # SUCH DAMAGE.
+ #
+-# $MCom: portstools/tinderbox/webui/core/TinderboxDS.php,v 1.36.2.6 2009/02/01 19:43:27 beat Exp $
++# $MCom: portstools/tinderbox/webui/core/TinderboxDS.php,v 1.36.2.7 2009/03/13 07:57:24 beat Exp $
+ #
+
+ require_once 'DB.php';
+@@ -388,7 +388,7 @@
+ }
+ $query = "SELECT p.port_id,
+ p.port_directory,
+- TRIM(TRAILING '@FreeBSD.org' FROM p.port_maintainer) as port_maintainer,
++ REPLACE(p.port_maintainer, '@FreeBSD.org', '') as port_maintainer,
+ p.port_name,
+ p.port_comment,
+ bp.last_built,