aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2021-09-19 17:12:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2021-09-19 17:12:39 +0000
commit772ba6c8dbe420f4f96721ddaa060432a0f57ec4 (patch)
tree242e0c51cd4c51509d9943c7679ed08753b5020d /ports-mgmt
parenta9775bb5502ae22a05da9e96762cd8216bb72a67 (diff)
downloadports-772ba6c8dbe420f4f96721ddaa060432a0f57ec4.tar.gz
ports-772ba6c8dbe420f4f96721ddaa060432a0f57ec4.zip
ports-mgmt/portlint: Update to 2.19.8
* Warn about deprecated USE_AUTOTOOLS [1] * Add support for BROKEN_* PR: 248487 [1] 257951 [2]
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl18
2 files changed, 14 insertions, 6 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index d21f0898cb4f..41bec3134480 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -1,7 +1,7 @@
# Created by: Jun-ichiro itojun Hagino <itojun@itojun.org>
PORTNAME= portlint
-PORTVERSION= 2.19.7
+PORTVERSION= 2.19.8
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index e5d64f1a573d..1c5b7da8fa7b 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -49,7 +49,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 19;
-my $micro = 7;
+my $micro = 8;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1916,7 +1916,7 @@ sub checkmakefile {
# whole file: BROKEN et al.
#
my ($var);
- foreach $var (qw(IGNORE BROKEN COMMENT FORBIDDEN MANUAL_PACKAGE_BUILD NO_CDROM NO_PACKAGE RESTRICTED)) {
+ foreach $var (qw(IGNORE BROKEN(_[\w\d]+)? COMMENT FORBIDDEN MANUAL_PACKAGE_BUILD NO_CDROM NO_PACKAGE RESTRICTED)) {
print "OK: checking ${var}.\n" if ($verbose);
if ($whole =~ /\n${var}[+?]?=[ \t]+"/) {
my $lineno = &linenumber($`);
@@ -1937,8 +1937,8 @@ sub checkmakefile {
"with a lowercase letter and end without a period.");
}
- if ($whole =~ /\nBROKEN[+?]=[ \t]+[^a-z \t]/ ||
- $whole =~ /^BROKEN[+?]?=[ \t]+.*\.$/m) {
+ if ($whole =~ /\nBROKEN(_[\w\d]+)?[+?]?=[ \t]+[^a-z \t]/ ||
+ $whole =~ /^BROKEN(_[\w\d]+)?[+?]?=[ \t]+.*\.$/m) {
my $lineno = &linenumber($`);
&perror("WARN", $file, $lineno, "BROKEN messages should begin ".
"with a lowercase letter and end without a period.");
@@ -2223,7 +2223,7 @@ xargs xmkmf
&& $lm !~ /^COMMENT(.)?=[^\n]+($i\d*)/m) {
&perror("WARN", $file, $lineno, "possible direct use of ".
"command \"$sm\" found. Use $autocmdnames{$i} ".
- "instead and set according USE_AUTOTOOLS=<tool> macro");
+ "instead and set USES=autoreconf and GNU_CONFIGURE=yes");
}
}
}
@@ -2233,6 +2233,14 @@ xargs xmkmf
"Use USES=libtool instead.");
}
+ if ($makevar{'USE_AUTOTOOLS'} =~ /\blibtoolize\b/) {
+ &perror("WARN", $file, -1, "USE_AUTOTOOLS=libtoolize is deprecated. ".
+ "Use \"USES=autoreconf libtool\" instead.");
+ } elsif ($makevar{'USE_AUTOCONF'}) {
+ &perror("WARN", $file, -1, "USE_AUTOTOOLS is deprecated. ".
+ "Use USES=autoreconf and set GNU_CONFIGURE=yes instead.");
+ }
+
#
# whole file: check for use of paths that have macro replacements
#