aboutsummaryrefslogtreecommitdiff
path: root/print/auctex/Makefile
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2015-08-22 17:48:35 +0000
committerHiroki Sato <hrs@FreeBSD.org>2015-08-22 17:48:35 +0000
commit27470e1676e69455acf06ae25ebd42ebd5bdecdb (patch)
tree445c3e315f03aa972de87391f921c655e4634f60 /print/auctex/Makefile
parentcb9ed09fda5119f533f6a0b50796a275dfe64587 (diff)
downloadports-27470e1676e69455acf06ae25ebd42ebd5bdecdb.tar.gz
ports-27470e1676e69455acf06ae25ebd42ebd5bdecdb.zip
Notes
Diffstat (limited to 'print/auctex/Makefile')
-rw-r--r--print/auctex/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/print/auctex/Makefile b/print/auctex/Makefile
index b9a8a1c1d4ae..5d2ca09e5a40 100644
--- a/print/auctex/Makefile
+++ b/print/auctex/Makefile
@@ -3,10 +3,10 @@
PORTNAME= auctex
PORTVERSION= 11.88
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print elisp
MASTER_SITES= GNU
-PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Integrated environment for writing LaTeX using GNU Emacs
@@ -14,25 +14,23 @@ COMMENT= Integrated environment for writing LaTeX using GNU Emacs
LICENSE= GPLv3
NOT_FOR_ARCHS= ia64
-USE_TEX= latex
USES= ghostscript
USE_EMACS= yes
+USE_TEX= latex texhash
+TEXHASHDIRS= ${TEXMFDIR}
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${LISPDIR} \
- --with-auto-dir=${PREFIX}/${LISPDIR}/auctex/auto \
- --with-texmf-dir=${PREFIX}/${TEXMFDIR}
-DOCS_CONFIGURE_ON= --docdir=${DOCSDIR}
-DOCS_CONFIGURE_OFF= WITHOUT_AUCTEX_DOCSDIR=yes
+CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR} \
+ --with-auto-dir=${PREFIX}/${EMACS_VERSION_SITE_LISPDIR}/auctex/auto \
+ --with-texmf-dir=${PREFIX}/${TEXMFDIR}
PORTDOCS= tex-ref.pdf
INFO= auctex preview-latex
-LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}
-PLIST_SUB+= LISPDIR=${LISPDIR} \
- TEXMFDIR=${TEXMFDIR} \
- MKTEXLSR=${MKTEXLSR}
+PLIST_SUB= TEXMFDIR=${TEXMFDIR}
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
OPTIONS_DEFINE= DOCS
OPTIONS_DEFAULT=DOCS
+DOCS_CONFIGURE_ON= --docdir=${DOCSDIR}
+DOCS_CONFIGURE_OFF= WITHOUT_AUCTEX_DOCSDIR=yes
.include <bsd.port.mk>