aboutsummaryrefslogtreecommitdiff
path: root/print/axpoint/Makefile
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-06-08 01:15:04 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-06-08 01:15:04 +0000
commitc399421a8d05fc8ba2c7b98f033891206cc5ebd1 (patch)
treecd2e4a7cd0f5330dac199669b77414ff44693362 /print/axpoint/Makefile
parent3437f51b00250515d0a1cd45f8a48c238d7292a1 (diff)
Notes
Diffstat (limited to 'print/axpoint/Makefile')
-rw-r--r--print/axpoint/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/print/axpoint/Makefile b/print/axpoint/Makefile
index 09cdd8ea9708..691f6b09961d 100644
--- a/print/axpoint/Makefile
+++ b/print/axpoint/Makefile
@@ -7,25 +7,26 @@
#
PORTNAME= axpoint
-PORTVERSION= 1.30
+PORTVERSION= 1.50
CATEGORIES= print perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= XML
-DISTNAME= XML-Handler-AxPoint-${PORTVERSION}
+DISTNAME= XML-Handler-AxPoint-${PORTVERSION:S/0$//}
MAINTAINER= ports@FreeBSD.org
COMMENT= XML Based Presentations
-BUILD_DEPENDS= ${PERL_SITELIBDIR}/XML/SAX.pm:${PORTSDIR}/textproc/p5-XML-SAX \
- ${PERL_SITELIBDIR}/XML/SAX/Writer.pm:${PORTSDIR}/textproc/p5-XML-SAX-Writer \
- ${PERL_SITELIBDIR}/PDFLib.pm:${PORTSDIR}/print/p5-PDFLib
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv \
+ p5-Time-Piece>=1.08:${PORTSDIR}/devel/p5-Time-Piece \
+ ${SITE_PERL}/XML/Filter/XSLT.pm:${PORTSDIR}/textproc/p5-XML-Filter-XSLT \
+ p5-XML-SAX>=0.09:${PORTSDIR}/textproc/p5-XML-SAX \
+ p5-XML-SAX-Writer>=0.39:${PORTSDIR}/textproc/p5-XML-SAX-Writer \
+ p5-PDFLib>=0.14:${PORTSDIR}/print/p5-PDFLib
RUN_DEPENDS= ${BUILD_DEPENDS}
-PERL_SITELIBDIR= ${SITE_PERL}
USE_PERL5= yes
PERL_CONFIGURE= yes
-MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= XML::Handler::AxPoint.3
.include <bsd.port.mk>