aboutsummaryrefslogtreecommitdiff
path: root/print/bibcursed
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-11 04:50:35 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-08-11 04:50:35 +0000
commitb3f251db95d79341da01c2d2d691fc2da59fdfaa (patch)
tree651beb4576354a148d9bf72854830566f804cf8e /print/bibcursed
parent37708c9db6c6b71a916aff0ef67a864694759f74 (diff)
downloadports-b3f251db95d79341da01c2d2d691fc2da59fdfaa.tar.gz
ports-b3f251db95d79341da01c2d2d691fc2da59fdfaa.zip
Notes
Diffstat (limited to 'print/bibcursed')
-rw-r--r--print/bibcursed/Makefile27
-rw-r--r--print/bibcursed/distinfo1
-rw-r--r--print/bibcursed/pkg-comment1
-rw-r--r--print/bibcursed/pkg-descr11
-rw-r--r--print/bibcursed/pkg-plist1
5 files changed, 41 insertions, 0 deletions
diff --git a/print/bibcursed/Makefile b/print/bibcursed/Makefile
new file mode 100644
index 000000000000..ce774b4bcd20
--- /dev/null
+++ b/print/bibcursed/Makefile
@@ -0,0 +1,27 @@
+# ex:ts=8
+# Ports collection makefile for: bibcursed
+# Date created: Aug 11, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= bibcursed
+PORTVERSION= 2.0.0
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKEFILE= Makefile.ncurses
+
+MAN1= bibcursed.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bibcursed ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/bibcursed.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/print/bibcursed/distinfo b/print/bibcursed/distinfo
new file mode 100644
index 000000000000..85cafbc895eb
--- /dev/null
+++ b/print/bibcursed/distinfo
@@ -0,0 +1 @@
+MD5 (bibcursed_2.0.0.tar.gz) = 2579457724f17c23cdac408e4271f2d9
diff --git a/print/bibcursed/pkg-comment b/print/bibcursed/pkg-comment
new file mode 100644
index 000000000000..de263b96e000
--- /dev/null
+++ b/print/bibcursed/pkg-comment
@@ -0,0 +1 @@
+A simple curses-based editor for BibTeX bibliography files
diff --git a/print/bibcursed/pkg-descr b/print/bibcursed/pkg-descr
new file mode 100644
index 000000000000..0a3cf1f343e0
--- /dev/null
+++ b/print/bibcursed/pkg-descr
@@ -0,0 +1,11 @@
+Bibcursed is a simple program to make life a little easier when using
+BibTeX bibliographies. It currently provides these main functions:
+
+ - Adding references to your bibliography. This is done with prompts so
+ templates for the different entries (article, proceedings, etc) do
+ not have to be remembered. Error checking is used so that the required
+ fields have to be supplied, and incorrect fields cannot be entered.
+ New entries are inserted into the 'correct' place in the BibTeX file
+ - Clean and easy removal of entries
+ - Viewing of entries and changing of fields
+ - Easy searching of entries, including search by field
diff --git a/print/bibcursed/pkg-plist b/print/bibcursed/pkg-plist
new file mode 100644
index 000000000000..94f88c4f6fc2
--- /dev/null
+++ b/print/bibcursed/pkg-plist
@@ -0,0 +1 @@
+bin/bibcursed