aboutsummaryrefslogtreecommitdiff
path: root/print/c2ps-letter/Makefile
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1998-11-20 04:15:15 +0000
committerSatoshi Asami <asami@FreeBSD.org>1998-11-20 04:15:15 +0000
commit751790b51ae4c1152e8944cbaf99d49b1377e95b (patch)
tree086c03d44a933a34d3f086e2ad7487d5d6b2872d /print/c2ps-letter/Makefile
parent1007d89b1e30bdb9e77bc765b023f4e3c60f6982 (diff)
downloadports-751790b51ae4c1152e8944cbaf99d49b1377e95b.tar.gz
ports-751790b51ae4c1152e8944cbaf99d49b1377e95b.zip
Notes
Diffstat (limited to 'print/c2ps-letter/Makefile')
-rw-r--r--print/c2ps-letter/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/print/c2ps-letter/Makefile b/print/c2ps-letter/Makefile
index 2a925298fd65..aae94eb01480 100644
--- a/print/c2ps-letter/Makefile
+++ b/print/c2ps-letter/Makefile
@@ -1,37 +1,27 @@
-# New ports collection makefile for: c2ps
+# New ports collection makefile for: c2ps (letter)
# Version required: 4.0
# Date created: 19 March 1997
# Whom: Matthew Hunt <mph@pobox.com>
#
-# $Id: Makefile,v 1.5 1998/04/17 23:26:29 mph Exp $
+# $Id: Makefile,v 1.6 1998/10/30 08:35:31 asami Exp $
#
DISTNAME= c2ps-4.0
-PKGNAME= c2ps-${PAPERSIZE:S/A4/a4/:S/LETTER/letter/:S/Letter/letter/}-4.0
+PKGNAME= c2ps-${PAPERSIZE}-4.0
CATEGORIES= print
MASTER_SITES= http://www.cs.technion.ac.il/users/c2ps/
MAINTAINER= mph@freebsd.org
-LOOP_VAR= PAPERSIZE
-LOOP_OPTIONS= letter a4
MAN1= c2ps.1
-MAKE_ENV= DEFAULT_PAPER_TYPE=${PAPERSIZE}
+MAKE_ENV= DEFAULT_PAPER_TYPE=${PS}
-.if !defined(PAPERSIZE)
-PAPERSIZE=A4
-.elif ${PAPERSIZE} == letter || ${PAPERSIZE} == Letter
-PAPERSIZE=LETTER
-.elif ${PAPERSIZE} == a4
-PAPERSIZE=A4
-.elif ${PAPERSIZE} != A4 && ${PAPERSIZE} != LETTER
-PAPERSIZE_INVALID=yes
-.endif
-
-pre-fetch:
-.if defined(PAPERSIZE_INVALID)
+PAPERSIZE?= letter
+PS!= echo ${PAPERSIZE} | awk '{print toupper($$1)}'
+.if ${PAPERSIZE} != a4 && ${PAPERSIZE} != letter
+.BEGIN:
@${ECHO} "Invalid value for PAPERSIZE: \"${PAPERSIZE}\""
- @${ECHO} "Possible values are: A4 (default), and Letter."
+ @${ECHO} "Possible values are: a4, and letter."
@${FALSE}
.endif