aboutsummaryrefslogtreecommitdiff
path: root/print/cjk-lyx/Makefile
diff options
context:
space:
mode:
authorCHOI Junho <cjh@FreeBSD.org>2000-07-05 14:58:12 +0000
committerCHOI Junho <cjh@FreeBSD.org>2000-07-05 14:58:12 +0000
commit0ae505a66b9994b28577755374c4b85bc61c45fa (patch)
tree819590f0f6a4f88db5e0f89edc9775190d58194a /print/cjk-lyx/Makefile
parent9d73def274a799c21d99887afc6479fd0825056d (diff)
downloadports-0ae505a66b9994b28577755374c4b85bc61c45fa.tar.gz
ports-0ae505a66b9994b28577755374c4b85bc61c45fa.zip
Notes
Diffstat (limited to 'print/cjk-lyx/Makefile')
-rw-r--r--print/cjk-lyx/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/print/cjk-lyx/Makefile b/print/cjk-lyx/Makefile
new file mode 100644
index 000000000000..4a6531521995
--- /dev/null
+++ b/print/cjk-lyx/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: CJK-LyX
+# Date created: 2 Jul 2000
+# Whom: CHOI Junho <cjh@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lyx
+PORTVERSION= 1.1.4.3
+CATEGORIES= print
+MASTER_SITES= ftp://stone.phys.pusan.ac.kr/pub/CJK-LyX/
+PKGNAMEPREFIX= cjk-
+DISTNAME= CJK-LyX-1.1.4fix3-src
+
+MAINTAINER= cjh@FreeBSD.org
+
+BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
+.if defined(WITH_ISPELL)
+RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+.endif
+LIB_DEPENDS= xforms.0:${PORTSDIR}/x11-toolkits/xforms \
+ Xpm.4:${PORTSDIR}/graphics/xpm \
+ intl.1:${PORTSDIR}/devel/gettext
+
+USE_NEWGCC= yes
+USE_PERL5= yes
+USE_LIBTOOL= yes
+USE_GMAKE= yes
+CONFIGURE_ARGS= --with-extra-lib="${X11BASE}/lib ${LOCALBASE}/lib" \
+ --with-extra-inc="${X11BASE}/include ${LOCALBASE}/include"
+MAN1= lyx.1 reLyX.1
+WRKSRC= ${WRKDIR}/CJK-LyX-1.1.4fix3
+
+.if !defined(WITH_ISPELL)
+pre-fetch:
+ @${ECHO_MSG} "If you want this port built with spell checker support, use"
+ @${ECHO_MSG} "make WITH_ISPELL=yes"
+.endif
+
+post-patch:
+ (cd ${WRKSRC}; ${TOUCH} Makefile.in */Makefile.in src/config.h.in)
+
+.include <bsd.port.mk>