aboutsummaryrefslogtreecommitdiff
path: root/print/cjk-lyx
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2006-11-08 00:59:33 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2006-11-08 00:59:33 +0000
commitc2fd546aa9ac21f8e8a073aec314f6b4052b3d71 (patch)
treea0852797fa73f4ac65e220ab2dcb82fc27a5c7ff /print/cjk-lyx
parent48d38958e22df6e9bbdd1f49c6df05f8bc391247 (diff)
Notes
Diffstat (limited to 'print/cjk-lyx')
-rw-r--r--print/cjk-lyx/Makefile29
1 files changed, 23 insertions, 6 deletions
diff --git a/print/cjk-lyx/Makefile b/print/cjk-lyx/Makefile
index 25f1662eb67f..563595cfcf4f 100644
--- a/print/cjk-lyx/Makefile
+++ b/print/cjk-lyx/Makefile
@@ -26,26 +26,29 @@ PATCHFILES= patch-platex-${PORTVERSION}.diff
MAINTAINER= yokota@res.otaru-uc.ac.jp
COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG)
-LIB_DEPENDS= qt-mt:${PORTSDIR}/x11-toolkits/qt33
+LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost \
+ qt-mt:${PORTSDIR}/x11-toolkits/qt33
RUN_DEPENDS= ${X11BASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
CONFLICTS= lyx-*
OPTIONS= ASPELL "Utilize ASPELL library" on \
ISPELL "Depend on ISPELL as well" off
.if defined(LANG) && ${LANG:C/_.*//} == "ja"
-OPTIONS+= JA_TETEX "Use pLaTeX (Japanese LaTeX)" ON
+OPTIONS+= JATETEX "Use pLaTeX (Japanese LaTeX)" ON
.else
-OPTIONS+= JA_TETEX "Use pLaTeX (Japanese LaTeX)" OFF
+OPTIONS+= JATETEX "Use pLaTeX (Japanese LaTeX)" OFF
.endif
+ALL_TARGET= all check
USE_GNOME= gnometarget lthack
USE_PERL5= yes
USE_PYTHON= yes
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
-#EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch]
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch] --exclude ${PORTNAME}-${PORTVERSION}/boost
CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
+ --without-included-boost \
--with-extra-inc="${LOCALBASE}/include" \
--with-frontend=qt
CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
@@ -57,6 +60,17 @@ MAN1= lyx.1 tex2lyx.1 lyxclient.1
# Make uic stay off the lawn
MAKE_ENV= TMPDIR=/tmp
+post-patch:
+ # Removing mention of the bundled boost
+ ${REINPLACE_CMD} -e 's, boost/[^ ]*Makefile,,g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's,detail/nullstream,utils/nullstream,' \
+ ${WRKSRC}/src/pch.h ${WRKSRC}/src/support/pch.h \
+ ${WRKSRC}/src/support/debugstream.h
+ ${REINPLACE_CMD} -e 's,boost/regex\.hpp,boost/cregex.hpp,' \
+ ${WRKSRC}/src/support/filetools.C
+ ${REINPLACE_CMD} -e 's,/bin/bash,/bin/sh,' \
+ ${WRKSRC}/src/support/tests/test_*
+
post-configure:
# Removing explicit linking with -lc
${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
@@ -87,15 +101,18 @@ RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
.endif
# Choose appropriate settings for each LaTeX
-.if defined(WITH_JA_TETEX)
+.if defined(WITH_JATETEX)
+BUILD_DEPENDS+= latex:${PORTSDIR}/japanese/teTeX
RUN_DEPENDS+= latex:${PORTSDIR}/japanese/teTeX
-#PATCHFILES+= patch-platex-jpnonly-${PORTVERSION}.diff
.else
+BUILD_DEPENDS+= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS+= latex:${PORTSDIR}/print/teTeX
.endif
.if ${OSVERSION} < 500035
CFLAGS+= -Wno-non-template-friend -ftemplate-depth-30
+.elif ${OSVERSION} >= 700007 && ${ARCH} == i386 && ${CXX} == c++
+BROKEN= C++ compiler seg-faults, try using a different one and report to ${MAINTAINER}
.endif
.include <bsd.port.post.mk>