aboutsummaryrefslogtreecommitdiff
path: root/print/cups-base/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2009-02-03 12:58:33 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2009-02-03 12:58:33 +0000
commit624b3ba4f031f6b7061e4fbeb2632c382b27bec0 (patch)
tree9b6603d016415ff32a25590ebccf1a521fe675c6 /print/cups-base/Makefile
parent2db9ae46c95c6a871254402408c88e3f4ce9f756 (diff)
downloadports-624b3ba4f031f6b7061e4fbeb2632c382b27bec0.tar.gz
ports-624b3ba4f031f6b7061e4fbeb2632c382b27bec0.zip
Notes
Diffstat (limited to 'print/cups-base/Makefile')
-rw-r--r--print/cups-base/Makefile12
1 files changed, 10 insertions, 2 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index de566865453f..86878a99f4e2 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -51,7 +51,8 @@ OPTIONS= GNUTLS "Build with GNUTLS library" on \
PAM "Build with PAM support" off \
LDAP "Build with LDAP support" off \
DBUS "Build with DBUS support" off \
- XDG_OPEN "Build with XDG_OPEN support" off
+ XDG_OPEN "Build with XDG_OPEN as browser" off \
+ GVFS_OPEN "Build with GVFS_OPEN as browser" off
CUPS_ETCDIR= ${PREFIX}/etc/cups
CUPS_SPOOLDIR= /var/spool/cups
@@ -132,7 +133,11 @@ CONFIGURE_ARGS+= --disable-dbus
.endif
.if defined(WITH_XDG_OPEN)
-RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
+RUN_DEPENDS+= xdg-open:${PORTSDIR}/devel/xdg-utils
+.endif
+
+.if defined(WITH_GVFS_OPEN)
+RUN_DEPENDS+= gvfs-open:${PORTSDIR}/devel/gvfs
.endif
MAN1EXT= 1
@@ -190,6 +195,9 @@ post-configure:
.endif
post-patch:
+.if defined(WITH_GVFS_OPEN)
+ @${REINPLACE_CMD} -e 's|htmlview|gvfs-open|' ${WRKSRC}/desktop/cups.desktop
+.endif
.if defined(WITH_XDG_OPEN)
@${REINPLACE_CMD} -e 's|htmlview|xdg-open|' ${WRKSRC}/desktop/cups.desktop
.endif