aboutsummaryrefslogtreecommitdiff
path: root/print/cups-base/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2006-06-22 20:16:06 +0000
committerMichael Johnson <ahze@FreeBSD.org>2006-06-22 20:16:06 +0000
commit2bc3fec6c8d665da4d17cfc76fe23a2898063809 (patch)
tree4d15bee3084773b1e63be6f5996ee86a264b6655 /print/cups-base/Makefile
parentcfd249a51c991295f0c69ebafdc295d3897f9424 (diff)
Notes
Diffstat (limited to 'print/cups-base/Makefile')
-rw-r--r--print/cups-base/Makefile147
1 files changed, 127 insertions, 20 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 3caa20039b4b..d59dae9258b3 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -8,50 +8,157 @@
#
PORTNAME= cups-base
-PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= 9
-PORTEPOCH= ${CUPS_PORTEPOCH}
+PORTVERSION= 1.2.0
+PORTREVISION= 1
CATEGORIES= print
-MASTER_SITES= ${CUPS_MASTER_SITES}
+MASTER_SITES= ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${PORTVERSION}/ \
+ ftp://ftp.ntua.gr/pub/gnu/cups/${PORTVERSION}/ \
+ ftp://ftp.easysw.com/pub/cups/${PORTVERSION}/ \
+ ftp://ftp.fisek.com.tr/pub/cups/${PORTVERSION}/ \
+ ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${PORTVERSION}/
+DISTNAME= cups-${PORTVERSION}-source
MAINTAINER= asa@agava.com
-COMMENT= The Common UNIX Printing System: headers, libs, & daemons
+COMMENT= The Common UNIX Printing System
INSTALLS_SHLIB= yes
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_PERL5_RUN= yes
+GNU_CONFIGURE= yes
USE_RC_SUBR= cupsd
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
-MANLANG= "" es fr
+OPTIONS= GNUTLS "Build with GNUTLS library" on \
+ PHP "Build PHP support" off \
+ PYTHON "Build PYTHON support" off \
+ LIBPAPER "Build with libpaper support" off
+
+CUPS_FILESDIR= ${.CURDIR}/../../print/cups/files
+CUPS_ETCDIR= ${PREFIX}/etc/cups
+CUPS_RCDIR= ${PREFIX}/etc/rc.d
+CUPS_DOCSDIR= ${PREFIX}/share/doc/cups
+CUPS_SPOOLDIR= /var/spool/cups
+CUPS_SOCKET?= /var/run/cups.sock
+WRKSRC= ${WRKDIR}/cups-${PORTVERSION}
+
+# file, dir ownership
+CUPSGRP= cups
+CUPSOWN= cups
+CUPSSYSGRP= wheel
+
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+CONFIGURE_ARGS+= --localstatedir=/var \
+ --disable-pam \
+ --disable-slp \
+ --with-cups-user=${CUPSOWN} \
+ --with-cups-group=${CUPSGRP} \
+ --with-system-groups=${CUPSSYSGRP} \
+ --with-docdir=${CUPS_DOCSDIR} \
+ --with-rcdir=${CUPS_RCDIR} \
+ --with-domainsocket=${CUPS_SOCKET}
+
+.if !defined(WITHOUT_GNUTLS)
+CONFIGURE_ARGS+= --enable-gnutls --disable-openssl
+LIB_DEPENDS+= gnutls-openssl.15:${PORTSDIR}/security/gnutls
+.endif
+
+.if defined(WITH_PHP)
+CONFIGURE_ARGS+= --with-php
+RUN_DEPENDS+= php:${PORTSDIR}/lang/php4
+.endif
+
+.if defined(WITH_PYTHON)
+CONFIGURE_ARGS+= --with-python
+USE_PYTHON= yes
+.endif
+
+.if defined(WITH_LIBPAPER)
+CONFIGURE_ARGS+= --enable-libpaper
+LIB_DEPENDS+= paper.2:${PORTSDIR}/print/libpaper
+.endif
+
+CONFIGURE_ARGS+= CPPFLAGS="-I.. -I${LOCALBASE}/include"
+CONFIGURE_ARGS+= DSOFLAGS="-Wl,-rpath,${PREFIX}/lib -L${PREFIX}/lib"
+CONFIGURE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1EXT= 1
+MAN5EXT= 5
+MAN7EXT= 7
+MAN8EXT= 8
+
+MAN1= cancel.$(MAN1EXT) \
+ cups-config.$(MAN1EXT) \
+ cupstestdsc.$(MAN1EXT) \
+ cupstestppd.$(MAN1EXT) \
+ lp.$(MAN1EXT) \
+ lpoptions.$(MAN1EXT) \
+ lppasswd.$(MAN1EXT) \
+ lpq.$(MAN1EXT) \
+ lprm.$(MAN1EXT) \
+ lpr.$(MAN1EXT) \
+ lpstat.$(MAN1EXT)
+MAN5= classes.conf.$(MAN5EXT) \
+ client.conf.$(MAN5EXT) \
+ cups-snmp.conf.$(MAN5EXT) \
+ cupsd.conf.$(MAN5EXT) \
+ mime.convs.$(MAN5EXT) \
+ mime.types.$(MAN5EXT) \
+ printers.conf.$(MAN5EXT) \
+ subscriptions.conf.$(MAN5EXT)
+MAN7= backend.$(MAN7EXT) \
+ filter.$(MAN7EXT)
+MAN8= accept.$(MAN8EXT) \
+ cupsaddsmb.$(MAN8EXT) \
+ cups-deviced.$(MAN8EXT) \
+ cups-driverd.$(MAN8EXT) \
+ cups-lpd.$(MAN8EXT) \
+ cups-polld.$(MAN8EXT) \
+ cupsd.$(MAN8EXT) \
+ cupsenable.$(MAN8EXT) \
+ lpadmin.$(MAN8EXT) \
+ lpinfo.$(MAN8EXT) \
+ lpmove.$(MAN8EXT) \
+ lpc.$(MAN8EXT) \
+
+pre-configure::
+ @${ECHO_MSG} Configuring CUPS with options:
+ @${ECHO_MSG} ${CONFIGURE_ARGS} | fmt
post-patch:
- @${REINPLACE_CMD} -e '/SILENT/d' \
+ @${REINPLACE_CMD} -e '/SILENT/d;\
+ s|@SSLFLAGS@|@SSLFLAGS@ -I${LOCALBASE}/include|; \
+ s|@SSLLIBS@|@SSLLIBS@ -L${LOCALBASE}/lib|' \
${WRKSRC}/Makedefs.in
- @${REINPLACE_CMD} -e '/LN/d' -e '/cat/d' \
- ${WRKSRC}/man/Makefile ${WRKSRC}/man/es/Makefile
- @${REINPLACE_CMD} -e '/LN/d' -e '/cat/d' \
- ${WRKSRC}/man/Makefile ${WRKSRC}/man/fr/Makefile
@${REINPLACE_CMD} -e 's|/etc/cups|/usr/local/etc/cups|g' \
- ${WRKSRC}/man/*.man
+ ${WRKSRC}/man/*.man*
@${REINPLACE_CMD} -e 's|CXX="$$CC"||g' \
${WRKSRC}/${CONFIGURE_SCRIPT}
pre-install:
@${ECHO_MSG} "===>" Stopping cupsd ...
-killall cupsd || ${TRUE}
- ${RMDIR} ${PREFIX}/etc/cups/certs/* || ${TRUE}
post-install:
${MKDIR} ${CUPS_ETCDIR}
-.for f in classes.conf client.conf cupsd.conf printers.conf mime.convs mime.types
+.ifdef CUPS_OVERWRITE_BASE
+ ${SH} ${PKGINSTALL} placeholder POST-INSTALL overwrite
+.endif
+ ${SH} ${PKGINSTALL} placeholder POST-INSTALL
+.for f in cupsd.conf mime.convs mime.types
${INSTALL_DATA} ${WRKSRC}/conf/${f} ${CUPS_ETCDIR}/${f}.N
cd ${CUPS_ETCDIR}; if test ! -f ${f}; then ${CP} -p ${f}.N ${f}; fi
-.endfor # classes.conf client.conf cupsd.conf printers.conf
- ${FIND} ${PREFIX}/man/cat* -type l -name '*.0' -delete
+.endfor # cupsd.conf mime.convs mime.types
+# ${FIND} ${PREFIX}/man/cat* -type l -name '*.0' -delete
${MKDIR} ${CUPS_SPOOLDIR} ${CUPS_SPOOLDIR}/tmp
${CHOWN} -R ${CUPSOWN}:${CUPSGRP} ${CUPS_SPOOLDIR}
${CHMOD} -R g+w ${CUPS_SPOOLDIR}
@${SED} -e 's#PREFIX#${PREFIX}#' ${PKGMESSAGE}
-.include "${.CURDIR}/../../print/cups/Makefile.common"
-.include <bsd.port.pre.mk>
-.include "${FILESDIR}/manpages.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>