aboutsummaryrefslogtreecommitdiff
path: root/print/cups-base
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2008-03-04 12:00:15 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2008-03-04 12:00:15 +0000
commita74ba08bc7145480995be19e469d06d28d73820a (patch)
treeca0ecd75c42d0ba9794629aa2f3668a83ce436d7 /print/cups-base
parent8732c6010b85851f6a68c84f0811ca44892cbf50 (diff)
Notes
Diffstat (limited to 'print/cups-base')
-rw-r--r--print/cups-base/Makefile5
-rw-r--r--print/cups-base/files/patch-auth.c12
2 files changed, 17 insertions, 0 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 071f7b979a4f..e91ccf33f3b7 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -172,6 +172,11 @@ pre-configure::
@${ECHO_MSG} Configuring CUPS with options:
@${ECHO_MSG} ${CONFIGURE_ARGS} | fmt
+.if defined(WITH_PAM)
+post-configure:
+ ${GREP} -v pam_securityserver ${WRKSRC}/conf/pam.darwin > ${WRKSRC}/conf/pam.std
+.endif
+
post-patch:
@${REINPLACE_CMD} -e '/SILENT/d' ${WRKSRC}/Makedefs.in
@${REINPLACE_CMD} -e '/share/s|/usr/share|${PREFIX}/share|g' ${WRKSRC}/Makefile
diff --git a/print/cups-base/files/patch-auth.c b/print/cups-base/files/patch-auth.c
new file mode 100644
index 000000000000..1324eb958f75
--- /dev/null
+++ b/print/cups-base/files/patch-auth.c
@@ -0,0 +1,12 @@
+--- scheduler/auth.c.orig 2008-03-03 20:49:42.000000000 +0300
++++ scheduler/auth.c 2008-03-03 20:53:19.000000000 +0300
+@@ -652,8 +652,7 @@
+ {
+ cupsdLogMessage(CUPSD_LOG_ERROR,
+ "cupsdAuthorize: pam_start() returned %d (%s)!\n",
+- pamerr, pam_strerror(pamh, pamerr));
+- pam_end(pamh, 0);
++ pamerr, pam_strerror(NULL, pamerr));
+ return;
+ }
+