aboutsummaryrefslogtreecommitdiff
path: root/print/cups-base
diff options
context:
space:
mode:
authorJosef El-Rayes <josef@FreeBSD.org>2004-12-24 23:17:44 +0000
committerJosef El-Rayes <josef@FreeBSD.org>2004-12-24 23:17:44 +0000
commitba9d5bd94589a61b5a24cb234f57df8e498a2df9 (patch)
tree94b26b56dceaf25283aa694e48fb4922c33dcdbe /print/cups-base
parent7afc38b6237da75ce883ff39d388d90c5988ece5 (diff)
downloadports-ba9d5bd94589a61b5a24cb234f57df8e498a2df9.tar.gz
ports-ba9d5bd94589a61b5a24cb234f57df8e498a2df9.zip
Notes
Diffstat (limited to 'print/cups-base')
-rw-r--r--print/cups-base/Makefile2
-rw-r--r--print/cups-base/files/patch-pdftops-Gfx.cc29
2 files changed, 30 insertions, 1 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 0c6d23c176e2..8f8b1b8136d1 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -9,7 +9,7 @@
PORTNAME= cups-base
PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= ${CUPS_PORTREV}
+PORTREVISION= 1
PORTEPOCH= ${CUPS_PORTEPOCH}
CATEGORIES= print
MASTER_SITES= ${CUPS_MASTER_SITES}
diff --git a/print/cups-base/files/patch-pdftops-Gfx.cc b/print/cups-base/files/patch-pdftops-Gfx.cc
new file mode 100644
index 000000000000..5ec60d90d8c1
--- /dev/null
+++ b/print/cups-base/files/patch-pdftops-Gfx.cc
@@ -0,0 +1,29 @@
+diff -ruN pdftops/Gfx.cxx /home/josef//temp/pdftops/Gfx.cxx
+--- pdftops/Gfx.cxx Fri Apr 9 22:18:31 2004
++++ /home/josef//temp/pdftops/Gfx.cxx Fri Dec 24 20:21:32 2004
+@@ -2655,7 +2655,9 @@
+ haveMask = gFalse;
+ dict->lookup("Mask", &maskObj);
+ if (maskObj.isArray()) {
+- for (i = 0; i < maskObj.arrayGetLength(); ++i) {
++ for (i = 0;
++ i < maskObj.arrayGetLength() && i < 2*gfxColorMaxComps;
++ ++i) {
+ maskObj.arrayGet(i, &obj1);
+ maskColors[i] = obj1.getInt();
+ obj1.free();
+diff -ruN pdftops/GfxState.cxx /home/josef//temp/pdftops/GfxState.cxx
+--- pdftops/GfxState.cxx Mon Feb 2 23:41:09 2004
++++ /home/josef//temp/pdftops/GfxState.cxx Fri Dec 24 20:21:32 2004
+@@ -708,6 +708,11 @@
+ }
+ nCompsA = obj2.getInt();
+ obj2.free();
++ if (nCompsA > gfxColorMaxComps) {
++ error(-1, "ICCBased color space with too many (%d > %d) components",
++ nCompsA, gfxColorMaxComps);
++ nCompsA = gfxColorMaxComps;
++ }
+ if (dict->lookup("Alternate", &obj2)->isNull() ||
+ !(altA = GfxColorSpace::parse(&obj2))) {
+ switch (nCompsA) {