aboutsummaryrefslogtreecommitdiff
path: root/print/cups-base
diff options
context:
space:
mode:
authorJacques Vidrine <nectar@FreeBSD.org>2002-02-23 16:46:58 +0000
committerJacques Vidrine <nectar@FreeBSD.org>2002-02-23 16:46:58 +0000
commitd16b0f3a13066018e0c9b53d4647c02b0249fae1 (patch)
tree07720ff9dadcddcc8e78ed44a1fe13e9085d9bc4 /print/cups-base
parente5fdc91f4424111ee42657869e9c4c81b5b59603 (diff)
downloadports-d16b0f3a13066018e0c9b53d4647c02b0249fae1.tar.gz
ports-d16b0f3a13066018e0c9b53d4647c02b0249fae1.zip
Notes
Diffstat (limited to 'print/cups-base')
-rw-r--r--print/cups-base/Makefile21
-rw-r--r--print/cups-base/distinfo2
-rw-r--r--print/cups-base/files/patch-configure18
-rw-r--r--print/cups-base/files/patch-cups.sh.in21
-rw-r--r--print/cups-base/files/patch-data-Makefile10
-rw-r--r--print/cups-base/pkg-plist19
6 files changed, 53 insertions, 38 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index f9a67ed3dcb9..7ad28981af76 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -6,27 +6,12 @@
#
PORTNAME= cups-base
-PORTVERSION= ${VERSION}
-PORTREVISION= 2
+PORTVERSION= ${CUPS_VERSION}
CATEGORIES= print
-MASTER_SITES= ftp://ftp.easysw.com/pub/cups/${VERSION}/ \
- ftp://ftp2.easysw.com/pub/cups/${VERSION}/ \
- ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${VERSION}/ \
- ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${VERSION}/
-DISTNAME= cups-${VERSION}-source
-
MAINTAINER= jah4007@cs.rit.edu
-VERSION= 1.1.12
-
-USE_BZIP2= yes
INSTALLS_SHLIB= yes
-WRKSRC= ${WRKDIR}/cups-${VERSION}
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --localstatedir=/var
-
MAN1= backend.1 filter.1
MAN3= cups-config.3
MAN5= classes.conf.5 cupsd.conf.5 mime.convs.5 mime.types.5 \
@@ -46,4 +31,6 @@ post-install:
${PREFIX}/etc/rc.d/cupsd.sh.sample
@${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/print/cups/Makefile.inc"
+.include <bsd.port.post.mk>
diff --git a/print/cups-base/distinfo b/print/cups-base/distinfo
index 14e622162ea1..f871858bea1c 100644
--- a/print/cups-base/distinfo
+++ b/print/cups-base/distinfo
@@ -1 +1 @@
-MD5 (cups-1.1.12-source.tar.bz2) = 18e74aa115e9fdaa569685e6351f0ebc
+MD5 (cups-1.1.14-source.tar.bz2) = 7cc9725d94568b24f5ade78fb7e26480
diff --git a/print/cups-base/files/patch-configure b/print/cups-base/files/patch-configure
new file mode 100644
index 000000000000..9e48416b54e6
--- /dev/null
+++ b/print/cups-base/files/patch-configure
@@ -0,0 +1,18 @@
+--- configure.old Tue Feb 5 11:17:34 2002
++++ configure Tue Feb 5 11:18:00 2002
+@@ -3224,13 +3224,13 @@
+ DSO="\$(CC)"
+ DSOFLAGS="$DSOFLAGS -Wl,-rpath,\$(libdir),-set_version,sgi2.4,-soname,\$@ -shared \$(OPTIM)"
+ ;;
+- OSF1* | Linux* | NetBSD* | OpenBSD*)
++ OSF1* | Linux* | NetBSD* | OpenBSD* | FreeBSD*)
+ LIBCUPS="libcups.so.2"
+ LIBCUPSIMAGE="libcupsimage.so.2"
+ DSO="\$(CC)"
+ DSOFLAGS="$DSOFLAGS -Wl,-soname,\$@ -shared \$(OPTIM)"
+ ;;
+- Darwin* | FreeBSD*)
++ Darwin*)
+ LIBCUPS="libcups.2.dylib"
+ LIBCUPSIMAGE="libcupsimage.2.dylib"
+ DSO="ld"
diff --git a/print/cups-base/files/patch-cups.sh.in b/print/cups-base/files/patch-cups.sh.in
index 66c8738ba614..cad2eaf28948 100644
--- a/print/cups-base/files/patch-cups.sh.in
+++ b/print/cups-base/files/patch-cups.sh.in
@@ -1,7 +1,7 @@
---- cups.sh.in.orig Fri Nov 2 15:43:10 2001
-+++ cups.sh.in Sat Nov 17 12:25:49 2001
-@@ -63,6 +63,10 @@
- IS_ON=:
+--- cups.sh.in.orig Sat Feb 2 23:26:44 2002
++++ cups.sh.in Sat Feb 2 23:27:07 2002
+@@ -78,6 +78,10 @@
+ IS_ON=/bin/true
;;
+ FreeBSD*)
@@ -11,16 +11,7 @@
*)
IS_ON=/bin/true
;;
-@@ -104,7 +108,7 @@
- OSF1*)
- pid=`ps -e | awk '{if (match($5, ".*/cupsd$") || $5 == "cupsd") print $1}'`
- ;;
-- Linux* | NetBSD* | Darwin*)
-+ Linux* | NetBSD* | Darwin* | FreeBSD*)
- pid=`ps ax | awk '{if (match($5, ".*/cupsd$") || $5 == "cupsd") print $1}'`
- ;;
- *)
-@@ -126,7 +130,8 @@
+@@ -141,7 +145,8 @@
exec_prefix=@exec_prefix@
@sbindir@/cupsd
fi
@@ -30,7 +21,7 @@
else
$ECHO "cups: scheduler stopped."
fi
-@@ -135,7 +140,8 @@
+@@ -150,7 +155,8 @@
stop)
if test "$pid" != ""; then
kill $pid
diff --git a/print/cups-base/files/patch-data-Makefile b/print/cups-base/files/patch-data-Makefile
index 508fc84eea58..b5c974148dec 100644
--- a/print/cups-base/files/patch-data-Makefile
+++ b/print/cups-base/files/patch-data-Makefile
@@ -1,10 +1,10 @@
---- data/Makefile.orig Sat Aug 18 10:38:01 2001
-+++ data/Makefile Sat Aug 18 10:39:25 2001
-@@ -93,14 +93,14 @@
+--- data/Makefile.orig Thu Jan 31 09:53:42 2002
++++ data/Makefile Sat Feb 2 23:34:44 2002
+@@ -97,14 +97,14 @@
for file in $(DATAFILES); do \
$(INSTALL_DATA) $$file $(DATADIR)/data; \
done
-- -if test x$(PAMDIR) != x; then \
+- -if test x$(PAMDIR) != x$(BUILDROOT); then \
- $(INSTALL_DIR) $(PAMDIR); \
- if test -f /lib/security/pam_unix.so; then \
- $(INSTALL_DATA) cups.suse $(PAMDIR)/cups; \
@@ -12,7 +12,7 @@
- $(INSTALL_DATA) cups.pam $(PAMDIR)/cups; \
- fi \
- fi
-+# -if test x$(PAMDIR) != x; then \
++# -if test x$(PAMDIR) != x$(BUILDROOT); then \
+# $(INSTALL_DIR) $(PAMDIR); \
+# if test -f /lib/security/pam_unix.so; then \
+# $(INSTALL_DATA) cups.suse $(PAMDIR)/cups; \
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index ab15b6c2ef9d..7c9c017bc8d5 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -16,6 +16,7 @@ etc/cups/printers.conf.sample
@exec test -f %B/printers.conf || cp %B/%f %B/printers.conf
include/cups/cups.h
include/cups/http.h
+include/cups/image.h
include/cups/ipp.h
include/cups/language.h
include/cups/md5.h
@@ -69,6 +70,8 @@ share/cups/charsets/iso-8859-6
share/cups/charsets/iso-8859-7
share/cups/charsets/iso-8859-8
share/cups/charsets/iso-8859-9
+share/cups/charsets/koi8-r
+share/cups/charsets/koi8-u
share/cups/charsets/utf-8
share/cups/charsets/windows-1250
share/cups/charsets/windows-1251
@@ -287,12 +290,20 @@ share/doc/cups/sum.pdf
share/doc/cups/svd.html
share/doc/cups/svd.pdf
share/locale/C/cups_C
+share/locale/be/cups_be
share/locale/cs/cups_cs
share/locale/de/cups_de
share/locale/en/cups_en
share/locale/es/cups_es
share/locale/fr/cups_fr
+share/locale/he/cups_he
share/locale/it/cups_it
+share/locale/ru_RU.cp1251/cups_ru_RU.cp1251
+share/locale/ru_RU.koi8r/cups_ru_RU.koi8r
+share/locale/sv/cups_sv
+share/locale/uk/cups_uk
+share/locale/uk_UA.cp1251/cups_uk_UA.cp1251
+share/locale/zh_CN/cups_zh_CN
@exec mkdir -p /var/log/cups
@unexec rmdir /var/log/cups 2>/dev/null || true
@exec mkdir -p /var/spool/cups/tmp
@@ -325,10 +336,18 @@ share/locale/it/cups_it
@dirrm share/doc/cups/images
@dirrm share/doc/cups
@dirrm share/locale/C
+@dirrm share/locale/be
@dirrm share/locale/cs
@dirrm share/locale/de
@dirrm share/locale/en
@dirrm share/locale/es
@dirrm share/locale/fr
+@dirrm share/locale/he
@dirrm share/locale/it
+@dirrm share/locale/ru_RU.cp1251
+@dirrm share/locale/ru_RU.koi8r
+@dirrm share/locale/sv
+@dirrm share/locale/uk
+@dirrm share/locale/uk_UA.cp1251
+@dirrm share/locale/zh_CN
@dirrm share/locale