aboutsummaryrefslogtreecommitdiff
path: root/print/cups-magicolor
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-05 21:08:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-05 21:08:12 +0000
commitdccbd9e5a98f2261e80ac52331dd7faf972a82d4 (patch)
tree9ebc5388ef63424e96a04bc3fb7df90737267eb2 /print/cups-magicolor
parentfc2a4229b39a66369bd8187e9c9158d302c9dbc2 (diff)
downloadports-dccbd9e5a98f2261e80ac52331dd7faf972a82d4.tar.gz
ports-dccbd9e5a98f2261e80ac52331dd7faf972a82d4.zip
Notes
Diffstat (limited to 'print/cups-magicolor')
-rw-r--r--print/cups-magicolor/Makefile19
-rw-r--r--print/cups-magicolor/distinfo6
-rw-r--r--print/cups-magicolor/files/patch-Makefile33
-rw-r--r--print/cups-magicolor/files/patch-configure.in11
-rw-r--r--print/cups-magicolor/files/patch-kmlf.h11
-rw-r--r--print/cups-magicolor/files/patch-rastertokmlf.c25
-rw-r--r--print/cups-magicolor/pkg-plist9
7 files changed, 31 insertions, 83 deletions
diff --git a/print/cups-magicolor/Makefile b/print/cups-magicolor/Makefile
index bbe64dc868cb..3513df7cda28 100644
--- a/print/cups-magicolor/Makefile
+++ b/print/cups-magicolor/Makefile
@@ -6,24 +6,31 @@
#
PORTNAME= cups-magicolor
-PORTVERSION= 1.1.0
+PORTVERSION= 1.5.0
CATEGORIES= print
-MASTER_SITES= ftp://ftp.minolta-qms.com/pub/crc/out_going/other/
+MASTER_SITES= http://printer.konicaminolta.net/drivers/linux/
+DISTNAME= 2430DL_sc_linux
MAINTAINER= frank@exit.com
COMMENT= CUPS support for the Konica-Minolta Magicolor 2430DL
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/print/cups-base:configure
+#BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/print/cups-base:configure
LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base \
jbig.1:${PORTSDIR}/graphics/jbigkit \
lcms.1:${PORTSDIR}/graphics/lcms
RUN_DEPENDS= espgs:${PORTSDIR}/print/cups-pstoraster
-DISTNAME= magicolor2430DL-1.1.0
+WRKSRC= ${WRKDIR}/magicolor2430DL-${PORTVERSION}
+
+USE_AUTOTOOLS= automake:19:env autoconf:259
USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
-do-configure:
- ${CP} ${WRKSRC}/../../../cups-base/work/cups-*/config.h ${WRKSRC}
+.if ${OSVERSION} < 500000
+BROKEN= Does not compile on 4.x
+.endif
.include <bsd.port.mk>
diff --git a/print/cups-magicolor/distinfo b/print/cups-magicolor/distinfo
index 58f304b1ea80..487cfc565415 100644
--- a/print/cups-magicolor/distinfo
+++ b/print/cups-magicolor/distinfo
@@ -1,3 +1,3 @@
-MD5 (magicolor2430DL-1.1.0.tar.gz) = d58ad3835e1a19c9de88d45a8ada1215
-SHA256 (magicolor2430DL-1.1.0.tar.gz) = 6339ccae0640102e9bcb336b1a29e25ac5757aec71790ed7bc026dad64512256
-SIZE (magicolor2430DL-1.1.0.tar.gz) = 989276
+MD5 (2430DL_sc_linux.tar.gz) = 63777c64ca8e50823dce1a6f3ec49ab4
+SHA256 (2430DL_sc_linux.tar.gz) = 6117a12390896ec346665b5b91d88edad7a158eeb60c589d92c4d25558870922
+SIZE (2430DL_sc_linux.tar.gz) = 1041864
diff --git a/print/cups-magicolor/files/patch-Makefile b/print/cups-magicolor/files/patch-Makefile
deleted file mode 100644
index d1c05f4e816c..000000000000
--- a/print/cups-magicolor/files/patch-Makefile
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./Makefile Fri Sep 17 17:33:59 2004
-+++ ../magicolor2430DL-1.1.0-new/./Makefile Thu Jul 28 19:51:27 2005
-@@ -1,11 +1,11 @@
- CC = gcc
--CFLAGS = $(RC_CFLAGS) -I. -I../include
-+CFLAGS = $(RC_CFLAGS) -I. -I../include -I/usr/local/include
- OPTIM = -Wall -fPIC -O2
- #OPTIM = -g
--LDLIBS = -lcups -lcupsimage
--LDADD = /usr/lib/liblcms.a /usr/local/lib/libjbig.a
-+LDLIBS = -L/usr/local/lib -lcups -lcupsimage
-+LDADD = /usr/local/lib/liblcms.a /usr/local/lib/libjbig.a
-
--MYPRINTER = /usr/local/KONICA_MINOLTA/mc2430DL
-+MYPRINTER = /usr/local/share/KONICA_MINOLTA/mc2430DL
-
- .SILENT:
- .SUFFIXES: .a .c .cxx .h .o .0 .1 .1m
-@@ -28,10 +28,10 @@
-
- #install the driver
- install: all
-- install -m 755 -d $(DESTDIR)/usr/lib/cups/filter
-- install -m 755 rastertokmlf $(DESTDIR)/usr/lib/cups/filter/rastertokm2430dl
-- install -m 755 -d $(DESTDIR)/usr/share/cups/model/KONICA_MINOLTA
-- install -m 644 km_en.ppd.gz $(DESTDIR)/usr/share/cups/model/KONICA_MINOLTA/km2430dl.ppd.gz
-+ install -m 755 -d $(DESTDIR)/usr/local/libexec/cups/filter
-+ install -m 755 rastertokmlf $(DESTDIR)/usr/local/libexec/cups/filter/rastertokm2430dl
-+ install -m 755 -d $(DESTDIR)/usr/local/share/cups/model/KONICA_MINOLTA
-+ install -m 644 km_en.ppd.gz $(DESTDIR)/usr/local/share/cups/model/KONICA_MINOLTA/km2430dl.ppd.gz
- install -m 755 -d $(DESTDIR)$(MYPRINTER)/Profiles
- install -m 644 km_0.icm $(DESTDIR)$(MYPRINTER)/Profiles/km_0.icm
- install -m 644 km_1.icm $(DESTDIR)$(MYPRINTER)/Profiles/km_1.icm
diff --git a/print/cups-magicolor/files/patch-configure.in b/print/cups-magicolor/files/patch-configure.in
new file mode 100644
index 000000000000..bf241fcd7bc6
--- /dev/null
+++ b/print/cups-magicolor/files/patch-configure.in
@@ -0,0 +1,11 @@
+--- configure.in.orig Tue May 31 15:46:41 2005
++++ configure.in Tue Dec 5 09:28:21 2006
+@@ -35,7 +35,7 @@
+
+ #filterdir=/usr/lib/cups/filter
+ #AC_SUBST(filterdir)
+-KM_PPDDIR=/usr/share/cups/model/KONICA_MINOLTA
++KM_PPDDIR=$datadir/cups/model/KONICA_MINOLTA
+ AC_SUBST(KM_PPDDIR)
+
+ UNAME=`(uname) 2>/dev/null || echo unknown`
diff --git a/print/cups-magicolor/files/patch-kmlf.h b/print/cups-magicolor/files/patch-kmlf.h
deleted file mode 100644
index 0dca272fbec7..000000000000
--- a/print/cups-magicolor/files/patch-kmlf.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./kmlf.h Thu Sep 2 11:18:38 2004
-+++ ../magicolor2430DL-1.1.0-new/./kmlf.h Thu Jul 28 18:56:32 2005
-@@ -38,6 +38,8 @@
-
- #ifdef __linux
- #define KM_FOLDER "/usr/local/KONICA_MINOLTA"
-+#elif defined(__FreeBSD__)
-+#define KM_FOLDER "/usr/local/share/KONICA_MINOLTA"
- #else
- #define KM_FOLDER "/Library/Printers/KONICA_MINOLTA"
- #endif
diff --git a/print/cups-magicolor/files/patch-rastertokmlf.c b/print/cups-magicolor/files/patch-rastertokmlf.c
deleted file mode 100644
index 160e2329cf40..000000000000
--- a/print/cups-magicolor/files/patch-rastertokmlf.c
+++ /dev/null
@@ -1,25 +0,0 @@
---- rastertokmlf.c.orig Thu Sep 2 20:18:38 2004
-+++ rastertokmlf.c Sat Oct 8 21:21:41 2005
-@@ -1339,6 +1339,7 @@
- DWORD x, y, iShift;//, dwWidthInByte;
- unsigned char bTmpCyan, bTmpMagenta, bTmpYellow, bTmpBlack, bit;
- //int err = 0;
-+ PHTHEADER pCHThdr, pMHThdr, pYHThdr, pKHThdr;
-
- /*
- * Make sure status messages are not buffered...
-@@ -1572,10 +1573,10 @@
- dwVert = header.cupsHeight;
- //dwWidthInByte = (dwHori + 7)/8;
-
-- PHTHEADER pCHThdr = (PHTHEADER)pImage->pHT[0];
-- PHTHEADER pMHThdr = (PHTHEADER)pImage->pHT[1];
-- PHTHEADER pYHThdr = (PHTHEADER)pImage->pHT[2];
-- PHTHEADER pKHThdr = (PHTHEADER)pImage->pHT[3];
-+ pCHThdr = (PHTHEADER)pImage->pHT[0];
-+ pMHThdr = (PHTHEADER)pImage->pHT[1];
-+ pYHThdr = (PHTHEADER)pImage->pHT[2];
-+ pKHThdr = (PHTHEADER)pImage->pHT[3];
-
- //pbSrc = pSrcBitmap;
- #ifdef CUPS_FLIP
diff --git a/print/cups-magicolor/pkg-plist b/print/cups-magicolor/pkg-plist
index 2790f783ace9..529af498e75a 100644
--- a/print/cups-magicolor/pkg-plist
+++ b/print/cups-magicolor/pkg-plist
@@ -1,8 +1,5 @@
libexec/cups/filter/rastertokm2430dl
share/cups/model/KONICA_MINOLTA/km2430dl.ppd.gz
-share/KONICA_MINOLTA/mc2430DL/Profiles/km_0.icm
-share/KONICA_MINOLTA/mc2430DL/Profiles/km_1.icm
-share/KONICA_MINOLTA/mc2430DL/Profiles/km_2.icm
share/KONICA_MINOLTA/mc2430DL/Halftones/km_ht_00.bmp
share/KONICA_MINOLTA/mc2430DL/Halftones/km_ht_01.bmp
share/KONICA_MINOLTA/mc2430DL/Halftones/km_ht_02.bmp
@@ -15,10 +12,12 @@ share/KONICA_MINOLTA/mc2430DL/Halftones/km_ht_20.bmp
share/KONICA_MINOLTA/mc2430DL/Halftones/km_ht_21.bmp
share/KONICA_MINOLTA/mc2430DL/Halftones/km_ht_22.bmp
share/KONICA_MINOLTA/mc2430DL/Halftones/km_ht_23.bmp
-share/KONICA_MINOLTA/mc2430DL/Installation
+share/KONICA_MINOLTA/mc2430DL/Profiles/km_0.icm
+share/KONICA_MINOLTA/mc2430DL/Profiles/km_1.icm
+share/KONICA_MINOLTA/mc2430DL/Profiles/km_2.icm
share/KONICA_MINOLTA/mc2430DL/COPYING
@dirrm share/KONICA_MINOLTA/mc2430DL/Profiles
@dirrm share/KONICA_MINOLTA/mc2430DL/Halftones
-@dirrm share/cups/model/KONICA_MINOLTA
@dirrm share/KONICA_MINOLTA/mc2430DL
@dirrm share/KONICA_MINOLTA
+@dirrm share/cups/model/KONICA_MINOLTA