aboutsummaryrefslogtreecommitdiff
path: root/print/cups-pdf
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-17 10:46:25 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2006-06-17 10:46:25 +0000
commita462c0c647e89c57efa9c07f93cd45db6aa12c27 (patch)
treebe9ce1281a68ec51d69701b9fcb5731f5eade147 /print/cups-pdf
parent8e9a7b9af554bf95dd3890a0266df5984582544e (diff)
downloadports-a462c0c647e89c57efa9c07f93cd45db6aa12c27.tar.gz
ports-a462c0c647e89c57efa9c07f93cd45db6aa12c27.zip
Notes
Diffstat (limited to 'print/cups-pdf')
-rw-r--r--print/cups-pdf/Makefile17
-rw-r--r--print/cups-pdf/distinfo6
-rw-r--r--print/cups-pdf/pkg-plist2
3 files changed, 14 insertions, 11 deletions
diff --git a/print/cups-pdf/Makefile b/print/cups-pdf/Makefile
index 3c5415dc19b7..2ae5a67aee4e 100644
--- a/print/cups-pdf/Makefile
+++ b/print/cups-pdf/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cups-pdf
-PORTVERSION= 2.4.0
+PORTVERSION= 2.4.1
CATEGORIES= print
MASTER_SITES= http://www.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/src/ \
http://olofsson.de/mirror/distfiles/
@@ -52,9 +52,12 @@ SUBST_CMD+= -e "s,\#Log /var/log/cups,Log ${LOG_DIRECTORY},"
.endif
pre-everything::
+.if !defined(PDF_VERSION) || !defined(HOME_SUBDIR) || \
+!defined(OUTPUT_DIRECTORY) || !defined(LOG_DIRECTORY)
@${ECHO_MSG} ""
@${ECHO_MSG} "You may use the following build options:"
@${ECHO_MSG} ""
+.endif
.if !defined(PDF_VERSION)
@${ECHO_MSG} "PDF_VERSION=1.2|1.3|1.4|1.5 PDF-version of PDF-files produced"
.endif
@@ -70,9 +73,6 @@ pre-everything::
@${ECHO_MSG} "LOG_DIRECTORY=<dir> Place logfile into <dir>/cups-pdf_log"
.endif
-post-extract:
- @${GUNZIP_CMD} ${WRKSRC}/extra/PostscriptColor.ppd.gz
-
post-configure:
@${REINPLACE_CMD} ${SUBST_CMD} ${WRKSRC}/extra/cups-pdf.conf
@${REINPLACE_CMD} -e \
@@ -84,16 +84,19 @@ do-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/cups-pdf ${LOCALBASE}/libexec/cups/backend
- ${INSTALL_DATA} ${WRKSRC}/extra/PostscriptColor.ppd ${LOCALBASE}/share/cups/model
+ ${INSTALL_DATA} ${WRKSRC}/extra/PostscriptColor_rev3b.ppd.gz \
+ ${LOCALBASE}/share/cups/model/PostscriptColor.ppd.gz
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/extra/cups-pdf.conf ${LOCALBASE}/etc/cups/cups-pdf.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/extra/cups-pdf.conf \
+ ${LOCALBASE}/etc/cups/cups-pdf.conf.sample
.endif
post-install:
@if [ ! -f ${LOCALBASE}/etc/cups/cups-pdf.conf ]; then \
- ${CP} -p ${LOCALBASE}/etc/cups/cups-pdf.conf.sample ${LOCALBASE}/etc/cups/cups-pdf.conf ; \
+ ${CP} -p ${LOCALBASE}/etc/cups/cups-pdf.conf.sample \
+ ${LOCALBASE}/etc/cups/cups-pdf.conf ; \
fi
.include <bsd.port.post.mk>
diff --git a/print/cups-pdf/distinfo b/print/cups-pdf/distinfo
index 2477e20b39f2..6d6396469660 100644
--- a/print/cups-pdf/distinfo
+++ b/print/cups-pdf/distinfo
@@ -1,3 +1,3 @@
-MD5 (cups-pdf_2.4.0.tar.gz) = e80555d7f58d90c2ad43f131745e09ac
-SHA256 (cups-pdf_2.4.0.tar.gz) = aef0f1e66de08ba6ac0ade30c4f6d75285843f59158d6805e0d32ce96fd7c790
-SIZE (cups-pdf_2.4.0.tar.gz) = 34421
+MD5 (cups-pdf_2.4.1.tar.gz) = 4cef6dd76d09dc2f7f3df133ef339b52
+SHA256 (cups-pdf_2.4.1.tar.gz) = 9b44b84c28d15f48e0ca0ae5191f0df5bc5600a72118a4ed29fee8a0812fa59b
+SIZE (cups-pdf_2.4.1.tar.gz) = 50448
diff --git a/print/cups-pdf/pkg-plist b/print/cups-pdf/pkg-plist
index 8713f9c7d659..c1bbb5444c4d 100644
--- a/print/cups-pdf/pkg-plist
+++ b/print/cups-pdf/pkg-plist
@@ -1,5 +1,5 @@
libexec/cups/backend/cups-pdf
-share/cups/model/PostscriptColor.ppd
+share/cups/model/PostscriptColor.ppd.gz
@unexec if cmp -s %D/etc/cups/cups-pdf.conf.sample %D/etc/cups/cups-pdf.conf; then rm -f %D/etc/cups/cups-pdf.conf; fi
etc/cups/cups-pdf.conf.sample
@exec if [ ! -f %D/etc/cups/cups-pdf.conf ] ; then cp -p %D/%F %B/cups-pdf.conf; fi