aboutsummaryrefslogtreecommitdiff
path: root/print/cups-pdf
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-06-17 20:00:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-06-17 20:00:24 +0000
commit9ed14aeafca73b75fbd25a86e36b6885980703d5 (patch)
tree62be3611816e1ecac8f2bed7be707651f0a9e597 /print/cups-pdf
parent1d57bd986a3e7207714da42e53ac9ac5790f5f7e (diff)
downloadports-9ed14aeafca73b75fbd25a86e36b6885980703d5.tar.gz
ports-9ed14aeafca73b75fbd25a86e36b6885980703d5.zip
Notes
Diffstat (limited to 'print/cups-pdf')
-rw-r--r--print/cups-pdf/Makefile85
-rw-r--r--print/cups-pdf/distinfo2
-rw-r--r--print/cups-pdf/pkg-descr10
-rw-r--r--print/cups-pdf/pkg-plist4
4 files changed, 101 insertions, 0 deletions
diff --git a/print/cups-pdf/Makefile b/print/cups-pdf/Makefile
new file mode 100644
index 000000000000..909a863cdb19
--- /dev/null
+++ b/print/cups-pdf/Makefile
@@ -0,0 +1,85 @@
+# New ports collection makefile for: cups-pdf
+# Date created: Jun 15 2004
+# Whom: Mark Reidel <ports@mark.reidel.info>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cups-pdf
+PORTVERSION= 1.4.2
+CATEGORIES= print
+MASTER_SITES= http://cip.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/
+DISTNAME= ${PORTNAME}_${PORTVERSION}a
+
+MAINTAINER= ports@mark.reidel.info
+COMMENT= A virtual printer for CUPS to produce PDF files
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/cupsd:${PORTSDIR}/print/cups-base
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}a
+
+.include <bsd.port.pre.mk>
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GHOSTSCRIPT_RUN= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --with-backenddir=${LOCALBASE}/libexec/cups/backend
+SUBST_CMD= -e "s,/usr/bin/gs,${LOCALBASE}/bin/gs,"
+
+.ifdef(PDF_VERSION)
+.if ${PDF_VERSION} == 1.2
+.elif ${PDF_VERSION} == 1.3
+.elif ${PDF_VERSION} == 1.4
+.elif ${PDF_VERSION} == 1.5
+.else
+BROKEN= "unsupported PDF-Version selected: ${PDF_VERSION}"
+.endif
+SUBST_CMD+= -e 's,CPPDFVER "1.4",CPPDFVER "${PDF_VERSION}",'
+.endif
+
+.ifdef(HOME_SUBDIR)
+SUBST_CMD+= -e 's,/var/spool/cups-pdf,$$HOME,' -e 's,CPHOMESUB "cups-pdf",CPHOMESUB "${HOME_SUBDIR}",'
+.else
+.ifdef(OUTPUT_DIRECTORY)
+SUBST_CMD+= -e "s,/var/spool/cups-pdf,${OUTPUT_DIRECTORY},"
+.endif
+.endif
+
+.ifdef(LOG_DIRECTORY)
+SUBST_CMD+= -e "s,/var/log/cups,${LOG_DIRECTORY},"
+.endif
+
+pre-fetch:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "You may use the following build options:"
+ @${ECHO_MSG} ""
+.if !defined(PDF_VERSION)
+ @${ECHO_MSG} "PDF_VERSION=1.2|1.3|1.4|1.5 PDF-version of PDF-files produced"
+.endif
+.if !defined(HOME_SUBDIR)
+ @${ECHO_MSG} "HOME_SUBDIR=<subdir> Place produced PDF-files in the"
+ @${ECHO_MSG} " directory ~/<subdir>/"
+.endif
+.if !defined(OUTPUT_DIRECTORY)
+ @${ECHO_MSG} "OUTPUT_DIRECTORY=<dir> Place produced PDF-files in the"
+ @${ECHO_MSG} " directory <dir>/"
+.endif
+.if !defined(LOG_DIRECTORY)
+ @${ECHO_MSG} "LOG_DIRECTORY=<dir> Place logfile into <dir>/cups-pdf_log"
+.endif
+
+post-configure:
+ @${REINPLACE_CMD} ${SUBST_CMD} ${WRKSRC}/src/cups-pdf.h
+ @${GUNZIP_CMD} ${WRKSRC}/extra/PostscriptColor.ppd.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/cups-pdf ${LOCALBASE}/libexec/cups/backend
+ ${INSTALL_DATA} ${WRKSRC}/extra/PostscriptColor.ppd ${LOCALBASE}/share/cups/model
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/print/cups-pdf/distinfo b/print/cups-pdf/distinfo
new file mode 100644
index 000000000000..9d102bcb9da6
--- /dev/null
+++ b/print/cups-pdf/distinfo
@@ -0,0 +1,2 @@
+MD5 (cups-pdf_1.4.2a.tar.gz) = 39a207ad22ce1d1b3cae7ee853c53b7f
+SIZE (cups-pdf_1.4.2a.tar.gz) = 114018
diff --git a/print/cups-pdf/pkg-descr b/print/cups-pdf/pkg-descr
new file mode 100644
index 000000000000..690ec6e166dc
--- /dev/null
+++ b/print/cups-pdf/pkg-descr
@@ -0,0 +1,10 @@
+CUPS-PDF is designed to produce PDF files in a heterogeneous network by
+providing a PDF printer on the central fileserver.
+
+After restarting CUPS, you will be able to choose
+"Virtual Printer (PDF Printer)" when setting up a new printer in CUPS.
+
+Once you print to the new device all converted PDF files will be placed in
+the specified directory.
+
+WWW: http://cip.physik.uni-wuerzburg.de/~vrbehr/cups-pdf/
diff --git a/print/cups-pdf/pkg-plist b/print/cups-pdf/pkg-plist
new file mode 100644
index 000000000000..2cf9222ba7fc
--- /dev/null
+++ b/print/cups-pdf/pkg-plist
@@ -0,0 +1,4 @@
+libexec/cups/backend/cups-pdf
+share/cups/model/PostscriptColor.ppd
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%@dirrm %%DOCSDIR%%