aboutsummaryrefslogtreecommitdiff
path: root/print/cups-pk-helper/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-05-10 21:19:08 +0000
commit48e62d9a379cd45a15f6ae89d564f81b3c13d16e (patch)
treeb627baa77f19bb1eab2fa4dee08aab1908131cd0 /print/cups-pk-helper/Makefile
parentfbdf96410f8e803568c33397323dd9d8d3af995f (diff)
downloadports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.tar.gz
ports-48e62d9a379cd45a15f6ae89d564f81b3c13d16e.zip
Notes
Diffstat (limited to 'print/cups-pk-helper/Makefile')
-rw-r--r--print/cups-pk-helper/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/print/cups-pk-helper/Makefile b/print/cups-pk-helper/Makefile
new file mode 100644
index 000000000000..566b879d8b73
--- /dev/null
+++ b/print/cups-pk-helper/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: cups-pk-helper
+# Date created: 2009-12-29
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/print/cups-pk-helper/Makefile,v 1.1 2009/12/29 16:01:07 ahze Exp $
+
+PORTNAME= cups-pk-helper
+PORTVERSION= 0.0.4
+CATEGORIES= print
+MASTER_SITES= http://www.freedesktop.org/software/${PORTNAME}/
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= A helper that makes system-config-printer use PolicyKit
+
+LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
+ cups.2:${PORTSDIR}/print/cups-client \
+ polkit.2:${PORTSDIR}/sysutils/policykit
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/libs"
+
+.include <bsd.port.mk>