aboutsummaryrefslogtreecommitdiff
path: root/print/cups/Makefile.common
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-07-21 14:28:32 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-07-21 14:28:32 +0000
commitf334b33c50a3f4e936d6a1f48b6a3c83bfb2e24d (patch)
treeda3beac8220875ea74b8fcc88f908ecfd54dd5f6 /print/cups/Makefile.common
parent568128bcfeb180b70fd057818d29f1d0abb24a71 (diff)
Notes
Diffstat (limited to 'print/cups/Makefile.common')
-rw-r--r--print/cups/Makefile.common18
1 files changed, 10 insertions, 8 deletions
diff --git a/print/cups/Makefile.common b/print/cups/Makefile.common
index 6312c7572f02..d3039cc18691 100644
--- a/print/cups/Makefile.common
+++ b/print/cups/Makefile.common
@@ -9,10 +9,10 @@ CUPS_MASTER_SITES=\
ftp://ftp.fisek.com.tr/pub/cups/${CUPS_VERSION}/ \
ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${CUPS_VERSION}/
-CUPS_VERSION= 1.1.18
+CUPS_VERSION= 1.1.19
CUPS_REVISION= 0
CUPS_PORTVER= ${CUPS_VERSION}.${CUPS_REVISION}
-CUPS_PORTREV= 5
+CUPS_PORTREV= 0
CUPS_PORTEPOCH= 0
CUPS_FILESDIR= ${.CURDIR}/../../print/cups/files
CUPS_ETCDIR= ${PREFIX}/etc/cups
@@ -39,6 +39,8 @@ DISTNAME= cups-${CUPS_VERSION}-${CUPS_REVISION}-source
.endif # ${CUPS_REVISION} < 1
DISTFILES= ${DISTNAME}.tar.bz2
+
+MD5_FILE= ${.CURDIR}/../../print/cups/distinfo
WRKSRC= ${WRKDIR}/cups-${CUPS_VERSION}
LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
@@ -52,6 +54,8 @@ USE_GMAKE= yes
USE_PERL5_RUN= yes
GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
CONFIGURE_ARGS+= --localstatedir=/var \
--disable-pam \
--disable-slp \
@@ -60,14 +64,12 @@ CONFIGURE_ARGS+= --localstatedir=/var \
--with-docdir=${CUPS_DOCSDIR} \
--with-rcdir=${CUPS_RCDIR}
-CONFIGURE_ARGS+= CPPFLAGS="-I${PREFIX}/include"
-CONFIGURE_ARGS+= CFLAGS="${CFLAGS} -I.. -I${PREFIX}/include"
-CONFIGURE_ARGS+= CXXFLAGS="${CFLAGS} -I.. -I${PREFIX}/include"
+CONFIGURE_ARGS+= CPPFLAGS="-I.. -I${LOCALBASE}/include"
CONFIGURE_ARGS+= DSOFLAGS="-Wl,-rpath,${PREFIX}/lib -L${PREFIX}/lib"
-CONFIGURE_ARGS+= LDFLAGS="-L${PREFIX}/lib"
+CONFIGURE_ARGS+= LDFLAGS="-L${LOCALBASE}/lib"
pre-configure::
- @${ECHO_CMD} Configuring CUPS with options:
- @${ECHO_CMD} ${CONFIGURE_ARGS} | fmt
+ @${ECHO_MSG} Configuring CUPS with options:
+ @${ECHO_MSG} ${CONFIGURE_ARGS} | fmt
.endif # ${PORTNAME} != "cups"