aboutsummaryrefslogtreecommitdiff
path: root/print/cups/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-12-04 01:10:42 +0000
committerWill Andrews <will@FreeBSD.org>2001-12-04 01:10:42 +0000
commitd32643d595be96de21ccb0e339aa1a00eb1696ef (patch)
tree3047c499617939d243386b6719d952328d6e013f /print/cups/Makefile
parent0b6ed2f44eb69da28cff7b0598c112478c220fe8 (diff)
downloadports-d32643d595be96de21ccb0e339aa1a00eb1696ef.tar.gz
ports-d32643d595be96de21ccb0e339aa1a00eb1696ef.zip
Notes
Diffstat (limited to 'print/cups/Makefile')
-rw-r--r--print/cups/Makefile44
1 files changed, 9 insertions, 35 deletions
diff --git a/print/cups/Makefile b/print/cups/Makefile
index fa1614a5c707..88764888bde0 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -6,47 +6,21 @@
#
PORTNAME= cups
-PORTVERSION= ${VERSION}#.${REVISION}
+PORTVERSION= ${VERSION}
+PORTREVISION= 1
CATEGORIES= print
-MASTER_SITES= ftp://ftp.easysw.com/pub/cups/${VERSION}/ \
- ftp://ftp2.easysw.com/pub/cups/${VERSION}/ \
- ftp://ftp.funet.fi/pub/mirrors/ftp.easysw.com/pub/cups/${VERSION}/ \
- ftp://ftp.mpg.goe.ni.schule.de/pub/internet/printing/cups/${VERSION}/
-DISTNAME= ${PORTNAME}-${VERSION}-source
+MASTER_SITES= # empty
+DISTFILES= # none
+EXTRACT_ONLY= # empty
MAINTAINER= jah4007@cs.rit.edu
VERSION= 1.1.12
-USE_BZIP2= yes
-INSTALLS_SHLIB= yes
+LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base
+RUN_DEPENDS= ${LOCALBASE}/sbin/cupsaddsmb:${PORTSDIR}/print/cups-lpr
-WRKSRC= ${WRKDIR}/${PORTNAME}-${VERSION}
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+= --localstatedir=/var
-
-MAN1= backend.1 cancel.1 filter.1 lp.1 lpoptions.1 lpq.1 \
- lpr.1 lprm.1 lpstat.1 lppasswd.1
-MAN3= cups-config.3
-MAN5= classes.conf.5 cupsd.conf.5 mime.convs.5 mime.types.5 \
- printers.conf.5
-MAN8= accept.8 cups-lpd.8 cups-polld.8 cupsd.8 disable.8 \
- enable.8 lpadmin.8 lpc.8 lpinfo.8 lpmove.8 \
- cupsaddsmb.8
-MLINKS= accept.8 reject.8
-
-post-install:
- @${INSTALL_DATA} ${WRKSRC}/conf/classes.conf \
- ${PREFIX}/etc/cups/classes.conf.sample
- @${INSTALL_DATA} ${WRKSRC}/conf/client.conf \
- ${PREFIX}/etc/cups/client.conf.sample
- @${INSTALL_DATA} ${WRKSRC}/conf/cupsd.conf \
- ${PREFIX}/etc/cups/cupsd.conf.sample
- @${INSTALL_DATA} ${WRKSRC}/conf/printers.conf \
- ${PREFIX}/etc/cups/printers.conf.sample
- @${INSTALL_SCRIPT} -m 751 ${WRKSRC}/cups.sh \
- ${PREFIX}/etc/rc.d/cupsd.sh.sample
- @${SED} -e 's,%%PREFIX%%,${PREFIX},g' ${PKGMESSAGE}
+NO_BUILD= true
+do-install: # empty
.include <bsd.port.mk>