aboutsummaryrefslogtreecommitdiff
path: root/print/dvipdfmx/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-03-29 17:29:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-03-29 17:29:57 +0000
commitc356e47e0d41d413c0e059a392f4fd7e3d8b0049 (patch)
tree2caf8c892fba19b11ee7e4861a4079c9ed74e273 /print/dvipdfmx/Makefile
parentc35272cf1b11c69389b0699ea951e90e2381508b (diff)
Notes
Diffstat (limited to 'print/dvipdfmx/Makefile')
-rw-r--r--print/dvipdfmx/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/print/dvipdfmx/Makefile b/print/dvipdfmx/Makefile
index 906c32ec0dde..a5158556a5eb 100644
--- a/print/dvipdfmx/Makefile
+++ b/print/dvipdfmx/Makefile
@@ -1,27 +1,34 @@
-# New ports collection makefile for: zh-dvipdfm-cjk
+# New ports collection makefile for: dvipdfmx
# Date created: 8 March 2001
# Whom: Shen Chuan-Hsing <statue@freebsd.sinica.edu.tw>
#
# $FreeBSD$
#
-PORTNAME= dvipdfm
-PORTVERSION= 20020605
+PORTNAME= dvipdfmx
+PORTVERSION= 20030313
CATEGORIES= print
-MASTER_SITES= http://project.ktug.or.kr/dvipdfm-cjk/snapshot/ \
- http://project.ktug.or.kr/dvipdfmx/snapshot/
-PKGNAMESUFFIX= -cjk
-DISTNAME= ${PORTNAME}${PKGNAMESUFFIX}-${PORTVERSION}
+MASTER_SITES= http://project.ktug.or.kr/dvipdfmx/snapshot/
MAINTAINER= statue@freebsd.sinica.edu.tw
COMMENT= Dvipdfm with Asian languages by CID-keyed font technology support
BUILD_DEPENDS= ${LOCALBASE}/lib/libkpathsea.a:${PORTSDIR}/print/teTeX
LIB_DEPENDS= png:${PORTSDIR}/graphics/png
+RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/Resource/ai0/CMap/Identity-H:${PO
+RTSDIR}/print/adobe-cmaps \
+ kpsepath:${PORTSDIR}/print/teTeX
MAN1= dvipdfm.1
USE_OPENSSL= yes
GNU_CONFIGURE= yes
+pre-install:
+ ${CP} ${LOCALBASE}/bin/dvipdfm ${LOCALBASE}/bin/dvipdfm-orig || ${TRUE}
+ ${MV} ${LOCALBASE}/share/texmf/dvipdfm ${LOCALBASE}/share/texmf/dvipdfm-orig || ${TRUE}
+
+post-install:
+ @${LN} -fs ${LOCALBASE}/share/ghostscript/Resource ${PREFIX}/share/texmf/dvipdfm/
+
.include <bsd.port.mk>