aboutsummaryrefslogtreecommitdiff
path: root/print/dvips
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>1995-04-20 02:04:02 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>1995-04-20 02:04:02 +0000
commit3f3532544cbb32240bdd7d50e50afb348bd3344a (patch)
treeef28d6c062e11d9c69eae53fb0051cd155238f60 /print/dvips
parent3a6807ac37c1d6eb8759ca3f5a6632d2b10a7e73 (diff)
downloadports-3f3532544cbb32240bdd7d50e50afb348bd3344a.tar.gz
ports-3f3532544cbb32240bdd7d50e50afb348bd3344a.zip
Notes
Diffstat (limited to 'print/dvips')
-rw-r--r--print/dvips/Makefile3
-rw-r--r--print/dvips/scripts/configure27
2 files changed, 24 insertions, 6 deletions
diff --git a/print/dvips/Makefile b/print/dvips/Makefile
index 7ff7ef1baf2d..c658c8fb890b 100644
--- a/print/dvips/Makefile
+++ b/print/dvips/Makefile
@@ -3,7 +3,7 @@
# Date created: 30 September 1994
# Whom: jmz
#
-# $Id$
+# $Id: Makefile,v 1.6 1995/04/15 04:33:41 asami Exp $
#
DISTNAME= dvips
@@ -19,5 +19,6 @@ IS_INTERACTIVE= yes
pre-install:
@mkdir -p ${PREFIX}/lib/texmf
@mkdir -p ${PREFIX}/man/man1
+ @if -f ${SCRIPTDIR}/install.tmp; then sh ${SCRIPTDIR}/install.tmp; fi
.include <bsd.port.mk>
diff --git a/print/dvips/scripts/configure b/print/dvips/scripts/configure
index 492a6eff1e57..309b216d2b04 100644
--- a/print/dvips/scripts/configure
+++ b/print/dvips/scripts/configure
@@ -3,8 +3,16 @@
# paper size, default is no nor A4
A4=n
-#default font cache directory: must be world writable
-CACHE=/tmp
+prefix=$PREFIX;
+if `echo $PREFIX |grep -q X11` ; then
+ prefix=/usr/local
+fi
+CACHE=$prefix/lib/texmf/fonts
+
+if [ -f $prefix/bin/MakeTeXPK ]; then
+ echo "**WARNING** MakeTeXPK already exists in $PREFIX/bin"
+ echo "This file will be replaced during install."
+fi
if [ ! -f ${WRKSRC}/MakeTeXPK.orig ]; then
@@ -25,9 +33,18 @@ for i in $RES; do
shift
done
-echo "Choose a font cache directory for automatic font generation"
-echo -n "(this directory must be world writable) [$CACHE]: "
-read answ; if [ "$answ" != "" ]; then CACHE=$answ; fi
+rm -f $SCRIPTDIR/install.tmp
+echo "Choose a font directory for automatic font generation."
+echo "The default directory is $CACHE. If you"
+echo "don't want to make this directory world writable, then you"
+echo "can choose eg. /tmp. Then you will have to periodically move "
+echo "the files to $CACHE/pk."
+echo -n "font directory [$CACHE]: "
+read answ; if [ "$answ" != "" ]; then
+ CACHE=$answ;
+else
+ echo "mkdir -p $CACHE/pk; chmod 1777 $CACHE/pk" > $SCRIPTDIR/install.tmp
+fi
sed -e s:/usr/lib/tex:/$PREFIX/lib/texmf: \
-e s:/LocalLibrary/Fonts/TeXFonts:$CACHE: \