aboutsummaryrefslogtreecommitdiff
path: root/print/easylatex
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-07-06 18:02:28 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-07-06 18:02:28 +0000
commit21b0ea66480d076292655e7007fceaf9a49d5b65 (patch)
tree121da42c31c5d7094c179b37a9382b8be9f6e6ce /print/easylatex
parent0258aa3432d29da14354bc2ddecbc11eb71b5312 (diff)
downloadports-21b0ea66480d076292655e7007fceaf9a49d5b65.tar.gz
ports-21b0ea66480d076292655e7007fceaf9a49d5b65.zip
Notes
Diffstat (limited to 'print/easylatex')
-rw-r--r--print/easylatex/Makefile44
-rw-r--r--print/easylatex/distinfo3
-rw-r--r--print/easylatex/pkg-descr5
-rw-r--r--print/easylatex/pkg-plist32
4 files changed, 84 insertions, 0 deletions
diff --git a/print/easylatex/Makefile b/print/easylatex/Makefile
new file mode 100644
index 000000000000..a19cd4a9c705
--- /dev/null
+++ b/print/easylatex/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: easylatex
+# Date created: 2006-02-15
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= easylatex
+PORTVERSION= 0.062
+CATEGORIES= print textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= nivit@email.it
+COMMENT= Perl script which transforms "pseudo-LaTeX" into proper LaTeX
+
+RUN_DEPENDS= dot:${PORTSDIR}/graphics/graphviz
+PERL_RUN_DEPENDS= Getopt-Declare:${PORTSDIR}/devel/p5-Getopt-Declare
+
+NO_BUILD= yes
+USE_PERL5= yes
+
+FIND_DIRS= .
+PORTDOCS= TUTORIAL demo.txt demo-no-graph.txt
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,/usr/lib/easylatex,${DATADIR},' \
+ ${WRKSRC}/${PORTNAME}.pl
+
+do-install:
+# script/data
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ cd ${WRKSRC}/${PORTNAME} && ${FIND} ${FIND_DIRS} -type d -exec ${MKDIR} ${DATADIR}/{} \;
+ cd ${WRKSRC}/${PORTNAME} && ${FIND} ${FIND_DIRS} -type f -name "*.pl" -exec ${INSTALL_SCRIPT} {} ${DATADIR}/{} \;
+ cd ${WRKSRC}/${PORTNAME} && ${FIND} ${FIND_DIRS} -type f -name "*.txt" -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+# docs
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+. for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+. endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/easylatex/distinfo b/print/easylatex/distinfo
new file mode 100644
index 000000000000..747ed9f0d40f
--- /dev/null
+++ b/print/easylatex/distinfo
@@ -0,0 +1,3 @@
+MD5 (easylatex-0.062.tar.gz) = a503c2a4bde7a98def3f7aff94f03036
+SHA256 (easylatex-0.062.tar.gz) = 0abd896bc878eb9d4c1fcf1ac9a0916e5b6f32c2d058670823056dbbcb0ece3e
+SIZE (easylatex-0.062.tar.gz) = 184469
diff --git a/print/easylatex/pkg-descr b/print/easylatex/pkg-descr
new file mode 100644
index 000000000000..be2bcda3b515
--- /dev/null
+++ b/print/easylatex/pkg-descr
@@ -0,0 +1,5 @@
+EasyLatex is a preprocessor which takes an input file in "pseudo-latex",
+and transforms it into proper LaTeX syntax.
+
+Author: Bayle Shanks <bshanks@ucsd.edu>
+WWW: http://easylatex.sourceforge.net/
diff --git a/print/easylatex/pkg-plist b/print/easylatex/pkg-plist
new file mode 100644
index 000000000000..3a10d1c2ff9d
--- /dev/null
+++ b/print/easylatex/pkg-plist
@@ -0,0 +1,32 @@
+@comment $FreeBSD$
+bin/easylatex
+%%DATADIR%%/disabled/30autoAlignEquationsOutsideOfMathMode.pl
+%%DATADIR%%/embed_transforms/25scriptedMatrix.pl
+%%DATADIR%%/math_mode_symbol_list.txt
+%%DATADIR%%/transforms/20escapeInsideGraphs.pl
+%%DATADIR%%/transforms/25autoLinefeedInMathMode.pl
+%%DATADIR%%/transforms/25wiki.pl
+%%DATADIR%%/transforms/30autoFractions.pl
+%%DATADIR%%/transforms/30dotsToLdots.pl
+%%DATADIR%%/transforms/30superSubscripts.pl
+%%DATADIR%%/transforms/70autoMathMode.pl
+%%DATADIR%%/transforms/80autoAlignEquations.pl
+%%DATADIR%%/transforms/80autoItemize.pl
+%%DATADIR%%/transforms/80easyMatrices.pl
+%%DATADIR%%/transforms/85sweepHalfEquationsIntoAdjacentMathMode.pl
+%%DATADIR%%/transforms/90addHeaderAndFooter.pl
+%%DATADIR%%/transforms/90doublePercentIsCommentSymbol.pl
+%%DATADIR%%/transforms/90easyFigures.pl
+%%DATADIR%%/transforms/90graphs.pl
+%%DATADIR%%/transforms/90numberSign.pl
+%%DATADIR%%/transforms/90removeWhitespaceAroundEquations.pl
+%%DATADIR%%/transforms/91easyQuotes.pl
+%%DATADIR%%/transforms/91easySections.pl
+%%DATADIR%%/transforms/91seminarAddSlidesec.pl
+%%DATADIR%%/transforms/91seminarEnvAddSlide.pl
+%%DATADIR%%/transforms/92seminarFlushHeadingsTop.pl
+%%DATADIR%%/transforms/92tempKludges.pl
+@dirrm %%DATADIR%%/disabled
+@dirrm %%DATADIR%%/embed_transforms
+@dirrm %%DATADIR%%/transforms
+@dirrm %%DATADIR%%