aboutsummaryrefslogtreecommitdiff
path: root/print/font2svg/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-17 09:58:53 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-17 09:58:53 +0000
commit413c54a7554bde32e291cacbd3d256422e95751b (patch)
tree7600ed518a69a41c90d053e01da4b8eba8666831 /print/font2svg/Makefile
parent1e10f6c6b71e4cfa23da093b0d2edd197b2d0042 (diff)
Notes
Diffstat (limited to 'print/font2svg/Makefile')
-rw-r--r--print/font2svg/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/print/font2svg/Makefile b/print/font2svg/Makefile
new file mode 100644
index 000000000000..57c1a15eb18f
--- /dev/null
+++ b/print/font2svg/Makefile
@@ -0,0 +1,33 @@
+# ex:ts=8
+# Ports collection makefile for: font2svg
+# Date created: Jan 10, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= font2svg
+PORTVERSION= 0.1.4
+CATEGORIES= print
+MASTER_SITES= http://www.gdv.uni-hannover.de/~peinecke/font2svg/
+
+MAINTAINER= ports@FreeBSD.org
+
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
+ gs:${PORTSDIR}/print/ghostscript-gnu
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
+ -e "s|/home/peinecke/cprog/font2svg|${DATADIR}|" \
+ ${WRKSRC}/font2svg
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/font2svg ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/encodings ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/font2svg.ps ${DATADIR}
+
+.include <bsd.port.mk>