aboutsummaryrefslogtreecommitdiff
path: root/print/fontforge/Makefile
diff options
context:
space:
mode:
authorFUJISHIMA Satsuki <sf@FreeBSD.org>2001-11-25 17:17:36 +0000
committerFUJISHIMA Satsuki <sf@FreeBSD.org>2001-11-25 17:17:36 +0000
commita27a04ddcb9f1858a8ebc7ba7e8ca1c885eedcd2 (patch)
tree06595d75a1792dc9d02d92a08fcf9e45b55f0e68 /print/fontforge/Makefile
parent328a8a33701deaba6c88a7c4f010299fcc36a0fb (diff)
downloadports-a27a04ddcb9f1858a8ebc7ba7e8ca1c885eedcd2.tar.gz
ports-a27a04ddcb9f1858a8ebc7ba7e8ca1c885eedcd2.zip
Notes
Diffstat (limited to 'print/fontforge/Makefile')
-rw-r--r--print/fontforge/Makefile21
1 files changed, 14 insertions, 7 deletions
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index abf4ca7bfd41..69168e48493b 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -6,33 +6,40 @@
#
PORTNAME= pfaedit
-PORTVERSION= 20010808
+PORTVERSION= 20011124
CATEGORIES= print
-MASTER_SITES= http://pfaedit.sourceforge.net/
+MASTER_SITES= http://pfaedit.sourceforge.net/
DISTFILES= ${PORTNAME}_src-${DIST_VER}.tgz \
libgunicode-${LIBGUNI_VER}.tgz libgdraw-${LIBGDRAW_VER}.tgz \
cidmaps.tgz
MAINTAINER= kanou@mil.allnet.ne.jp
-DIST_VER= 010808
-LIBGDRAW_VER= 010808
-LIBGUNI_VER= 010808
-
LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
ungif.5:${PORTSDIR}/graphics/libungif
+USE_GMAKE= yes
USE_XLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= pfaedit
MAN1= pfaedit.1
+DIST_VER= 011124
+LIBGDRAW_VER= 011123
+LIBGUNI_VER= 011123
+
+post-patch:
+ ${PERL} -pi.orig -e 's,/usr/share/,${PREFIX}/share/,g' \
+ ${WRKSRC}/pfaedit/pfaedit.1
+ ${PERL} -pi.orig -e 's,/usr/pkg/,${PREFIX}/,g' \
+ ${WRKSRC}/*/[mM]akefile.*
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pfaedit/pfaedit ${PREFIX}/bin
${MKDIR} ${PREFIX}/share/pfaedit