aboutsummaryrefslogtreecommitdiff
path: root/print/fontforge/Makefile
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-09-06 22:20:07 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-09-06 22:20:07 +0000
commit99117f737307de943b26269fe3c5cc4843b79858 (patch)
tree669c894c09cebac2ff551d31723b42c02ab7ce1e /print/fontforge/Makefile
parente8999e72d4ac4f449162509cd6bf15e496be8059 (diff)
print/fontforge: Update to 20190801
* Update to 20190801 * Update distinfo * Update pkg-plist * Move most required things to options (only required LIB_DEPENDS is freetype2 and only required GNOME use is glib20 and libxml2) * USES autoreconf no longer needs to have the build argument because they made their bootstrap be just running autoreconf and not all the other junk it did before * USES localbase in favor of setting CPPFLAGS and LDFLAGS to those * iconv is forced on despite being an option as the build fails without iconv for some reason * Included options for some things that were not options before but are configurable via GNU configure * Removed patches from files: patch-Makefile.am (uthash not used anymore), patch-fontforge_cvexport.c and patch-fontforge_print.c (that code was removed and the patch is not needed anymore), patch-fontforge_splinefont.h (looking at SVN history, this was added to fix build for 8.x, but that isn't supported anymore and it builds without this) * Added patch to files: patch-m4-fontforge__arg__enable.m4 (without this, woff2 was always being enabled regardless of --enable/disable-woff2 being set) Changelog: https://github.com/fontforge/fontforge/releases/tag/20190801 PR: 239768 Submitted by: kunda Approved by: Naram Qashat (maintainer)
Notes
Notes: svn path=/head/; revision=511370
Diffstat (limited to 'print/fontforge/Makefile')
-rw-r--r--print/fontforge/Makefile108
1 files changed, 71 insertions, 37 deletions
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index d119a38d799c..6c724d38dde4 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= fontforge
-PORTVERSION= 20190413
+PORTVERSION= 20190801
CATEGORIES= print
MAINTAINER= cyberbotx@cyberbotx.com
@@ -11,30 +11,15 @@ COMMENT= Type 1/TrueType/OpenType/bitmap font editor
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/include/uthash.h:devel/uthash \
- ${LOCALBASE}/bin/gnulib-tool:devel/gnulib
-LIB_DEPENDS= libuninameslist.so:textproc/libuninameslist \
- libtiff.so:graphics/tiff \
- libpng.so:graphics/png \
- libgif.so:graphics/giflib \
- libspiro.so:graphics/libspiro \
- libfreetype.so:print/freetype2 \
- libltdl.so:devel/libltdl \
- libfontconfig.so:x11-fonts/fontconfig
-
-USES= autoreconf:build compiler desktop-file-utils gettext \
- gmake gnome iconv jpeg libtool pkgconfig python \
- readline:port shared-mime-info shebangfix
-USE_GITHUB= yes
-USE_XORG= ice sm x11 xi xkbui xft
-USE_GNOME= cairo glib20 gtk20 libxml2 pango
+LIB_DEPENDS= libfreetype.so:print/freetype2
-SHEBANG_FILES= pycontrib/gdraw/__init__.py \
- pycontrib/gdraw/gdraw.py
+USES= autoreconf compiler gettext gmake gnome iconv:wchar_t libtool \
+ localbase pkgconfig
+USE_GITHUB= yes
+USE_GNOME= glib20 libxml2
-CONFIGURE_ARGS= --enable-tile-path --enable-gtk2-use
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+# It seems that iconv is required regardless of this setting, so forcing it on
+CONFIGURE_ARGS= --with-iconv
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -43,29 +28,78 @@ INSTALLS_ICONS= yes
PORTDOCS= * .htaccess
-OPTIONS_DEFINE= DOCS FREETYPE CAIRO PYTHON
+OPTIONS_DEFINE= CAIRO DOCS FREETYPE GIF JPEG PNG PYTHON READLINE SPIRO TIFF \
+ TILEPATH UNINAMESLIST WOFF2 WRITEPFM
+OPTIONS_GROUP= GUI
+OPTIONS_GROUP_GUI= GTK3 X11
+OPTIONS_SINGLE= THEME
+OPTIONS_SINGLE_THEME= TANGO 2012
+OPTIONS_DEFAULT=CAIRO GIF GTK3 JPEG PNG PYTHON READLINE SPIRO TANGO TIFF \
+ TILEPATH UNINAMESLIST WOFF2
OPTIONS_SUB= yes
-FREETYPE_DESC= Include freetype's internal debugger
+2012_DESC= Old theme that was used until 2012
+2012_CONFIGURE_ENABLE= theme-2012
+
+CAIRO_USE= gnome=cairo,pango
+CAIRO_CONFIGURE_WITH= cairo
+CAIRO_IMPLIES= PNG
+
+FREETYPE_DESC= Include freetype's internal debugger
FREETYPE_PATCH_DEPENDS= ${NONEXISTENT}:print/freetype2:extract
FREETYPE_CONFIGURE_ENABLE= freetype-debugger=${WRKSRC}/freetype
-CAIRO_CONFIGURE_WITH= cairo
+GIF_LIB_DEPENDS= libgif.so:graphics/giflib
+GIF_CONFIGURE_WITH= giflib
+
+GTK3_USE= gnome=gtk30
+GTK3_CONFIGURE_ENABLE= gdk
+GTK3_IMPLIES= CAIRO X11
+
+JPEG_USES= jpeg
+JPEG_CONFIGURE_WITH= libjpeg
+
+PNG_LIB_DEPENDS=libpng.so:graphics/png
+PNG_CONFIGURE_WITH= libpng
+PYTHON_USES= python:3.5-3.7
+PYTHON_USES_OFF=python:3.5-3.7,build
PYTHON_CONFIGURE_ENABLE= python-scripting python-extension
+READLINE_USES= readline:port
+READLINE_CONFIGURE_WITH= libreadline
+
+SPIRO_DESC= Use libspiro to edit with clothoid splines
+SPIRO_LIB_DEPENDS= libspiro.so:graphics/libspiro
+SPIRO_CONFIGURE_WITH= libspiro
+
+TANGO_DESC= Default theme based on the Tango Desktop Project
+
+TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
+TIFF_CONFIGURE_WITH= libtiff
+
+TILEPATH_DESC= Enable a 'tile path' command (a variant of 'expand stroke')
+TILEPATH_CONFIGURE_ENABLE= tile-path
+
+UNINAMESLIST_DESC= Use libuninameslist for Unicode attribute data
+UNINAMESLIST_LIB_DEPENDS= libuninameslist.so:textproc/libuninameslist
+UNINAMESLIST_CONFIGURE_WITH= libuninameslist
+
+WOFF2_DESC= WOFF2 web font support
+WOFF2_LIB_DEPENDS= libbrotlidec.so:archivers/brotli \
+ libwoff2dec.so:devel/woff2
+WOFF2_CONFIGURE_ENABLE= woff2
+
+WRITEPFM_DESC= Add ability to save PFM file w/o creating associated font file
+WRITEPFM_CONFIGURE_ENABLE= write-pfm
+
+X11_USES= desktop-file-utils shared-mime-info xorg
+X11_USE= gnome=pango xorg=ice,sm,x11,xft,xi
+X11_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
+X11_RUN_DEPENDS= ${LOCALBASE}/share/fonts/gnu-unifont/unifont.pcf.gz:x11-fonts/gnu-unifont
+X11_CONFIGURE_WITH= x
+
post-patch-FREETYPE-on:
@${LN} -s $$(${MAKE} -C ${PORTSDIR}/print/freetype2 -V WRKSRC) ${WRKSRC}/freetype
-# This is to get around calling fontforge's bootstrap script, as that script fails
-# if git isn't installed on a system DESPITE there being a --skip-git argument that
-# can be passed into it. autoreconf is called here because I want to run it without
-# libtoolize being run along with it.
-pre-configure:
- (cd ${WRKSRC} && \
- ${SH} -c '. ./bootstrap.conf ; \
- ${LOCALBASE}/bin/libtoolize -i -c -q ; \
- ${LOCALBASE}/bin/gnulib-tool --aux-dir=config --m4-base=m4 --libtool --symlink --import $${gnulib_modules}' ; \
- export LIBTOOLIZE=true ; ${AUTORECONF} -f -i)
-
.include <bsd.port.mk>