aboutsummaryrefslogtreecommitdiff
path: root/print/fontforge
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-01-24 12:10:53 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-01-24 12:10:53 +0000
commit985efe61bfab22501b9ef82b10aca7ef8481014f (patch)
treedb2fa3c8c202b0b0670d0db9ad1a92e6bf8301c1 /print/fontforge
parent2b75f759383c82e61d4b09f4139dd7a18e4f5bd7 (diff)
downloadports-985efe61bfab22501b9ef82b10aca7ef8481014f.tar.gz
ports-985efe61bfab22501b9ef82b10aca7ef8481014f.zip
Notes
Diffstat (limited to 'print/fontforge')
-rw-r--r--print/fontforge/Makefile60
-rw-r--r--print/fontforge/distinfo10
-rw-r--r--print/fontforge/files/patch-Makefile.dynamic.in46
-rw-r--r--print/fontforge/files/patch-fontforge-fontinfo.c19
-rw-r--r--print/fontforge/files/patch-fontforge-parsettf.c25
-rw-r--r--print/fontforge/files/patch-fontforge::Makefile.dynamic.in20
-rw-r--r--print/fontforge/files/patch-fontforge::makenomenh.c11
-rw-r--r--print/fontforge/pkg-plist209
8 files changed, 321 insertions, 79 deletions
diff --git a/print/fontforge/Makefile b/print/fontforge/Makefile
index 8f5d019f6736..51907a072ea1 100644
--- a/print/fontforge/Makefile
+++ b/print/fontforge/Makefile
@@ -6,13 +6,16 @@
#
PORTNAME= fontforge
-PORTVERSION= 20051028
-PORTREVISION= 1
+PORTVERSION= 20060117
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fontforge
-DISTFILES= ${EXTRACT_ONLY} ${DOCFILE}
+DISTFILES= ${EXTRACT_ONLY} ${DOCFILES}
EXTRACT_ONLY= ${PORTNAME}_full-${PORTVERSION}.tar.bz2
+.if defined(FONTFORGE_WITH_TTF_DEBUGGER)
+FREETYPE_VERSION= 2.1.10
+EXTRACT_ONLY+= freetype-${FREETYPE_VERSION}.tar.bz2
+.endif
MAINTAINER= kanou@khdd.net
COMMENT= Type 1/TrueType/OpenType/bitmap font editor
@@ -25,33 +28,69 @@ LIB_DEPENDS= uninameslist.0:${PORTSDIR}/textproc/libuninameslist \
freetype.9:${PORTSDIR}/print/freetype2 \
xml2.5:${PORTSDIR}/textproc/libxml2
-DOC_VERSION= ${PORTVERSION}
-DOCFILE= ${PORTNAME}_htdocs-${DOC_VERSION}.tgz
+DOC_VERSION= 20060114
+DOCFILES= ${DOCFILE_IN_TAR_GZ} ${DOCFILE_IN_TAR_BZ2}
+DOCFILE_IN_TAR_GZ= ${PORTNAME}_htdocs-${DOC_VERSION}.tgz
+DOCFILE_IN_TAR_BZ2= ${PORTNAME}_ja_htdocs-${DOC_VERSION}.tar.bz2
USE_GMAKE= yes
USE_XLIB= yes
USE_ICONV= yes
USE_BZIP2= yes
PATCH_STRIP= -l
+
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
.if !defined(FONTFORGE_NO_MULTILAYER)
-CONFIGURE_ARGS= --with-multilayer --with-devicetables --without-freetype-src
+WITH_MULTILAYER= --with-multilayer
+.endif
+.if !defined(WITHOUT_TTF_BYTECODE_ENABLED) && defined(FONTFORGE_WITH_TTF_DEBUGGER)
+WITH_FREETYPE_SRC= --with-freetype-src=${WRKDIR}/freetype-${FREETYPE_VERSION}
.else
-CONFIGURE_ARGS= --with-devicetables --without-freetype-src
+WITH_FREETYPE_SRC= --without-freetype-src
.endif
+CONFIGURE_ARGS= ${WITH_MULTILAYER} --with-devicetables ${WITH_FREETYPE_SRC}
CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CFLAGS="${CFLAGS} \
-I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include \
-I${LOCALBASE}/include/freetype2"
+
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
INSTALLS_SHLIB= yes
USE_AUTOTOOLS= libtool:13
MAN1= fontforge.1 sfddiff.1
+pre-everything::
+.if defined(WITHOUT_EXTRA_ENCODINGS)
+ @${ECHO_MSG} "WARNING: You should not compile libiconv with WITHOUT_EXTRA_ENCODINGS"
+ @${ECHO_MSG} "defined, because libiconv must be configured with --enable-extra-encoding"
+ @${ECHO_MSG} "as FontForge requires Shift-JIS."
+ @${ECHO_MSG} ""
+.endif
+.if !defined(WITHOUT_TTF_BYTECODE_ENABLED) && !defined(FONTFORGE_WITH_TTF_DEBUGGER)
+ @${ECHO_MSG} "If you have built freetype2 port with bytecode interpreter enabled,"
+ @${ECHO_MSG} "You can use TTF instruction debugger by compiling fontforge port"
+ @${ECHO_MSG} "with FONTFORGE_WITH_TTF_DEBUGGER defined."
+ @${ECHO_MSG} "Note that you must put the source archive of FreeType in ${DISTDIR}."
+ @${ECHO_MSG} "If you have installed freetype2 from a package, chdir to ${PORTSDIR}/print/"
+ @${ECHO_MSG} "and execute 'make fetch' before building this port".
+ @${ECHO_MSG} ""
+.endif
+.if !defined(FONTFORGE_NO_MULTILAYER)
+ @${ECHO_MSG} "If your machine has small memory and you have to edit fonts with a lot"
+ @${ECHO_MSG} "of glyphs, you can save memory by defining FONTFORGE_NO_MULTILAYER."
+ @${ECHO_MSG} "Enabling multilayer editing increases memory consumption per glyph."
+ @${ECHO_MSG} ""
+.endif
+
post-extract:
${MKDIR} ${WRKDIR}/html ${WRKSRC}/cidmap
- ${TAR} -xzC ${WRKDIR}/html -f ${DISTDIR}/${DOCFILE}
+ for doc in ${DOCFILE_IN_TAR_GZ} ; \
+ do ${TAR} -xzC ${WRKDIR}/html -f ${DISTDIR}/$${doc} ; \
+ done
+ for doc in ${DOCFILE_IN_TAR_BZ2} ; \
+ do ${TAR} -xyC ${WRKDIR}/html -f ${DISTDIR}/$${doc} ; \
+ done
${TAR} -xzC ${WRKSRC}/cidmap -f ${WRKDIR}/html/cidmaps.tgz
${RM} ${WRKDIR}/html/cidmaps.tgz
@@ -59,7 +98,10 @@ post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/LICENSE ${DOCSDIR}
.if !defined(NOPORTDOCS)
- ${INSTALL_DATA} ${WRKDIR}/html/* ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/flags ${DOCSDIR}/ja
+ ${INSTALL_DATA} ${WRKDIR}/html/*.* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/html/flags/* ${DOCSDIR}/flags
+ ${INSTALL_DATA} ${WRKDIR}/html/ja/* ${DOCSDIR}/ja
.endif
.include <bsd.port.mk>
diff --git a/print/fontforge/distinfo b/print/fontforge/distinfo
index dee6a4474633..a885241717d8 100644
--- a/print/fontforge/distinfo
+++ b/print/fontforge/distinfo
@@ -1,6 +1,8 @@
MD5 (fontforge_full-20051028.tar.bz2) = 3d385a58cb37c544cfef9a0434072dd6
-SHA256 (fontforge_full-20051028.tar.bz2) = d5f96d51d3cec3b9efbf106a57acf2bc267d74fad906c4beaa42bd197e78ca07
-SIZE (fontforge_full-20051028.tar.bz2) = 3014049
-MD5 (fontforge_htdocs-20051028.tgz) = 1a4f98489bcbb7aa91e38a8cade6f2f5
-SHA256 (fontforge_htdocs-20051028.tgz) = d5a36b768c463aedce472cd487b99b69822d04b28fc59125960771b4a5558234
+MD5 (fontforge_full-20060117.tar.bz2) = d26919a63d605d2364dc7c8cb26c51ec
+SIZE (fontforge_full-20060117.tar.bz2) = 3215162
+MD5 (fontforge_htdocs-20060114.tgz) = 78a9f24e14c3e89afb5b88622f675546
+SIZE (fontforge_htdocs-20060114.tgz) = 2190544
+MD5 (fontforge_ja_htdocs-20060114.tar.bz2) = d8b75323a76c83b2538d8dcd8c7f5bb9
+SIZE (fontforge_ja_htdocs-20060114.tar.bz2) = 2588746
SIZE (fontforge_htdocs-20051028.tgz) = 2156822
diff --git a/print/fontforge/files/patch-Makefile.dynamic.in b/print/fontforge/files/patch-Makefile.dynamic.in
index fd121882cbe1..b8e4ccfc02b6 100644
--- a/print/fontforge/files/patch-Makefile.dynamic.in
+++ b/print/fontforge/files/patch-Makefile.dynamic.in
@@ -1,17 +1,17 @@
---- Makefile.dynamic.in.orig Mon Oct 17 03:30:49 2005
-+++ Makefile.dynamic.in Mon Oct 17 10:14:46 2005
-@@ -48,34 +48,34 @@
- $(LIBTOOL) $(INSTALL) -c libgunicode.la $(libdir)/libgunicode.la
+--- Makefile.dynamic.in.orig Thu Nov 17 05:56:25 2005
++++ Makefile.dynamic.in Sun Dec 4 16:19:03 2005
+@@ -52,17 +52,17 @@
+ $(LIBTOOL) --mode=install $(INSTALL) -c libgunicode.la $(libdir)/libgunicode.la
#cp .libs/*.so.*.* $(libdir)
- $(LIBTOOL) --finish $(libdir)
+ $(LIBTOOL) --mode=finish $(libdir)
- mkdir -p $(libdir)/pkgconfig
-- $(LIBTOOL) $(INSTALL) -c fontforge.pc $(libdir)/pkgconfig
+- $(LIBTOOL) --mode=install $(INSTALL) -c fontforge.pc $(libdir)/pkgconfig
+ mkdir -p ${PREFIX}/libdata/pkgconfig
+ ${BSD_INSTALL_DATA} -c fontforge.pc ${PREFIX}/libdata/pkgconfig
install_docs:
mkdir -p $(docdir)
- mkdir -p $(docdir)/flags
+ mkdir -p $(docdir)/flags $(docdir)/ja
#explicit use of sh to make sure we don't invoke csh with different "if" syntax
-sh -c "if test -d htdocs/ja >/dev/null ; then mkdir -p $(docdir)/ja ; fi"
- -cp htdocs/*.{html,png,gif,pdf} $(docdir)
@@ -21,28 +21,14 @@
+ ${BSD_INSTALL_DATA} htdocs/flags/* $(docdir)/flags
+ ${BSD_INSTALL_DATA} htdocs/ja/* $(docdir)/ja
- install: $(sharedir) all install_libs
- # You may need to be root to do the install
- mkdir -p $(bindir)
+ install_po:
+ ( cd po ; make install )
+@@ -73,7 +73,7 @@
mkdir -p $(mandir)/man1
mkdir -p $(sharedir)
-- $(LIBTOOL) $(INSTALL) -c fontforge/fontforge $(bindir)
-- $(LIBTOOL) $(INSTALL) -c fontforge/sfddiff $(bindir)
-+ ${BSD_INSTALL_PROGRAM} -c fontforge/.libs/fontforge $(bindir)
-+ ${BSD_INSTALL_PROGRAM} -c fontforge/.libs/sfddiff $(bindir)
- -rm -f $(bindir)/pfaedit
- (cd $(bindir) ; ln -s fontforge pfaedit)
-- cp fontforge/pfaedit-*.ui $(sharedir)
-+ ${BSD_INSTALL_DATA} fontforge/pfaedit-*.ui $(sharedir)
- #The next line will fail for most installs. If you have downloaded the cidmaps
- # this will install them. If you haven't it won't. You only need the cidmaps
- # if you are editing CID keyed files (and even then you can live without them
-- -cp $(srcdir)/cidmap/*.cidmap $(sharedir) >/dev/null 2>&1
-- cp $(srcdir)/fontforge/fontforge.1 $(mandir)/man1
-- cp $(srcdir)/fontforge/sfddiff.1 $(mandir)/man1
-+ ${BSD_INSTALL_DATA} $(srcdir)/cidmap/*.cidmap $(sharedir) >/dev/null 2>&1
-+ ${BSD_INSTALL_MAN} $(srcdir)/fontforge/fontforge.1 $(mandir)/man1
-+ ${BSD_INSTALL_MAN} $(srcdir)/fontforge/sfddiff.1 $(mandir)/man1
- #explicit use of sh to make sure we don't invoke csh with different "if" syntax
- sh -c "if test -d htdocs >/dev/null ; then $(MAKE) install_docs ; fi"
-
+ $(LIBTOOL) --mode=install $(INSTALL) -c fontforge/fontforge $(bindir)
+- -$(LIBTOOL) --mode=install $(INSTALL) -c fontforge/sfddiff $(bindir)
++ $(LIBTOOL) --mode=install $(INSTALL) -c fontforge/sfddiff $(bindir)
+ # -rm -f $(bindir)/pfaedit
+ # (cd $(bindir) ; ln -s fontforge pfaedit)
+ # cp fontforge/pfaedit-*.ui $(sharedir)
diff --git a/print/fontforge/files/patch-fontforge-fontinfo.c b/print/fontforge/files/patch-fontforge-fontinfo.c
new file mode 100644
index 000000000000..7d7d286e3382
--- /dev/null
+++ b/print/fontforge/files/patch-fontforge-fontinfo.c
@@ -0,0 +1,19 @@
+--- fontforge/fontinfo.c.orig Wed Jan 11 20:00:54 2006
++++ fontforge/fontinfo.c Tue Jan 24 12:55:39 2006
+@@ -5311,6 +5311,7 @@
+ (sf->xuid!=NULL && uc_strcmp(txt,sf->xuid)==0) ||
+ ttfuniqueidmatch(sf,d)) ) {
+ char *buts[4];
++ int ans;
+ buts[0] = _("Change");
+ buts[1] = _("Retain");
+ #if defined(FONTFORGE_CONFIG_GDRAW)
+@@ -5319,7 +5320,7 @@
+ buts[2] = GTK_STOCK_CANCEL;
+ #endif
+ buts[3] = NULL;
+- int ans = gwwv_ask(_("Change UniqueID?"),(const char **) buts,0,2,_("You have changed this font's name without changing the UniqueID (or XUID).\nThis is probably not a good idea, would you like me to\ngenerate a random new value?"));
++ ans = gwwv_ask(_("Change UniqueID?"),(const char **) buts,0,2,_("You have changed this font's name without changing the UniqueID (or XUID).\nThis is probably not a good idea, would you like me to\ngenerate a random new value?"));
+ if ( ans==2 ) {
+ GDrawSetCursor(gw,ct_pointer);
+ return(true);
diff --git a/print/fontforge/files/patch-fontforge-parsettf.c b/print/fontforge/files/patch-fontforge-parsettf.c
new file mode 100644
index 000000000000..8b8e71bcde1c
--- /dev/null
+++ b/print/fontforge/files/patch-fontforge-parsettf.c
@@ -0,0 +1,25 @@
+--- fontforge/parsettf.c.orig Sun Jan 15 00:40:17 2006
++++ fontforge/parsettf.c Tue Jan 24 13:04:32 2006
+@@ -4277,18 +4277,19 @@
+ if ( !info->onlystrikes &&
+ info->glyphlocations_start!=0 && info->glyph_start!=0 &&
+ info->cff_start!=0 ) {
++ int choice;
+ char *buts[4];
+ buts[0] = _("TTF 'glyf'");
+ buts[1] = _("OTF 'CFF '");
+ buts[3] = NULL;
+ #if defined(FONTFORGE_CONFIG_GDRAW)
+ buts[2] = _("_Cancel");
+- int choice = gwwv_ask(_("Pick a font, any font..."),(const char **) buts,0,2,_("This font contains both a TrueType 'glyf' table and an OpenType 'CFF ' table. FontForge can only deal with one at a time, please pick which one you want to use"));
++ choice = gwwv_ask(_("Pick a font, any font..."),(const char **) buts,0,2,_("This font contains both a TrueType 'glyf' table and an OpenType 'CFF ' table. FontForge can only deal with one at a time, please pick which one you want to use"));
+ #elif defined(FONTFORGE_CONFIG_GTK)
+ buts[2] = GTK_STOCK_CANCEL;
+- int choice = gwwv_ask(_("Pick a font, any font..."),(const char **) buts,0,2,_("This font contains both a TrueType 'glyf' table and an OpenType 'CFF ' table. FontForge can only deal with one at a time, please pick which one you want to use"));
++ choice = gwwv_ask(_("Pick a font, any font..."),(const char **) buts,0,2,_("This font contains both a TrueType 'glyf' table and an OpenType 'CFF ' table. FontForge can only deal with one at a time, please pick which one you want to use"));
+ #else
+- int choice = 0;
++ choice = 0;
+ #endif
+ if ( choice==2 ) {
+ setlocale(LC_NUMERIC,oldloc);
diff --git a/print/fontforge/files/patch-fontforge::Makefile.dynamic.in b/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
index c584750d1725..414c65afbdb7 100644
--- a/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
+++ b/print/fontforge/files/patch-fontforge::Makefile.dynamic.in
@@ -1,19 +1,23 @@
---- fontforge/Makefile.dynamic.in.orig Fri Oct 14 11:14:37 2005
-+++ fontforge/Makefile.dynamic.in Sat Oct 15 14:23:19 2005
-@@ -43,13 +43,13 @@
+--- fontforge/Makefile.dynamic.in.orig Fri Nov 11 11:41:01 2005
++++ fontforge/Makefile.dynamic.in Sun Dec 4 16:59:47 2005
+@@ -45,16 +45,16 @@
DIFFOBJS = sfddiff.o sfd.o diffstubs.o stamp.o
ACORNOBJS = acorn2sfd.o sfd.o diffstubs.o psunicodenames.o stamp.o
-_CFLAGS = -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
+_CFLAGS = -I$(LOCALBASE)/include -I$(top_srcdir)/inc -I$(srcdir) -I. @WFLAGS@ $(X_CFLAGS) \
- @DEFS@ '-DSHAREDIR="$(sharedir)"' -DLIBDIR='"$(libdir)"'
- CFLAGS = @CFLAGS@ @CPPFLAGS@ $(_CFLAGS)
+ @DEFS@ '-DSHAREDIR="$(sharedir)"' -DLIBDIR='"$(libdir)"' \
+ @CPPFLAGS@ '-DPREFIX="@prefix@"'
+ CFLAGS = @CFLAGS@ $(_CFLAGS)
LIBS = -rpath $(libdir) $(X_LIBS) ../libgdraw.la ../libgunicode.la \
- $(X_PRE_LIBS) $(X_11LIB) $(X_EXTRA_LIBS) @LIBS@ $(STATIC_LIBS) -L/usr/lib -lm
--DLIBS = -rpath $(libdir) ../libgunicode.la @LIBS@ -lm
+-DLIBS = -rpath $(libdir) ../libgunicode.la @LIBS@ $(STATIC_LIBS) -lm
+ $(X_PRE_LIBS) $(X_11LIB) $(X_EXTRA_LIBS) @LIBS@ $(STATIC_LIBS) -L/usr/lib -lm -lintl
-+DLIBS = -rpath $(libdir) ../libgunicode.la @LIBS@ -lm -lintl
++DLIBS = -rpath $(libdir) ../libgunicode.la @LIBS@ $(STATIC_LIBS) -lm -lintl
- all: fontforge sfddiff
+-all: fontforge
++all: fontforge sfddiff
+ fontforge: main.o $(fontforge_LIBOBJECTS)
+ $(LIBTOOL) --mode=link $(CC) -export-dynamic -o fontforge main.o $(fontforge_LIBOBJECTS) $(LIBS)
diff --git a/print/fontforge/files/patch-fontforge::makenomenh.c b/print/fontforge/files/patch-fontforge::makenomenh.c
deleted file mode 100644
index 7f470e78e301..000000000000
--- a/print/fontforge/files/patch-fontforge::makenomenh.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- fontforge/makenomenh.c.orig Wed Oct 19 09:50:52 2005
-+++ fontforge/makenomenh.c Wed Oct 19 09:51:36 2005
-@@ -299,7 +299,7 @@
- fprintf( po, "\"Project-Id-Version: PACKAGE VERSION\\n\"\n" );
- time(&now);
- tmnow = localtime(&now);
--#if !defined(__Mac) && !defined(__CygWin)
-+#if !defined(__Mac) && !defined(__CygWin) && !defined(__FreeBSD__)
- fprintf( po, "\"POT-Creation-Date: %d-%02d-%02d %02d:%02d+%02ld%02ld\\n\"\n",
- tmnow->tm_year+1900, tmnow->tm_mon, tmnow->tm_mday,
- tmnow->tm_hour, tmnow->tm_min,
diff --git a/print/fontforge/pkg-plist b/print/fontforge/pkg-plist
index 156e268daf19..48aa67d357ab 100644
--- a/print/fontforge/pkg-plist
+++ b/print/fontforge/pkg-plist
@@ -1,5 +1,4 @@
bin/fontforge
-bin/pfaedit
bin/sfddiff
lib/libgdraw.a
lib/libgdraw.la
@@ -10,11 +9,24 @@ lib/libgunicode.la
lib/libgunicode.so
lib/libgunicode.so.2
libdata/pkgconfig/fontforge.pc
+share/locale/es/LC_MESSAGES/FontForge.mo
+share/locale/fr/LC_MESSAGES/FontForge.mo
+share/locale/it/LC_MESSAGES/FontForge.mo
+share/locale/ja/LC_MESSAGES/FontForge.mo
+share/locale/ru/LC_MESSAGES/FontForge.mo
+%%DOCSDIR%%/LICENSE
+%%DATADIR%%/Adobe-CNS1-4.cidmap
+%%DATADIR%%/Adobe-GB1-4.cidmap
+%%DATADIR%%/Adobe-Identity-0.cidmap
+%%DATADIR%%/Adobe-Japan1-6.cidmap
+%%DATADIR%%/Adobe-Japan2-0.cidmap
+%%DATADIR%%/Adobe-Korea1-2.cidmap
%%PORTDOCS%%%%DOCSDIR%%/AA-Comparison.html
%%PORTDOCS%%%%DOCSDIR%%/AmbrosiaFV-bm.png
%%PORTDOCS%%%%DOCSDIR%%/AmbrosiaFV.png
%%PORTDOCS%%%%DOCSDIR%%/Anna.gif
%%PORTDOCS%%%%DOCSDIR%%/Antigone.gif
+%%PORTDOCS%%%%DOCSDIR%%/As.png
%%PORTDOCS%%%%DOCSDIR%%/BDFgrey.html
%%PORTDOCS%%%%DOCSDIR%%/BethSans.png
%%PORTDOCS%%%%DOCSDIR%%/BethSerif.png
@@ -131,6 +143,7 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/anchorcontrol-base.png
%%PORTDOCS%%%%DOCSDIR%%/anchorcontrol-mark.png
%%PORTDOCS%%%%DOCSDIR%%/anchorcontrol.html
+%%PORTDOCS%%%%DOCSDIR%%/arabic-seen.png
%%PORTDOCS%%%%DOCSDIR%%/asm1.png
%%PORTDOCS%%%%DOCSDIR%%/asm2.png
%%PORTDOCS%%%%DOCSDIR%%/asm3.png
@@ -140,6 +153,8 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/autowidth.html
%%PORTDOCS%%%%DOCSDIR%%/autowidth.png
%%PORTDOCS%%%%DOCSDIR%%/autowidthmenu.png
+%%PORTDOCS%%%%DOCSDIR%%/bdfinfo.html
+%%PORTDOCS%%%%DOCSDIR%%/bdfinfo.png
%%PORTDOCS%%%%DOCSDIR%%/bed-script.png
%%PORTDOCS%%%%DOCSDIR%%/bezier.gif
%%PORTDOCS%%%%DOCSDIR%%/bezier.html
@@ -356,6 +371,7 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/macfeature.png
%%PORTDOCS%%%%DOCSDIR%%/macformats.html
%%PORTDOCS%%%%DOCSDIR%%/mad.html
+%%PORTDOCS%%%%DOCSDIR%%/manual-ja-hover.png
%%PORTDOCS%%%%DOCSDIR%%/manual-ja.png
%%PORTDOCS%%%%DOCSDIR%%/markclass.png
%%PORTDOCS%%%%DOCSDIR%%/mergepost.png
@@ -409,6 +425,7 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/phi-hints-outline.png
%%PORTDOCS%%%%DOCSDIR%%/phi-nohints-filled.png
%%PORTDOCS%%%%DOCSDIR%%/phi-nohints-outline.png
+%%PORTDOCS%%%%DOCSDIR%%/plugins.html
%%PORTDOCS%%%%DOCSDIR%%/pnts.gif
%%PORTDOCS%%%%DOCSDIR%%/pointinfo.png
%%PORTDOCS%%%%DOCSDIR%%/pointmenu.html
@@ -431,6 +448,7 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/quadraticspline.png
%%PORTDOCS%%%%DOCSDIR%%/quotations.html
%%PORTDOCS%%%%DOCSDIR%%/realindex.html
+%%PORTDOCS%%%%DOCSDIR%%/ref-caveats.html
%%PORTDOCS%%%%DOCSDIR%%/removefeature.png
%%PORTDOCS%%%%DOCSDIR%%/retagfeature.png
%%PORTDOCS%%%%DOCSDIR%%/rgetinfo.png
@@ -456,6 +474,7 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/sfd.html
%%PORTDOCS%%%%DOCSDIR%%/sfddiff.html
%%PORTDOCS%%%%DOCSDIR%%/sfdformat.html
+%%PORTDOCS%%%%DOCSDIR%%/short-long-s.png
%%PORTDOCS%%%%DOCSDIR%%/showatt.html
%%PORTDOCS%%%%DOCSDIR%%/showatt.png
%%PORTDOCS%%%%DOCSDIR%%/sidebearings.png
@@ -491,7 +510,9 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/ttfinstrs-edit.png
%%PORTDOCS%%%%DOCSDIR%%/ttfinstrs-view.png
%%PORTDOCS%%%%DOCSDIR%%/ttfinstrs.html
+%%PORTDOCS%%%%DOCSDIR%%/tutorial-ja-hover.png
%%PORTDOCS%%%%DOCSDIR%%/tutorial-ja.png
+%%PORTDOCS%%%%DOCSDIR%%/tutorial-zh_TW-hover.png
%%PORTDOCS%%%%DOCSDIR%%/tutorial-zh_TW.png
%%PORTDOCS%%%%DOCSDIR%%/twolines.png
%%PORTDOCS%%%%DOCSDIR%%/typofeat.html
@@ -503,21 +524,175 @@ libdata/pkgconfig/fontforge.pc
%%PORTDOCS%%%%DOCSDIR%%/x-height.png
%%PORTDOCS%%%%DOCSDIR%%/xim.html
%%PORTDOCS%%%%DOCSDIR%%/xres.html
-%%DOCSDIR%%/LICENSE
-%%DATADIR%%/Adobe-CNS1-4.cidmap
-%%DATADIR%%/Adobe-GB1-4.cidmap
-%%DATADIR%%/Adobe-Identity-0.cidmap
-%%DATADIR%%/Adobe-Japan1-6.cidmap
-%%DATADIR%%/Adobe-Japan2-0.cidmap
-%%DATADIR%%/Adobe-Korea1-2.cidmap
-%%DATADIR%%/pfaedit-de.ui
-%%DATADIR%%/pfaedit-en.ui
-%%DATADIR%%/pfaedit-es.ui
-%%DATADIR%%/pfaedit-fr.ui
-%%DATADIR%%/pfaedit-gr.ui
-%%DATADIR%%/pfaedit-it.ui
-%%DATADIR%%/pfaedit-ja.ui
-%%DATADIR%%/pfaedit-ru.ui
-%%DATADIR%%/pfaedit-zh.ui
+%%PORTDOCS%%%%DOCSDIR%%/flags/BrasilFlag.png
+%%PORTDOCS%%%%DOCSDIR%%/flags/GermanFlag.png
+%%PORTDOCS%%%%DOCSDIR%%/flags/MalgasyFlag.gif
+%%PORTDOCS%%%%DOCSDIR%%/flags/Nisshoki-Japan.png
+%%PORTDOCS%%%%DOCSDIR%%/flags/RussianFlag.png
+%%PORTDOCS%%%%DOCSDIR%%/flags/StarsStripes.gif
+%%PORTDOCS%%%%DOCSDIR%%/flags/Tricolor.gif
+%%PORTDOCS%%%%DOCSDIR%%/flags/UnionJack.gif
+%%PORTDOCS%%%%DOCSDIR%%/flags/taiwan.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/AA-Comparison.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/AmbrosiaFV.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/BDFgrey.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/BitmapView.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/FontForge.css
+%%PORTDOCS%%%%DOCSDIR%%/ja/GenerateFamily.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/GenerateOptions.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/GlossaryFS.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/GlossaryFrame.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/HotKeys.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/IndexFS.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/IndexFrame.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/MacOSX.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/MetaFont.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/MetricsView.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/PfaEdit-TeX.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/TrueOpenTables.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/UniqueID.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/VerticalMetrics.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/accented.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/acorn2sfd.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/agetinfo.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/anchorcontrol.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/autotrace.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/autowidth.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/bezier.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/bibliography.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/bitmapsavail.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/bitmapview.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/changelog.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/charinfo.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/charview.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/charview2.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/cidmapformat.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/cidmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/cliargs.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/contextchain.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/corpchar.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/definegroups.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/diffs.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/display.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/displaygroups.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/editexample.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/editexample2.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/editexample3.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/editexample4.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/editexample5.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/editexample6-5.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/editexample6.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/editexample7.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/editmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/elementmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/encodingmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/errrecovery.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/expandstroke.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/faqFS.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/faqFrame.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/filemenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/files.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-comment.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-macstyle.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-panose.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-private.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-ps.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-size.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-statemach.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-subsup.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-tex.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-ttfmetrics.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo-ttfvals.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontinfo.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontutils.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontview-grouped.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/fontview.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/future.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/generate.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/generate.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/getinfo.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/glossary.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/gposgsub.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/greymapsavail.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/groups.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/helpmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/hinting.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/hintsmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/histogram.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/index.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/kernpairs.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/license.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/locale.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/mac-install.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/macformats.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/mad.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/metricsmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/metricsview.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/mmmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/ms-install.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/multilayer.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/multiplemaster.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/nix-install.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/non-standard.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/nvd.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/oldchangelog.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/otherlinks.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/overview.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/palmfonts.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/pcf-format.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/pfaeditchangelog.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/pfaeditmath.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/plugins.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/pointinfo.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/pointmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/prefs.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/print.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/privatekey.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/privatekeymenu.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/problems.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/quotations.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/realindex.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/ref-caveats.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/rgetinfo.png
+%%PORTDOCS%%%%DOCSDIR%%/ja/running.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/scripting.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/scriptnotes.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/search.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/selectbyatt.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/selections.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/sfd.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/sfddiff.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/sfdformat.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/showatt.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/source-build.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/splinefont.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/src.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/statemachine.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/tilepath.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/transform.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/ttfinstrs.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/typofeat.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/viewmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/views.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/vms-install.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/wacom.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/windowmenu.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/xim.html
+%%PORTDOCS%%%%DOCSDIR%%/ja/xres.html
@dirrm %%DATADIR%%
+@dirrm %%DOCSDIR%%/flags
+@dirrm %%DOCSDIR%%/ja
@dirrm %%DOCSDIR%%
+@dirrmtry share/locale/es/LC_MESSAGES
+@dirrmtry share/locale/es
+@dirrmtry share/locale/fr/LC_MESSAGES
+@dirrmtry share/locale/fr
+@dirrmtry share/locale/it/LC_MESSAGES
+@dirrmtry share/locale/it
+@dirrmtry share/locale/ja/LC_MESSAGES
+@dirrmtry share/locale/ja
+@dirrmtry share/locale/ru/LC_MESSAGES
+@dirrmtry share/locale/ru
+@dirrmtry share/locale