aboutsummaryrefslogtreecommitdiff
path: root/print/foomatic-filters
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2014-05-19 18:06:13 +0000
committerKris Moore <kmoore@FreeBSD.org>2014-05-19 18:06:13 +0000
commit09dd54b92c4a40744b24ffbcdbf3a2f878de973c (patch)
tree160da38f97bcffc9319a85a1da9aebb4ac666c21 /print/foomatic-filters
parent9221b33bbc69e20b5fa3449f16c2ea75e447a198 (diff)
downloadports-09dd54b92c4a40744b24ffbcdbf3a2f878de973c.tar.gz
ports-09dd54b92c4a40744b24ffbcdbf3a2f878de973c.zip
Notes
Diffstat (limited to 'print/foomatic-filters')
-rw-r--r--print/foomatic-filters/Makefile3
-rw-r--r--print/foomatic-filters/files/patch-foomaticrip.c24
2 files changed, 23 insertions, 4 deletions
diff --git a/print/foomatic-filters/Makefile b/print/foomatic-filters/Makefile
index 113f8cb14510..09e9abe06b01 100644
--- a/print/foomatic-filters/Makefile
+++ b/print/foomatic-filters/Makefile
@@ -3,7 +3,7 @@
PORTNAME= foomatic-filters
PORTVERSION= 4.0.17
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/foomatic/
@@ -72,6 +72,7 @@ RUN_DEPENDS+= mpage:${PORTSDIR}/print/mpage
post-patch:
@${REINPLACE_CMD} -e 's|/bin/bash|${SH}|g' ${WRKSRC}/foomaticrip.c
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/foomaticrip.c
@${REINPLACE_CMD} -e '/filter.conf/ s|if|#if|g' ${WRKSRC}/Makefile.in
post-install:
diff --git a/print/foomatic-filters/files/patch-foomaticrip.c b/print/foomatic-filters/files/patch-foomaticrip.c
index 347f75f8ad5e..21d3eb7ead4b 100644
--- a/print/foomatic-filters/files/patch-foomaticrip.c
+++ b/print/foomatic-filters/files/patch-foomaticrip.c
@@ -1,6 +1,24 @@
---- foomaticrip.c.orig 2014-04-26 11:32:42.578342305 +0400
-+++ foomaticrip.c 2014-04-26 11:44:16.016294870 +0400
-@@ -1197,7 +1197,8 @@ int main(int argc, char** argv)
+--- foomaticrip.c.orig 2012-07-02 10:50:46.000000000 -0400
++++ foomaticrip.c 2014-05-19 10:28:46.588515788 -0400
+@@ -180,7 +180,7 @@
+ "/opt/cups/filter:"
+ "/usr/lib/cups/filter";
+
+-char modern_shell[64] = "/bin/bash";
++char modern_shell[64] = "/bin/sh";
+
+ void config_set_option(const char *key, const char *value)
+ {
+@@ -1061,7 +1061,7 @@
+ Ghostscript is not available. */
+ if (spooler == SPOOLER_CUPS)
+ snprintf(pdf2ps_cmd, PATH_MAX,
+- "pdftops '%s' '%s' '%s' '%s' '%s' '%s'",
++ "%%LOCALBASE%%/libexec/cups/filter/pdftops '%s' '%s' '%s' '%s' '%s' '%s'",
+ job->id, job->user, job->title, "1", job->optstr->data,
+ filename);
+ else
+@@ -1197,7 +1197,8 @@
debug = 1;
if (debug) {