aboutsummaryrefslogtreecommitdiff
path: root/print/freetype2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-30 06:05:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-30 06:05:45 +0000
commitb4bb4bf90c6a5cfbafa8bdbaae39cc74241a9123 (patch)
tree58371532a687dad87b3fb894d3ec2ddb756c54c8 /print/freetype2/Makefile
parent9e06cd35a54cc8e093742dc3ddcc096cd021ea9d (diff)
downloadports-b4bb4bf90c6a5cfbafa8bdbaae39cc74241a9123.tar.gz
ports-b4bb4bf90c6a5cfbafa8bdbaae39cc74241a9123.zip
Notes
Diffstat (limited to 'print/freetype2/Makefile')
-rw-r--r--print/freetype2/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index 28185e98fd40..7820f87076be 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= freetype2
-PORTVERSION= 2.1.4
-PORTREVISION= 1
+PORTVERSION= 2.1.5
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%,freetype,} \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/%SUBDIR%/ \
@@ -18,7 +17,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%,freetype,} \
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= ${PORTNAME:S/2//}-${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gnome@FreeBSD.org
COMMENT= A free and portable TrueType font rendering engine
USE_BZIP2= yes
@@ -26,11 +25,16 @@ USE_GMAKE= yes
MAKE_ENV= TOP=""
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
+USE_GNOME= gnometarget
+USE_REINPLACE= yes
LIBTOOLFILES= builds/unix/configure
CONFIGURE_ARGS= --disable-nls
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-unknown-freebsd${OSREL}
CONFIGURE_WRKSRC= ${WRKSRC}/builds/unix
+pre-patch:
+ @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/builds/unix/install.mk
+
post-configure:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} setup)