aboutsummaryrefslogtreecommitdiff
path: root/print/frescobaldi/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-09-17 10:04:37 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-09-17 10:04:37 +0000
commit790a0f1d9bc996066aff29ee34be75bbac0deae5 (patch)
treeb887f1bdaf5fb6d9a7bf96bef48f7816d7c7b80b /print/frescobaldi/Makefile
parent4b633df65e3a93ac7b78519544dd71fd8f34cd58 (diff)
Notes
Diffstat (limited to 'print/frescobaldi/Makefile')
-rw-r--r--print/frescobaldi/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/print/frescobaldi/Makefile b/print/frescobaldi/Makefile
new file mode 100644
index 000000000000..ceff29658970
--- /dev/null
+++ b/print/frescobaldi/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: frescobaldi
+# Date created: 17 April 2011
+# Whom: martin.dieringer@gmx.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= frescobaldi
+PORTVERSION= 1.2.0
+CATEGORIES= print
+MASTER_SITES= http://lilykde.googlecode.com/files/
+
+MAINTAINER= martin.dieringer@gmx.de
+COMMENT= A music score editor for lilypond
+
+BUILD_DEPENDS= ${KDE4_PREFIX}/lib/kde4/kpythonpluginfactory.so:${PORTSDIR}/devel/kdebindings4-python-pykde4
+RUN_DEPENDS= lilypond:${PORTSDIR}/print/lilypond
+
+USE_GETTEXT= yes
+INSTALLS_ICONS= yes
+USE_KDE4= kdebase kdeprefix kdelibs pykde4
+USE_CMAKE= yes
+USE_GMAKE= yes
+USE_PYTHON= 2.6+
+
+do-install:
+ @cd ${WRKSRC} && ${GMAKE} install
+
+.include <bsd.port.mk>