aboutsummaryrefslogtreecommitdiff
path: root/print/gfontview/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-26 18:57:57 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-07-26 18:57:57 +0000
commit7145af16635db2964d5ee2dda0e9babc1102a4bc (patch)
treee4dd7760a78bfcfa6a350486af890b8193215742 /print/gfontview/Makefile
parent9ba380ef2691e99b409bf3d7d74e5d23ab0f6324 (diff)
downloadports-7145af16635db2964d5ee2dda0e9babc1102a4bc.tar.gz
ports-7145af16635db2964d5ee2dda0e9babc1102a4bc.zip
Notes
Diffstat (limited to 'print/gfontview/Makefile')
-rw-r--r--print/gfontview/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/print/gfontview/Makefile b/print/gfontview/Makefile
new file mode 100644
index 000000000000..5d2a77ef35e6
--- /dev/null
+++ b/print/gfontview/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# New ports collection makefile for: gfontview
+# Date created: Jul 9, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gfontview
+PORTVERSION= 0.5.0
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= t1:${PORTSDIR}/devel/t1lib \
+ ungif:${PORTSDIR}/graphics/libungif \
+ intl:${PORTSDIR}/devel/gettext
+
+USE_X_PREFIX= yes
+USE_FREETYPE= yes
+USE_GTK= yes
+USE_GNOME= yes
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-libungif
+
+post-patch:
+ @${PERL} -pi -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>