aboutsummaryrefslogtreecommitdiff
path: root/print/ggv/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-05-30 03:43:44 +0000
committerSteve Price <steve@FreeBSD.org>1999-05-30 03:43:44 +0000
commit68dd7b16f342cc9f38ab6ec4aa42d6bd7e759aae (patch)
treee285328544d5c5f96c6d7295f48818b73510b950 /print/ggv/Makefile
parente5386b5a68c83aba559bb941fd464f2676d89682 (diff)
downloadports-68dd7b16f342cc9f38ab6ec4aa42d6bd7e759aae.tar.gz
ports-68dd7b16f342cc9f38ab6ec4aa42d6bd7e759aae.zip
Notes
Diffstat (limited to 'print/ggv/Makefile')
-rw-r--r--print/ggv/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/print/ggv/Makefile b/print/ggv/Makefile
index 8c4088bcc499..b15b42b71938 100644
--- a/print/ggv/Makefile
+++ b/print/ggv/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: ggv
-# Version required: 0.26
+# Version required: 0.30
# Date created: 21 August 1998
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
-# $Id: Makefile,v 1.6 1999/04/08 18:08:35 steve Exp $
+# $Id: Makefile,v 1.7 1999/04/26 21:18:18 mharo Exp $
#
-DISTNAME= ggv-0.26
+DISTNAME= ggv-0.30
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/ggv
@@ -16,16 +16,15 @@ MAINTAINER= nacai@iname.com
BUILD_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
-# implicit dependencies:
-# gettext, xpm, gtk11-devel, gnomelibs
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
--datadir=${PREFIX}/share/gnome \
- --with-gnome=${X11BASE}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- GTK_CONFIG="${X11BASE}/bin/gtk12-config" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lxpg4"
+ --with-gnome=${PREFIX}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>