aboutsummaryrefslogtreecommitdiff
path: root/print/ggv/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-24 23:42:17 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-24 23:42:17 +0000
commit12cdd35c4b93fe83a6f5806e823f7991132b16ff (patch)
treef5f10072537dbd0e48ef1e7781074dd236c0a18d /print/ggv/Makefile
parentab228e5b7d711252695a6950bb6bec15feb848f1 (diff)
downloadports-12cdd35c4b93fe83a6f5806e823f7991132b16ff.tar.gz
ports-12cdd35c4b93fe83a6f5806e823f7991132b16ff.zip
Notes
Diffstat (limited to 'print/ggv/Makefile')
-rw-r--r--print/ggv/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/print/ggv/Makefile b/print/ggv/Makefile
new file mode 100644
index 000000000000..a9b6bf275ce2
--- /dev/null
+++ b/print/ggv/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: ggv2
+# Date created: 07 July 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ggv
+PORTVERSION= 2.8.2
+CATEGORIES= print gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.8
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= GNOME 2 ghostscript viewer
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+INSTALLS_OMF= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui desktopfileutils
+USE_GHOSTSCRIPT=yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= ggv.schemas
+
+pre-everything::
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO_MSG} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO_MSG} ""
+.endif
+
+.include <bsd.port.mk>