aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript-gpl
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>2000-08-24 20:43:55 +0000
committerAndreas Klemm <andreas@FreeBSD.org>2000-08-24 20:43:55 +0000
commit9269d1b0ebac420ced4f1856ac0c561292fab314 (patch)
tree17758bfa888cd1f3aaf9bbd0d0c47729052180e8 /print/ghostscript-gpl
parent41fc0919a07d8a83c18645d30cf9839c251bafa2 (diff)
downloadports-9269d1b0ebac420ced4f1856ac0c561292fab314.tar.gz
ports-9269d1b0ebac420ced4f1856ac0c561292fab314.zip
Notes
Diffstat (limited to 'print/ghostscript-gpl')
-rw-r--r--print/ghostscript-gpl/Makefile1
-rw-r--r--print/ghostscript-gpl/files/patch-aa73
2 files changed, 57 insertions, 17 deletions
diff --git a/print/ghostscript-gpl/Makefile b/print/ghostscript-gpl/Makefile
index dd19d26b28b0..d2f3ceaa4070 100644
--- a/print/ghostscript-gpl/Makefile
+++ b/print/ghostscript-gpl/Makefile
@@ -27,7 +27,6 @@ PLIST_SUB= GS_VERSION=${PORTVERSION}
USE_XLIB= yes
EXTRACT_ONLY= ${GS_SOURCES} ${HPDJ_DRV}
WRKSRC= ${WRKDIR}/gs${PORTVERSION}
-USE_GMAKE= yes
MAKEFILE= src/unix-gcc.mak
CFLAGS+= -I${PREFIX}/include
# Note: the order that the manpages are listed here matters because
diff --git a/print/ghostscript-gpl/files/patch-aa b/print/ghostscript-gpl/files/patch-aa
index 9706ac798453..ef9be84a3dda 100644
--- a/print/ghostscript-gpl/files/patch-aa
+++ b/print/ghostscript-gpl/files/patch-aa
@@ -1,6 +1,30 @@
---- src/unix-gcc.mak.orig Sat Mar 18 05:13:40 2000
-+++ src/unix-gcc.mak Sat Mar 25 21:47:45 2000
-@@ -52,11 +52,10 @@
+--- src/unix-gcc.mak Fri Mar 17 23:13:40 2000
++++ src/unix-gcc.mak Wed Jul 19 10:23:42 2000
+@@ -26,14 +26,15 @@
+ # source, generated intermediate file, and object directories
+ # for the graphics library (GL) and the PostScript/PDF interpreter (PS).
+
+-BINDIR=./bin
+-GLSRCDIR=./src
+-GLGENDIR=./obj
+-GLOBJDIR=./obj
+-PSSRCDIR=./src
+-PSLIBDIR=./lib
+-PSGENDIR=./obj
+-PSOBJDIR=./obj
++.CURDIR?=.
++BINDIR=${.CURDIR}/bin
++GLSRCDIR=${.CURDIR}/src
++GLGENDIR=${.CURDIR}/obj
++GLOBJDIR=${.CURDIR}/obj
++PSSRCDIR=${.CURDIR}/src
++PSLIBDIR=${.CURDIR}/lib
++PSGENDIR=${.CURDIR}/obj
++PSOBJDIR=${.CURDIR}/obj
+
+ # Do not edit the next group of lines.
+
+@@ -52,11 +53,10 @@
# the directories also define the default search path for the
# initialization files (gs_*.ps) and the fonts.
@@ -15,7 +39,24 @@
exec_prefix = $(prefix)
bindir = $(exec_prefix)/bin
scriptdir = $(bindir)
-@@ -153,7 +152,7 @@
+@@ -128,7 +128,7 @@
+ # You may need to change this if the IJG library version changes.
+ # See jpeg.mak for more information.
+
+-JSRCDIR=jpeg
++JSRCDIR=${.CURDIR}/jpeg
+ JVERSION=6
+
+ # Choose whether to use a shared version of the IJG JPEG library (-ljpeg).
+@@ -146,14 +147,14 @@
+ # You may need to change this if the libpng version changes.
+ # See libpng.mak for more information.
+
+-PSRCDIR=libpng
++PSRCDIR=${PREFIX}/include
+ PVERSION=10005
+
+ # Choose whether to use a shared version of the PNG library, and if so,
# what its name is.
# See gs.mak and Make.htm for more information.
@@ -24,7 +65,7 @@
LIBPNG_NAME=png
# Define the directory where the zlib sources are stored.
-@@ -165,7 +164,7 @@
+@@ -165,7 +165,7 @@
# what its name is (usually libz, but sometimes libgz).
# See gs.mak and Make.htm for more information.
@@ -33,16 +74,16 @@
#ZLIB_NAME=gz
ZLIB_NAME=z
-@@ -180,7 +179,7 @@
+@@ -180,7 +180,7 @@
# Define the name of the C compiler.
-CC=gcc
-+CC=cc
++CC?=cc
# Define the name of the linker for the final link step.
# Normally this is the same as the C compiler.
-@@ -213,7 +212,7 @@
+@@ -213,7 +213,7 @@
# gcc to accept ANSI-style function prototypes and function definitions.
XCFLAGS=
@@ -51,7 +92,7 @@
# Define platform flags for ld.
# SunOS 4.n may need -Bstatic.
-@@ -222,7 +221,7 @@
+@@ -222,7 +222,7 @@
# -R /usr/local/xxx/lib:/usr/local/lib
# giving the full path names of the shared library directories.
# XLDFLAGS can be set from the command line.
@@ -60,7 +101,7 @@
LDFLAGS=$(XLDFLAGS) -fno-common
-@@ -242,7 +241,7 @@
+@@ -242,7 +242,7 @@
# All reasonable platforms require -lm, but Rhapsody and perhaps one or
# two others fold libm into libc and don't require any additional library.
@@ -69,7 +110,7 @@
# Define the include switch(es) for the X11 header files.
# This can be null if handled in some other way (e.g., the files are
-@@ -252,7 +251,7 @@
+@@ -252,7 +252,7 @@
# Note that x_.h expects to find the header files in $(XINCLUDE)/X11,
# not in $(XINCLUDE).
@@ -78,7 +119,7 @@
# Define the directory/ies and library names for the X11 library files.
# XLIBDIRS is for ld and should include -L; XLIBDIR is for LD_RUN_PATH
-@@ -264,12 +263,12 @@
+@@ -264,12 +264,12 @@
# Solaris and other SVR4 systems with dynamic linking probably want
#XLIBDIRS=-L/usr/openwin/lib -R/usr/openwin/lib
# X11R6 (on any platform) may need
@@ -94,7 +135,7 @@
# Define whether this platform has floating point hardware:
# FPU_TYPE=2 means floating point is faster than fixed point.
-@@ -327,7 +326,7 @@
+@@ -327,7 +327,7 @@
# Choose the device(s) to include. See devs.mak for details,
# devs.mak and contrib.mak for the list of available devices.
@@ -103,7 +144,7 @@
#DEVICE_DEVS1=
#DEVICE_DEVS2=
-@@ -345,27 +344,27 @@
+@@ -345,27 +345,27 @@
#DEVICE_DEVS14=
#DEVICE_DEVS15=
@@ -152,7 +193,7 @@
# ---------------------------- End of options --------------------------- #
-@@ -379,13 +378,13 @@
+@@ -379,13 +379,13 @@
# detect whether we're running a version of gcc with the const optimization
# bug.
@@ -169,7 +210,7 @@
CC_LEAF=$(CC_) -fomit-frame-pointer
# gcc can't use -fomit-frame-pointer with -pg.
CC_LEAF_PG=$(CC_)
-@@ -412,5 +411,5 @@
+@@ -412,5 +412,5 @@
include $(GLSRCDIR)/unixinst.mak
# This has to come last so it won't be taken as the default target.