aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript7-commfont/files
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2013-04-29 20:12:16 +0000
committerHiroki Sato <hrs@FreeBSD.org>2013-04-29 20:12:16 +0000
commit045633a1b8b9a93da39276c44d8313ec66a07545 (patch)
treeb668622bec03cea02602798988a5ed72533143b2 /print/ghostscript7-commfont/files
parent968e6d2e1642a5f80b17ddc2526cf8092042645a (diff)
downloadports-045633a1b8b9a93da39276c44d8313ec66a07545.tar.gz
ports-045633a1b8b9a93da39276c44d8313ec66a07545.zip
Notes
Diffstat (limited to 'print/ghostscript7-commfont/files')
-rw-r--r--print/ghostscript7-commfont/files/Makefile.in140
-rw-r--r--print/ghostscript7-commfont/files/pkg-message.in13
-rw-r--r--print/ghostscript7-commfont/files/template.cidfont.in10
-rw-r--r--print/ghostscript7-commfont/files/template.font.in12
-rw-r--r--print/ghostscript7-commfont/files/template.ttcidfont.in10
5 files changed, 185 insertions, 0 deletions
diff --git a/print/ghostscript7-commfont/files/Makefile.in b/print/ghostscript7-commfont/files/Makefile.in
new file mode 100644
index 000000000000..ca964984a91f
--- /dev/null
+++ b/print/ghostscript7-commfont/files/Makefile.in
@@ -0,0 +1,140 @@
+# $FreeBSD$
+
+PREFIX?= /usr/local
+LOCALBASE?= /usr/local
+CMAPDIR?= ${LOCALBASE}/share/fonts/adobe-cmaps
+CIDFONTDIR?= ${LOCALBASE}/share/fonts/CIDFont
+GS_FONTDIR?= ${LOCALBASE}/share/ghostscript/fonts
+GS_RESFONTDIR?= ${LOCALBASE}/share/ghostscript/Resource/Font
+GS_RESCIDFONTDIR?= ${LOCALBASE}/share/ghostscript/Resource/CIDFont
+GS_RESCMAPDIR?= ${LOCALBASE}/share/ghostscript/Resource/CMap
+
+INSTALL_DATA?= install -m 444
+MKDIR?= mkdir -p
+LN?= ln
+FIND?= find
+AWK?= awk
+R?= 
+PROGRESS?= BEGIN { mark[0]=\"|\"; mark[1]=\"|\"; mark[2]=\"/\"; mark[3]=\"/\"; mark[4]=\"-\"; mark[5]=\"-\"; mark[6]=\"\\\\\"; mark[7]=\"\\\\\"; line = 0; } { line = (line + 1) % 8; printf(\"Generating virtual fonts...%s${R}\n\", mark[line]); }
+
+TEMPLATES_TTF= cs.serif cs.sansserif \
+ ct.serif cs.sansserif \
+ ja.serif ja.sansserif
+TEMPLATES_CID= ko.serif ko.sansserif
+
+CS.CMAPS= ac15
+
+CS.SERIF.GENERIC= STSong-Light
+CS.SERIF.GENERIC_SUBST= STSong-Light
+CS.SERIF= STSong-Light
+
+CS.SANSSERIF.GENERIC= STHeiti-Regular
+CS.SANSSERIF.GENERIC_SUBST= STHeiti-Regular
+CS.SANSSERIF= STHeiti-Regular
+
+CT.CMAPS= ag15
+
+CT.SERIF.GENERIC= MSung-Light
+CT.SERIF.GENERIC_SUBST= MSung-Light
+CT.SERIF= MSung-Light
+
+CT.SANSSERIF.GENERIC= MHei-Medium
+CT.SANSSERIF.GENERIC_SUBST= MHei-Medium
+CT.SANSSERIF= MHei-Medium
+
+JA.CMAPS= aj16 aj20
+
+JA.SERIF.GENERIC= Ryumin-Light
+JA.SERIF.GENERIC_SUBST= Ryumin-Light
+JA.SERIF= Ryumin-Light \
+ FutoMinA101-Bold \
+ HeiseiMin-W3
+
+JA.SANSSERIF.GENERIC= GothicBBB-Medium
+JA.SANSSERIF.GENERIC_SUBST= GothicBBB-Medium
+JA.SANSSERIF= GothicBBB-Medium \
+ FutoGoB101-Bold \
+ HeiseiKakuGo-W5 \
+ HGSSoeiKakugothicUB \
+ HGPSoeiKakugothicUB
+
+KO.CMAPS= ak12
+
+KO.SERIF.GENERIC= HYSMyeongJo-Medium
+KO.SERIF.GENERIC_SUBST= Munhwa-Regular
+KO.SERIF= HYSMyeongJo-Medium
+
+KO.SANSSERIF.GENERIC= HYGoThic-Medium
+KO.SANSSERIF.GENERIC_SUBST= MunhwaGothic-Regular
+KO.SANSSERIF= HYGoThic-Medium
+
+all:
+ @${MKDIR} CIDFont Font
+.for T in ${TEMPLATES_TTF}
+ @for F in ${${T:U}}; do \
+ echo "Generating CIDFont/$${F}"; \
+ sed -e "s,%%FONTNAME%%,$$F,g" \
+ -e "s,%%GS_FONTDIR%%,${GS_FONTDIR}," \
+ -e "s,%%GENERICFONTNAME%%,${${T:U}.GENERIC}," \
+ -e "s,%%GENERICFONTNAME_SUBST%%,${${T:U}.GENERIC_SUBST}," \
+ < template.ttcidfont > CIDFont/$${F}; \
+ for D in ${${T:U:C/\.[^.]*$//}.CMAPS}; do \
+ if [ -d ${CMAPDIR}/$${D}/CMap ]; then \
+ CMAPS=`cd ${CMAPDIR}/$${D}/CMap; echo *`; \
+ elif [ -r ${CMAPDIR}/$${D} ]; then \
+ CMAPS=`basename $${D}`; \
+ else \
+ echo "$${D}: not found"; exit 1; \
+ fi; \
+ for C in $${CMAPS}; do \
+ echo "Generating Font/$${F}-$${C}"; \
+ sed -e "s,%%FONTNAME%%,$$F,g" \
+ -e "s,%%GS_FONTDIR%%,${GS_FONTDIR}," \
+ -e "s,%%CMAPNAME%%,$${C}," \
+ -e "s,%%GENERICFONTNAME%%,${${T:U}.GENERIC}," \
+ -e "s,%%GENERICFONTNAME_SUBST%%,${${T:U}.GENERIC_SUBST}," \
+ < template.font > Font/$${F}-$${C}; \
+ done; \
+ done; \
+ done | awk "${PROGRESS}"
+.endfor
+.for T in ${TEMPLATES_CID}
+ @for F in ${${T:U}}; do \
+ echo "Generating CIDFont/$${F}"; \
+ sed -e "s,%%FONTNAME%%,$$F,g" \
+ -e "s,%%GS_FONTDIR%%,${GS_FONTDIR}," \
+ -e "s,%%GENERICFONTNAME%%,${${T:U}.GENERIC}," \
+ -e "s,%%GENERICFONTNAME_SUBST%%,${${T:U}.GENERIC_SUBST}," \
+ < template.cidfont > CIDFont/$${F}; \
+ for D in ${${T:U:C/\.[^.]*$//}.CMAPS}; do \
+ if [ -d ${CMAPDIR}/$${D}/CMap ]; then \
+ CMAPS=`cd ${CMAPDIR}/$${D}/CMap; echo *`; \
+ elif [ -r ${CMAPDIR}/$${D} ]; then \
+ CMAPS=`basename $${D}`; \
+ else \
+ echo "$${D}: not found"; exit 1; \
+ fi; \
+ for C in $${CMAPS}; do \
+ echo "Generating Font/$${F}-$${C}"; \
+ sed -e "s,%%FONTNAME%%,$$F,g" \
+ -e "s,%%GS_FONTDIR%%,${GS_FONTDIR}," \
+ -e "s,%%CMAPNAME%%,$${C}," \
+ -e "s,%%GENERICFONTNAME%%,${${T:U}.GENERIC}," \
+ -e "s,%%GENERICFONTNAME_SUBST%%,${${T:U}.GENERIC_SUBST}," \
+ < template.font > Font/$${F}-$${C}; \
+ done; \
+ done; \
+ done | awk "${PROGRESS}"
+.endfor
+ @echo "Generating virtual fonts...done."
+
+install:
+ ${MKDIR} ${GS_RESCIDFONTDIR}
+ ${INSTALL_DATA} CIDFont/* ${GS_RESCIDFONTDIR}
+ ${MKDIR} ${GS_RESFONTDIR}
+ ${INSTALL_DATA} Font/* ${GS_RESFONTDIR}
+ ${MKDIR} ${GS_RESCMAPDIR}
+ cd ${GS_RESCMAPDIR} && ${LN} -s -f `${FIND} ${CMAPDIR} -type f` .
+.for T in ${TEMPLATES_CID}
+ cd ${GS_RESCIDFONTDIR} && ${LN} -s -f ${CIDFONTDIR}/${${T:U}.GENERIC_SUBST} ${${T:U}.GENERIC_SUBST}
+.endfor
diff --git a/print/ghostscript7-commfont/files/pkg-message.in b/print/ghostscript7-commfont/files/pkg-message.in
new file mode 100644
index 000000000000..34170fbf1815
--- /dev/null
+++ b/print/ghostscript7-commfont/files/pkg-message.in
@@ -0,0 +1,13 @@
+=== NOTE ===
+
+The CJK font selection will be performed in the following order:
+
+ 1. %%PREFIX%%/%%GS_RESDIR%%/Font/<fontname>
+
+ 2. %%PREFIX%%/%%GS_RESDIR%%/CIDFont/<fontname>
+
+ 3. %%PREFIX%%/share/ghostscript/%%PORTVERSION%%/lib/CIDFnmap
+
+So, to use CIDFnmap you have to make sure that there is no font file that
+has the same name as you want to customize in Resource/Font and
+Resource/CIDFont.
diff --git a/print/ghostscript7-commfont/files/template.cidfont.in b/print/ghostscript7-commfont/files/template.cidfont.in
new file mode 100644
index 000000000000..5d9dab648773
--- /dev/null
+++ b/print/ghostscript7-commfont/files/template.cidfont.in
@@ -0,0 +1,10 @@
+%!PS-Adobe-3.0 Resource-CIDFont
+%%Creator: $FreeBSD$
+%%BeginResource: CIDFont (%%FONTNAME%%)
+
+(%%FONTNAME%%)
+(%%GENERICFONTNAME_SUBST%%) /CIDFont findresource
+/CIDFont defineresource pop
+
+%%EndResource
+%%EOF
diff --git a/print/ghostscript7-commfont/files/template.font.in b/print/ghostscript7-commfont/files/template.font.in
new file mode 100644
index 000000000000..56a68caec658
--- /dev/null
+++ b/print/ghostscript7-commfont/files/template.font.in
@@ -0,0 +1,12 @@
+%!PS-Adobe-3.0 Resource-Font
+%%Creator: $FreeBSD$
+%%DocumentNeededResources: %%CMAPNAME%% (CMap)
+%%IncludeResource: %%CMAPNAME%% (CMap)
+%%BeginResource: Font (%%FONTNAME%%-%%CMAPNAME%%)
+(%%FONTNAME%%-%%CMAPNAME%%)
+(%%CMAPNAME%%) /CMap findresource
+[(%%GENERICFONTNAME%%) /CIDFont findresource]
+composefont
+pop
+%%EndResource
+%%EOF
diff --git a/print/ghostscript7-commfont/files/template.ttcidfont.in b/print/ghostscript7-commfont/files/template.ttcidfont.in
new file mode 100644
index 000000000000..bc10770f819f
--- /dev/null
+++ b/print/ghostscript7-commfont/files/template.ttcidfont.in
@@ -0,0 +1,10 @@
+%!PS-Adobe-3.0 Resource-CIDFont
+%%Creator: $FreeBSD$
+%%BeginResource: CIDFont (%%FONTNAME%%)
+
+(%%FONTNAME%%)
+(%%GENERICFONTNAME_SUBST%%) findlibfile pop pop .openttcidfont
+/CIDFont defineresource pop
+
+%%EndResource
+%%EOF