aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript7-korfont/Makefile
diff options
context:
space:
mode:
authorYoshio MITA <mita@FreeBSD.org>2002-01-18 16:26:58 +0000
committerYoshio MITA <mita@FreeBSD.org>2002-01-18 16:26:58 +0000
commitdae085816354f5c6812fe17befe480763f05de15 (patch)
treec9c824887baa11c32458360a3d6f12cd5af14203 /print/ghostscript7-korfont/Makefile
parent2e16d6635aa20a1e196fc594db8326c4ea88388e (diff)
This port installs Korean resources used with print/ghostscript-gnu-cjk.
Notes
Notes: svn path=/head/; revision=53303
Diffstat (limited to 'print/ghostscript7-korfont/Makefile')
-rw-r--r--print/ghostscript7-korfont/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/print/ghostscript7-korfont/Makefile b/print/ghostscript7-korfont/Makefile
new file mode 100644
index 000000000000..d3c786f6d901
--- /dev/null
+++ b/print/ghostscript7-korfont/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: ghostscript
+# Date created: 14 Jan 2002
+# Whom: Mita Yoshio <mita@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ghostscript
+PORTVERSION= 6.52
+CATEGORIES= korean print
+MASTER_SITES= # nonexistent
+PKGNAMESUFFIX= -gnu-cjk
+DISTNAME= # nonexistent
+DISTFILES= # empty
+
+MAINTAINER= mita@FreeBSD.org
+
+RUN_DEPENDS= ${LOCALBASE}/share/ghostscript/Resource/cid.sh:${PORTSDIR}/print/ghostscript-gnu-cjk\
+ ${LOCALBASE}/share/ghostscript/fonts/Munhwa-Bold:${PORTSDIR}/korean/munhwafonts-cid
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+GSLIB_DIR= ${PREFIX}/share/ghostscript/${PORTVERSION}/lib
+PLIST_SUB= GS_VERSION=${PORTVERSION}
+FONTS= Munhwa-Bold Munhwa-Regular \
+ MunhwaGothic-Bold MunhwaGothic-Regular
+
+do-install:
+.for i in ${FONTS}
+ ${LN} -sf ${PREFIX}/share/ghostscript/fonts/${i} \
+ ${PREFIX}/share/ghostscript/Resource/CIDFont/
+.endfor
+ ${INSTALL_DATA} ${FILESDIR}/CIDFnmap.ko ${GSLIB_DIR}
+ ${MV} ${GSLIB_DIR}/CIDFnmap ${GSLIB_DIR}/CIDFnmap.orig.ko
+ ${GREP} -v -e "CIDFnmap.ko" ${GSLIB_DIR}/CIDFnmap.orig.ko > \
+ ${GSLIB_DIR}/CIDFnmap
+ ${ECHO} '(CIDFnmap.ko) .runlibfile' >> ${GSLIB_DIR}/CIDFnmap
+
+.include <bsd.port.mk>