aboutsummaryrefslogtreecommitdiff
path: root/print/ghostscript9/files
diff options
context:
space:
mode:
authorHiroki Sato <hrs@FreeBSD.org>2012-02-13 02:31:18 +0000
committerHiroki Sato <hrs@FreeBSD.org>2012-02-13 02:31:18 +0000
commite7399a84ee58f73b0017cb552b547882737460d3 (patch)
treed528be669048db1d57662e186cd2b2206e517423 /print/ghostscript9/files
parent7a938b802cc79b78464e84e3444111391237263a (diff)
downloadports-e7399a84ee58f73b0017cb552b547882737460d3.tar.gz
ports-e7399a84ee58f73b0017cb552b547882737460d3.zip
Notes
Diffstat (limited to 'print/ghostscript9/files')
-rw-r--r--print/ghostscript9/files/patch-base-Makefile.in11
-rw-r--r--print/ghostscript9/files/patch-base-openjpeg.mak11
-rw-r--r--print/ghostscript9/files/patch-openjpeg-libopenjpeg-opj_includes.h11
-rw-r--r--print/ghostscript9/files/patch-openjpeg-libopenjpeg-opj_malloc.h11
4 files changed, 43 insertions, 1 deletions
diff --git a/print/ghostscript9/files/patch-base-Makefile.in b/print/ghostscript9/files/patch-base-Makefile.in
index b276f1bd3f27..a191e8947e82 100644
--- a/print/ghostscript9/files/patch-base-Makefile.in
+++ b/print/ghostscript9/files/patch-base-Makefile.in
@@ -1,5 +1,5 @@
--- base/Makefile.in.orig 2012-02-08 17:48:48.000000000 +0900
-+++ base/Makefile.in 2012-02-13 00:28:00.000000000 +0900
++++ base/Makefile.in 2012-02-13 11:01:06.000000000 +0900
@@ -48,9 +48,8 @@
# the directories also define the default search path for the
# initialization files (gs_*.ps) and the fonts.
@@ -45,6 +45,15 @@
ZSRCDIR=@ZLIBDIR@
#ZLIB_NAME=gz
ZLIB_NAME=z
+@@ -250,7 +249,7 @@
+ JPX_LIB=@JPX_DECODER@
+ SHARE_JPX=@SHARE_JPX@
+ JPXSRCDIR=@JPXDIR@
+-JPX_CFLAGS=@JPX_AUTOCONF_CFLAGS@
++JPX_CFLAGS=@JPX_AUTOCONF_CFLAGS@ -ffast-math -DOPJ_STATIC -std=c99
+
+ # uncomment the following three lines and one of the last two to
+ # compile in the Luratech lwf_jp2 codec
@@ -330,7 +329,7 @@
# Define the added flags for standard, debugging, profiling
# and shared object builds.
diff --git a/print/ghostscript9/files/patch-base-openjpeg.mak b/print/ghostscript9/files/patch-base-openjpeg.mak
new file mode 100644
index 000000000000..f8d9bae3f8ab
--- /dev/null
+++ b/print/ghostscript9/files/patch-base-openjpeg.mak
@@ -0,0 +1,11 @@
+--- base/openjpeg.mak.orig 2012-02-13 10:49:36.000000000 +0900
++++ base/openjpeg.mak 2012-02-13 10:57:41.000000000 +0900
+@@ -101,7 +101,7 @@
+ $(SETMOD) $(OPEN_JPEG_GEN)openjpeg_0 $(open_jpeg_OBJS)
+
+ # define our specific compiler
+-OPEN_JPEG_CC=$(CC) $(CFLAGS) $(D_)OPJ_STATIC$(_D) $(I_)$(OPEN_JPEG_GEN)$(_I) $(I_)$(JPX_OPENJPEG_I_)$(_I) $(I_)$(JPX_OPENJPEG_I_)$(D)..$(_I) $(JPXCF_)
++OPEN_JPEG_CC=$(CC) $(JPX_CFLAGS) $(CFLAGS) $(D_)OPJ_STATIC$(_D) $(I_)$(OPEN_JPEG_GEN)$(_I) $(I_)$(JPX_OPENJPEG_I_)$(_I) $(I_)$(JPX_OPENJPEG_I_)$(D)..$(_I) $(JPXCF_)
+ OPEN_JPEG_O=$(O_)$(OPEN_JPEG_OBJ)$(OPEN_JPEG_PREFIX)
+
+ OPEN_JPEG_DEP=$(AK) $(OPEN_JPEG_MAK)
diff --git a/print/ghostscript9/files/patch-openjpeg-libopenjpeg-opj_includes.h b/print/ghostscript9/files/patch-openjpeg-libopenjpeg-opj_includes.h
new file mode 100644
index 000000000000..67591744852e
--- /dev/null
+++ b/print/ghostscript9/files/patch-openjpeg-libopenjpeg-opj_includes.h
@@ -0,0 +1,11 @@
+--- openjpeg/libopenjpeg/opj_includes.h.orig 2012-02-13 08:48:33.000000000 +0900
++++ openjpeg/libopenjpeg/opj_includes.h 2012-02-13 08:50:41.000000000 +0900
+@@ -77,7 +77,7 @@
+ #endif /* INLINE */
+
+ /* Are restricted pointers available? (C99) */
+-#if (__STDC_VERSION__ != 199901L)
++#if defined(__STDC_VERSION__) && (__STDC_VERSION__ != 199901L)
+ /* Not a C99 compiler */
+ #ifdef __GNUC__
+ #define restrict __restrict__
diff --git a/print/ghostscript9/files/patch-openjpeg-libopenjpeg-opj_malloc.h b/print/ghostscript9/files/patch-openjpeg-libopenjpeg-opj_malloc.h
new file mode 100644
index 000000000000..a2c27a03a799
--- /dev/null
+++ b/print/ghostscript9/files/patch-openjpeg-libopenjpeg-opj_malloc.h
@@ -0,0 +1,11 @@
+--- openjpeg/libopenjpeg/opj_malloc.h.orig 2012-02-08 17:48:48.000000000 +0900
++++ openjpeg/libopenjpeg/opj_malloc.h 2012-02-13 11:12:27.000000000 +0900
+@@ -83,6 +83,8 @@
+ #else /* Not _WIN32 */
+ #if defined(__sun)
+ #define HAVE_MEMALIGN
++ #elif defined(__FreeBSD__)
++ #undef HAVE_MEMALIGN
+ /* Linux x86_64 and OSX always align allocations to 16 bytes */
+ #elif !defined(__amd64__) && !defined(__APPLE__)
+ #define HAVE_MEMALIGN