aboutsummaryrefslogtreecommitdiff
path: root/print/gutenprint-base
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2011-10-17 00:11:10 +0000
committerPawel Pekala <pawel@FreeBSD.org>2011-10-17 00:11:10 +0000
commit1104d83d68a3cf0f6e165bcaedaf13b9b1f3bd5c (patch)
tree5220f2933fc26283c2e9a034f94afff02a8bca7a /print/gutenprint-base
parent01c66a73abf9d2017d07de6557937fb4611bfb7e (diff)
downloadports-1104d83d68a3cf0f6e165bcaedaf13b9b1f3bd5c.tar.gz
ports-1104d83d68a3cf0f6e165bcaedaf13b9b1f3bd5c.zip
Notes
Diffstat (limited to 'print/gutenprint-base')
-rw-r--r--print/gutenprint-base/Makefile18
-rw-r--r--print/gutenprint-base/distinfo4
-rw-r--r--print/gutenprint-base/files/patch-src_cups_commandtocanon.c10
-rw-r--r--print/gutenprint-base/files/patch-src_cups_commandtoepson.c10
-rw-r--r--print/gutenprint-base/files/patch-src_gimp2_Makefile.in8
-rw-r--r--print/gutenprint-base/pkg-plist28
6 files changed, 61 insertions, 17 deletions
diff --git a/print/gutenprint-base/Makefile b/print/gutenprint-base/Makefile
index 81286aea88cd..9da4d9e955a3 100644
--- a/print/gutenprint-base/Makefile
+++ b/print/gutenprint-base/Makefile
@@ -7,13 +7,12 @@
#
PORTNAME?= gutenprint
-PORTVERSION= 5.2.4
-PORTREVISION?= 2
+PORTVERSION= 5.2.7
CATEGORIES= print
MASTER_SITES= SF/gimp-print/gutenprint-5.2/${PORTVERSION}
PKGNAMESUFFIX?= -base
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= cmt@burggraben.net
COMMENT= GutenPrint Printer Driver
CONFLICTS= gimp-print-[0-9]*
@@ -39,13 +38,9 @@ GUTENPRINTUI2_LIBS=`${PKG_CONFIG} --libs gutenprintui2`
MAN1+= escputil.1
.endif
-.if defined(GUT_SLAVE) && (${GUT_SLAVE}=="gimp" || ${GUT_SLAVE}=="gimp-devel")
-.if ${GUT_SLAVE}=="gimp"
-LIB_DEPENDS+= gimp-2.0:${PORTSDIR}/graphics/gimp-app
-.elif ${GUT_SLAVE}=="gimp-devel"
-LIB_DEPENDS+= gimp-2.0:${PORTSDIR}/graphics/gimp-app-devel
-.endif
-LIB_DEPENDS+= gutenprint.2:${PORTSDIR}/print/gutenprint-base
+.if defined(GUT_SLAVE) && ${GUT_SLAVE}=="gimp"
+LIB_DEPENDS+= gimp-2.0:${PORTSDIR}/graphics/gimp-app \
+ gutenprint.2:${PORTSDIR}/print/gutenprint-base
CONFIGURE_ARGS=--with-gimp2=yes # Override CONFIGURE_ARGS
BUILD_WRKSRC= ${WRKSRC}/src/gimp2
INSTALL_WRKSRC= ${WRKSRC}/src/gimp2
@@ -54,7 +49,8 @@ CONFIGURE_ARGS+=--without-gimp2
.endif
.if defined(GUT_SLAVE) && ${GUT_SLAVE}=="cups"
-LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client
+LIB_DEPENDS+= cups.2:${PORTSDIR}/print/cups-client \
+ cupsimage.2:${PORTSDIR}/print/cups-image
RUN_DEPENDS+= espgs:${PORTSDIR}/print/cups-pstoraster
CONFIGURE_ARGS+= --with-cups=${PREFIX} \
--enable-cups-ppds \
diff --git a/print/gutenprint-base/distinfo b/print/gutenprint-base/distinfo
index c1717f1b2284..9dcfef243805 100644
--- a/print/gutenprint-base/distinfo
+++ b/print/gutenprint-base/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gutenprint-5.2.4.tar.bz2) = b610e86305efbb98696af20366696f06ea40a7b030b45f21a83a142892ab9626
-SIZE (gutenprint-5.2.4.tar.bz2) = 5119559
+SHA256 (gutenprint-5.2.7.tar.bz2) = 114c899227e3ebb0753c1db503e6a5c1afaa4b1f1235fdfe02fb6bbd533beed1
+SIZE (gutenprint-5.2.7.tar.bz2) = 5498414
diff --git a/print/gutenprint-base/files/patch-src_cups_commandtocanon.c b/print/gutenprint-base/files/patch-src_cups_commandtocanon.c
new file mode 100644
index 000000000000..a19eb11a5f70
--- /dev/null
+++ b/print/gutenprint-base/files/patch-src_cups_commandtocanon.c
@@ -0,0 +1,10 @@
+--- src/cups/commandtocanon.c.orig 2011-10-15 13:27:57.000000000 +0200
++++ src/cups/commandtocanon.c 2011-10-15 13:28:22.000000000 +0200
+@@ -13,6 +13,7 @@
+
+ #include <cups/cups.h>
+ #include <ctype.h>
++#include <stdio.h>
+ #include <stdlib.h>
+
+
diff --git a/print/gutenprint-base/files/patch-src_cups_commandtoepson.c b/print/gutenprint-base/files/patch-src_cups_commandtoepson.c
new file mode 100644
index 000000000000..c691f0f8bb75
--- /dev/null
+++ b/print/gutenprint-base/files/patch-src_cups_commandtoepson.c
@@ -0,0 +1,10 @@
+--- src/cups/commandtoepson.c.orig 2011-10-15 13:20:46.000000000 +0200
++++ src/cups/commandtoepson.c 2011-10-15 13:20:57.000000000 +0200
+@@ -30,6 +30,7 @@
+
+ #include <cups/cups.h>
+ #include <ctype.h>
++#include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+
diff --git a/print/gutenprint-base/files/patch-src_gimp2_Makefile.in b/print/gutenprint-base/files/patch-src_gimp2_Makefile.in
index 916ca38a6ff1..a2fdf1a37469 100644
--- a/print/gutenprint-base/files/patch-src_gimp2_Makefile.in
+++ b/print/gutenprint-base/files/patch-src_gimp2_Makefile.in
@@ -1,13 +1,13 @@
---- src/gimp2/Makefile.in.orig 2008-02-29 09:47:54.000000000 -0500
-+++ src/gimp2/Makefile.in 2008-02-29 09:48:44.000000000 -0500
-@@ -291,8 +291,8 @@
+--- src/gimp2/Makefile.in.orig 2011-10-15 12:53:29.000000000 +0200
++++ src/gimp2/Makefile.in 2011-10-15 12:54:02.000000000 +0200
+@@ -306,8 +306,8 @@
print_gimp.h
print_SOURCES = $(COMMON_PRINT_SOURCES) print-print.c
-print_LDADD = $(GIMP2_LIBS) $(GUTENPRINTUI2_LIBS)
-print_DEPENDENCIES = $(GUTENPRINTUI2_LIBS) $(GUTENPRINT_LIBS)
+print_LDADD = $(GIMP2_LIBS) %%GUTENPRINTUI2_LIBS%%
-+print_DEPENDENCIES =
++print_DEPENDENCIES =
gutenprint_SOURCES = $(COMMON_PRINT_SOURCES) print-gutenprint.c
gutenprint_LDADD = $(print_LDADD)
gutenprint_DEPENDENCIES = $(print_DEPENDENCIES)
diff --git a/print/gutenprint-base/pkg-plist b/print/gutenprint-base/pkg-plist
index c314ca7c463c..b977ccdfae76 100644
--- a/print/gutenprint-base/pkg-plist
+++ b/print/gutenprint-base/pkg-plist
@@ -58,6 +58,7 @@ libdata/pkgconfig/gutenprintui2.pc
%%DATADIR%%/5.2/xml/escp2/inks/f360_ultrachrome.xml
%%DATADIR%%/5.2/xml/escp2/inks/f360_ultrachrome_k3.xml
%%DATADIR%%/5.2/xml/escp2/inks/f360_ultrachrome_k3v.xml
+%%DATADIR%%/5.2/xml/escp2/inks/f360_ultrachrome_k3v_2.xml
%%DATADIR%%/5.2/xml/escp2/inks/nx100.xml
%%DATADIR%%/5.2/xml/escp2/inks/photo_gen0.xml
%%DATADIR%%/5.2/xml/escp2/inks/photo_gen1.xml
@@ -73,6 +74,9 @@ libdata/pkgconfig/gutenprintui2.pc
%%DATADIR%%/5.2/xml/escp2/inks/pro_pigment.xml
%%DATADIR%%/5.2/xml/escp2/inks/pro_ultrachrome.xml
%%DATADIR%%/5.2/xml/escp2/inks/pro_ultrachrome_k3.xml
+%%DATADIR%%/5.2/xml/escp2/inks/pro_ultrachrome_k34.xml
+%%DATADIR%%/5.2/xml/escp2/inks/pro_ultrachrome_k3v.xml
+%%DATADIR%%/5.2/xml/escp2/inks/pro_ultrachrome_k3v4.xml
%%DATADIR%%/5.2/xml/escp2/inks/standard.xml
%%DATADIR%%/5.2/xml/escp2/inks/standard_gen0.xml
%%DATADIR%%/5.2/xml/escp2/inks/ultrachrome.xml
@@ -81,10 +85,13 @@ libdata/pkgconfig/gutenprintui2.pc
%%DATADIR%%/5.2/xml/escp2/inks/x80.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/artisan.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/b500.xml
+%%DATADIR%%/5.2/xml/escp2/inputslots/cd.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/cd_cutter_roll_feed.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/cd_roll_feed.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/cutter_roll_feed.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/default.xml
+%%DATADIR%%/5.2/xml/escp2/inputslots/pro3880.xml
+%%DATADIR%%/5.2/xml/escp2/inputslots/pro_cutter_roll_feed.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/pro_roll_feed.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/r1800.xml
%%DATADIR%%/5.2/xml/escp2/inputslots/r2400.xml
@@ -121,11 +128,13 @@ libdata/pkgconfig/gutenprintui2.pc
%%DATADIR%%/5.2/xml/escp2/media/photo_pigment.xml
%%DATADIR%%/5.2/xml/escp2/media/picturemate_4.xml
%%DATADIR%%/5.2/xml/escp2/media/picturemate_6.xml
+%%DATADIR%%/5.2/xml/escp2/media/pro3880_ultrachrome_k3v.xml
%%DATADIR%%/5.2/xml/escp2/media/pro_gen1.xml
%%DATADIR%%/5.2/xml/escp2/media/pro_gen2.xml
%%DATADIR%%/5.2/xml/escp2/media/pro_pigment.xml
%%DATADIR%%/5.2/xml/escp2/media/pro_ultrachrome.xml
%%DATADIR%%/5.2/xml/escp2/media/pro_ultrachrome_k3.xml
+%%DATADIR%%/5.2/xml/escp2/media/pro_ultrachrome_k3v.xml
%%DATADIR%%/5.2/xml/escp2/media/r800.xml
%%DATADIR%%/5.2/xml/escp2/media/standard.xml
%%DATADIR%%/5.2/xml/escp2/media/standard_gen0.xml
@@ -136,7 +145,23 @@ libdata/pkgconfig/gutenprintui2.pc
%%DATADIR%%/5.2/xml/escp2/model/model_0.xml
%%DATADIR%%/5.2/xml/escp2/model/model_1.xml
%%DATADIR%%/5.2/xml/escp2/model/model_10.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_100.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_101.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_102.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_103.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_104.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_105.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_106.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_107.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_108.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_109.xml
%%DATADIR%%/5.2/xml/escp2/model/model_11.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_110.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_111.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_112.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_113.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_114.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_115.xml
%%DATADIR%%/5.2/xml/escp2/model/model_12.xml
%%DATADIR%%/5.2/xml/escp2/model/model_13.xml
%%DATADIR%%/5.2/xml/escp2/model/model_14.xml
@@ -232,6 +257,7 @@ libdata/pkgconfig/gutenprintui2.pc
%%DATADIR%%/5.2/xml/escp2/model/model_96.xml
%%DATADIR%%/5.2/xml/escp2/model/model_97.xml
%%DATADIR%%/5.2/xml/escp2/model/model_98.xml
+%%DATADIR%%/5.2/xml/escp2/model/model_99.xml
%%DATADIR%%/5.2/xml/escp2/qualitypresets/p1_5.xml
%%DATADIR%%/5.2/xml/escp2/qualitypresets/picturemate.xml
%%DATADIR%%/5.2/xml/escp2/qualitypresets/standard.xml
@@ -282,6 +308,7 @@ share/locale/de/LC_MESSAGES/gutenprint.mo
share/locale/el/LC_MESSAGES/gutenprint.mo
share/locale/en_GB/LC_MESSAGES/gutenprint.mo
share/locale/es/LC_MESSAGES/gutenprint.mo
+share/locale/fi/LC_MESSAGES/gutenprint.mo
share/locale/fr/LC_MESSAGES/gutenprint.mo
share/locale/hu/LC_MESSAGES/gutenprint.mo
share/locale/it/LC_MESSAGES/gutenprint.mo
@@ -292,6 +319,7 @@ share/locale/pl/LC_MESSAGES/gutenprint.mo
share/locale/pt/LC_MESSAGES/gutenprint.mo
share/locale/ru/LC_MESSAGES/gutenprint.mo
share/locale/sk/LC_MESSAGES/gutenprint.mo
+share/locale/sl/LC_MESSAGES/gutenprint.mo
share/locale/sv/LC_MESSAGES/gutenprint.mo
share/locale/zh_TW/LC_MESSAGES/gutenprint.mo
@dirrm %%DATADIR%%/samples