aboutsummaryrefslogtreecommitdiff
path: root/print/gv
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-10-18 09:43:46 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-10-18 09:43:46 +0000
commit85c0c0cc4502bff8b1b4f8bb2676b96ab949387c (patch)
tree26cf0b30dc3469b6e05d8a1343329a2ab92a213a /print/gv
parentbd8fa13576ed22e4caf7aadb5a4e69d700900742 (diff)
downloadports-85c0c0cc4502bff8b1b4f8bb2676b96ab949387c.tar.gz
ports-85c0c0cc4502bff8b1b4f8bb2676b96ab949387c.zip
Notes
Diffstat (limited to 'print/gv')
-rw-r--r--print/gv/Makefile7
-rw-r--r--print/gv/distinfo1
-rw-r--r--print/gv/files/patch-aa15
-rw-r--r--print/gv/files/patch-source::secscanf.c36
4 files changed, 51 insertions, 8 deletions
diff --git a/print/gv/Makefile b/print/gv/Makefile
index 75cbe2851299..b7f631314c79 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -8,17 +8,20 @@
PORTNAME= gv
PORTVERSION= 3.5.8
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ftp://ftpthep.physik.uni-mainz.de/pub/gv/unix/ \
${MASTER_SITE_TEX_CTAN}
MASTER_SITE_SUBDIR= support/ghostscript/gnu/gv/unix
+PATCHFILES= gv_3.5.8-17.1.diff.gz
+PATCH_SITES= http://security.debian.org/pool/updates/main/g/gv/
+PATCH_DIST_STRIP= -p1
+
MAINTAINER= ports@freebsd.org
LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
-FORBIDDEN= "Security vulnerability, see bugtraq id 5808"
-
USE_IMAKE= yes
MAN1= gv.1
diff --git a/print/gv/distinfo b/print/gv/distinfo
index 1504e0a7a068..1d9b308432a4 100644
--- a/print/gv/distinfo
+++ b/print/gv/distinfo
@@ -1 +1,2 @@
MD5 (gv-3.5.8.tar.gz) = 8f2f0bd97395d6cea52926ddee736da8
+MD5 (gv_3.5.8-17.1.diff.gz) = 2e9e7149b69bf36a80632c8b695b6495
diff --git a/print/gv/files/patch-aa b/print/gv/files/patch-aa
index 101a0a668d89..a0cd7830b51c 100644
--- a/print/gv/files/patch-aa
+++ b/print/gv/files/patch-aa
@@ -1,13 +1,16 @@
---- config.Unix.orig Sat Jun 7 07:00:00 1997
-+++ config.Unix Wed Feb 21 06:47:59 2001
+
+$FreeBSD$
+
+--- config.Unix.orig Fri Oct 18 11:54:17 2002
++++ config.Unix Fri Oct 18 11:55:45 2002
@@ -32,10 +32,10 @@
XCOMM --------------------------------------------------------------------
XCOMM Destination directories.
XCOMM --------------------------------------------------------------------
-- GV_BINDIR = /usr/local/bin/
-- GV_DOCDIR = /usr/local/doc/gv/
-- GV_LIBDIR = /usr/local/lib/gv/
-- GV_MANDIR = /usr/local/man/man1/
+- GV_BINDIR = /usr/X11R6/bin/
+- GV_DOCDIR = /usr/share/doc/gv/
+- GV_LIBDIR = /usr/X11R6/lib/X11/gv/
+- GV_MANDIR = /usr/X11R6/man/man1/
+ GV_BINDIR = $(BINDIR)
+ GV_DOCDIR = $(PREFIX)/share/doc/gv/
+ GV_LIBDIR = $(LIBDIR)/gv/
diff --git a/print/gv/files/patch-source::secscanf.c b/print/gv/files/patch-source::secscanf.c
new file mode 100644
index 000000000000..6d80c865482b
--- /dev/null
+++ b/print/gv/files/patch-source::secscanf.c
@@ -0,0 +1,36 @@
+
+$FreeBSD$
+
+--- source/secscanf.c 2002/10/18 09:04:10 1.1
++++ source/secscanf.c 2002/10/18 09:12:07
+@@ -45,6 +45,21 @@
+ static int process_number(union scan_value *vp, const char **sp, char fmt);
+ static int process_char_class(const char **, const char **, int);
+
++#if __FreeBSD__
++static char *
++strndup(const char *src, size_t size)
++{
++ char *dst;
++
++ dst = malloc(size + 1);
++ if (dst == NULL)
++ return (NULL);
++ dst[size] = '\0';
++ strncpy(dst, src, size);
++ return (dst);
++}
++#endif
++
+ static inline int
+ set_conv_type(int *type, int new_type)
+ {
+@@ -347,7 +362,7 @@
+ case 'g':
+ case 'e':
+ case 'E':
+- vp->v_double = strtold(s, (char **) sp);
++ vp->v_double = strtod(s, (char **) sp);
+ break;
+ default:
+ return 0;