aboutsummaryrefslogtreecommitdiff
path: root/print/hplip-plugin
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2016-04-24 19:39:34 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2016-04-24 19:39:34 +0000
commitbf12e6ae92c4f15b595c5b2c2d12e88ef0f40722 (patch)
treef25e2ac77f1a8d8bc1a5aaa06de5b1e9f350140c /print/hplip-plugin
parent5bc688d3c8b38917f64ce2fab63f5ddfc1389a59 (diff)
downloadports-bf12e6ae92c4f15b595c5b2c2d12e88ef0f40722.tar.gz
ports-bf12e6ae92c4f15b595c5b2c2d12e88ef0f40722.zip
Notes
Diffstat (limited to 'print/hplip-plugin')
-rw-r--r--print/hplip-plugin/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/print/hplip-plugin/Makefile b/print/hplip-plugin/Makefile
index 73ef6e521d5c..61d4b852b924 100644
--- a/print/hplip-plugin/Makefile
+++ b/print/hplip-plugin/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hplip-plugin
PORTVERSION= 3.16.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= http://hplipopensource.com/hplip-web/plugin/
DISTNAME= hplip-${DISTVERSION}-plugin
@@ -33,7 +33,7 @@ PLUGINS= fax/plugins/fax_marvell \
PLIST_SUB+= LINARCH="${LINARCH}"
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} == "i386"
LINARCH= x86_32
@@ -59,9 +59,10 @@ do-install:
${STAGEDIR}${PREFIX}/share/hplip/data/firmware
${MKDIR} ${PLUGINS:H:S,^,${STAGEDIR}${PREFIX}/share/hplip/,}
.for p in ${PLUGINS}
- ${INSTALL_LIB} ${WRKSRC}/${p:T}-${LINARCH}.so \
+# -m 555 because HPLIP checks that the plugins are +x.
+ ${INSTALL_LIB} -m 555 ${WRKSRC}/${p:T}-${LINARCH}.so \
${STAGEDIR}${PREFIX}/share/hplip/${p}-${LINARCH}.so
- ${INSTALL_LIB} ${WRKSRC}/${p:T}.so \
+ ${INSTALL_LIB} -m 555 ${WRKSRC}/${p:T}.so \
${STAGEDIR}${PREFIX}/share/hplip/${p}.so
.endfor
${INSTALL_DATA} ${WRKSRC}/plugin.spec ${STAGEDIR}${PREFIX}/share/hplip
@@ -71,4 +72,4 @@ do-install:
${ECHO_CMD} 'eula = 1' >> ${STAGEDIR}/var/lib/hp/hplip.state
${ECHO_CMD} 'version = ${PORTVERSION}' >> ${STAGEDIR}/var/lib/hp/hplip.state
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>