aboutsummaryrefslogtreecommitdiff
path: root/print/hplip
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2020-09-07 14:55:54 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2020-09-07 14:55:54 +0000
commitb531a27b610e024bc94d4f03aa0ca61e3317acea (patch)
treeeb977bfa5eee9f2244cc21d3e803b16f9f34ef82 /print/hplip
parentd214508875b66f3d8f7fbd2059a82193e2b0a424 (diff)
Notes
Diffstat (limited to 'print/hplip')
-rw-r--r--print/hplip/Makefile13
1 files changed, 10 insertions, 3 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index e42bf6e03186..838228b5dc38 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -21,8 +21,7 @@ RUN_DEPENDS= cups-filters>=0:print/cups-filters \
CONFLICTS_INSTALL= hpijs-[0-9]*
INSTALL_TARGET= install-strip
-USES= dos2unix gnome jpeg libtool pkgconfig python shebangfix
-USE_GNOME= pygobject3
+USES= dos2unix jpeg libtool pkgconfig python shebangfix
USE_LDCONFIG= yes
SHEBANG_GLOB= *.py hpps pstotiff
DOS2UNIX_FILES= scan/sane/orblite.c
@@ -70,6 +69,14 @@ XSANE_DESC= Install XSane for scanning (implies SCAN)
XSANE_IMPLIES= SCAN
XSANE_RUN_DEPENDS= xsane:graphics/xsane
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_MAJOR_VER} >= 3
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gobject3>=0:devel/py-gobject3@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}gobject>=0:devel/py-gobject@${PY_FLAVOR}
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-ldld||g;' \
-e 's|-ldl||g' \
@@ -131,4 +138,4 @@ post-install-SCAN-on:
${MV} ${STAGEDIR}${PREFIX}/etc/sane.d/dll.conf \
${STAGEDIR}${PREFIX}/etc/sane.d/dll.d/hpaio
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>